summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-25 07:51:51 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-25 07:51:51 +0000
commit2325e51a991da13f2b5d73ab7a1a08c0131b4517 (patch)
treee252f9cb860c29364589f15ecd4bb811f1a56913 /net-ftp
parentAdd a revdep-rebuild warning, bug #159045 (diff)
downloadgentoo-2-2325e51a991da13f2b5d73ab7a1a08c0131b4517.tar.gz
gentoo-2-2325e51a991da13f2b5d73ab7a1a08c0131b4517.tar.bz2
gentoo-2-2325e51a991da13f2b5d73ab7a1a08c0131b4517.zip
Version bump and fix building in parallel.
(Portage version: 2.1.2_rc3-r9)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/tftp-hpa/ChangeLog8
-rw-r--r--net-ftp/tftp-hpa/files/digest-tftp-hpa-0.453
-rw-r--r--net-ftp/tftp-hpa/files/tftp-hpa-0.45-parallel.patch13
-rw-r--r--net-ftp/tftp-hpa/tftp-hpa-0.45.ebuild51
4 files changed, 74 insertions, 1 deletions
diff --git a/net-ftp/tftp-hpa/ChangeLog b/net-ftp/tftp-hpa/ChangeLog
index 3a8fc0ce5542..e04d9673e676 100644
--- a/net-ftp/tftp-hpa/ChangeLog
+++ b/net-ftp/tftp-hpa/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/tftp-hpa
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/tftp-hpa/ChangeLog,v 1.21 2006/12/13 22:57:03 masterdriverz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/tftp-hpa/ChangeLog,v 1.22 2006/12/25 07:51:51 vapier Exp $
+
+*tftp-hpa-0.45 (25 Dec 2006)
+
+ 25 Dec 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/tftp-hpa-0.45-parallel.patch, +tftp-hpa-0.45.ebuild:
+ Version bump and fix building in parallel.
*tftp-hpa-0.44 (13 Dec 2006)
diff --git a/net-ftp/tftp-hpa/files/digest-tftp-hpa-0.45 b/net-ftp/tftp-hpa/files/digest-tftp-hpa-0.45
new file mode 100644
index 000000000000..4a8fecd7ecf9
--- /dev/null
+++ b/net-ftp/tftp-hpa/files/digest-tftp-hpa-0.45
@@ -0,0 +1,3 @@
+MD5 85f01fbb676bb9d56a47d02209c9995d tftp-hpa-0.45.tar.bz2 83335
+RMD160 2ad15d451501443f47c4f72f7dbf4d9fe96396eb tftp-hpa-0.45.tar.bz2 83335
+SHA256 8ccad375ab1444bd4685947f5763e88eae09cc924c4bf3220f6686e9f7b27edd tftp-hpa-0.45.tar.bz2 83335
diff --git a/net-ftp/tftp-hpa/files/tftp-hpa-0.45-parallel.patch b/net-ftp/tftp-hpa/files/tftp-hpa-0.45-parallel.patch
new file mode 100644
index 000000000000..5cda045e5eb5
--- /dev/null
+++ b/net-ftp/tftp-hpa/files/tftp-hpa-0.45-parallel.patch
@@ -0,0 +1,13 @@
+--- Makefile
++++ Makefile
+@@ -17,8 +17,8 @@
+
+ all: MCONFIG $(patsubst %, %.build, $(SUB))
+
+-tftp.build: lib.build
+-tftpd.build: lib.build
++tftp.build: lib.build common.build
++tftpd.build: lib.build common.build
+
+ install: MCONFIG $(patsubst %, %.install, $(SUB))
+
diff --git a/net-ftp/tftp-hpa/tftp-hpa-0.45.ebuild b/net-ftp/tftp-hpa/tftp-hpa-0.45.ebuild
new file mode 100644
index 000000000000..abcca51a377b
--- /dev/null
+++ b/net-ftp/tftp-hpa/tftp-hpa-0.45.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/tftp-hpa/tftp-hpa-0.45.ebuild,v 1.1 2006/12/25 07:51:51 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="port of the OpenBSD TFTP server"
+HOMEPAGE="http://www.kernel.org/pub/software/network/tftp/"
+SRC_URI="mirror://kernel/software/network/tftp/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="readline selinux tcpd"
+
+DEPEND="readline? ( sys-libs/readline )
+ tcpd? ( sys-apps/tcp-wrappers )
+ selinux? ( sec-policy/selinux-tftpd )
+ !virtual/tftp"
+PROVIDE="virtual/tftp"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-parallel.patch
+}
+
+src_compile() {
+ econf \
+ $(use_with tcpd tcpwrappers) \
+ $(use_with readline) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake INSTALLROOT="${D}" install || die
+ dodoc README* CHANGES tftpd/sample.rules
+
+ # iputils installs this
+ rm -f "${D}"/usr/share/man/man8/tftpd.8
+
+ newconfd "${FILESDIR}"/in.tftpd.confd-${PV} in.tftpd
+ newinitd "${FILESDIR}"/in.tftpd.rc6 in.tftpd
+}
+
+pkg_postinst() {
+ ewarn "After installation, please ensure you look at"
+ ewarn "/etc/conf.d/in.tftpd and set the correct path"
+ ewarn "for your application."
+}