summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2005-09-06 22:39:09 +0000
committerGustavo Felisberto <humpback@gentoo.org>2005-09-06 22:39:09 +0000
commitcb13bcaf95b531ff8b21b11aa8f3532d4aa601c9 (patch)
tree9a6d0d4a91e6bb37b674878d044ffb13417e9f3f /net-ftp/pureadmin
parentMove patches to a patchset. Add fixes from Debian, support for lossless crop... (diff)
downloadgentoo-2-cb13bcaf95b531ff8b21b11aa8f3532d4aa601c9.tar.gz
gentoo-2-cb13bcaf95b531ff8b21b11aa8f3532d4aa601c9.tar.bz2
gentoo-2-cb13bcaf95b531ff8b21b11aa8f3532d4aa601c9.zip
bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-ftp/pureadmin')
-rw-r--r--net-ftp/pureadmin/ChangeLog10
-rw-r--r--net-ftp/pureadmin/Manifest16
-rw-r--r--net-ftp/pureadmin/files/digest-pureadmin-0.2.21
-rw-r--r--net-ftp/pureadmin/pureadmin-0.2.2.ebuild51
4 files changed, 64 insertions, 14 deletions
diff --git a/net-ftp/pureadmin/ChangeLog b/net-ftp/pureadmin/ChangeLog
index cde9711e6c8b..bb745bf70714 100644
--- a/net-ftp/pureadmin/ChangeLog
+++ b/net-ftp/pureadmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/pureadmin
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/ChangeLog,v 1.6 2004/09/17 23:12:48 humpback Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/ChangeLog,v 1.7 2005/09/06 22:39:09 humpback Exp $
+
+*pureadmin-0.2.2 (06 Sep 2005)
+
+ 06 Sep 2005; Gustavo Felisberto <humpback@gentoo.org>;
+ +pureadmin-0.2.2.ebuild:
+ Bump and small cosmetic. Closes 2 or 3 bugs in portage.
*pureadmin-0.1.11 (18 Sep 2004)
diff --git a/net-ftp/pureadmin/Manifest b/net-ftp/pureadmin/Manifest
index 2ac0bfebee9f..0861f9caf4f1 100644
--- a/net-ftp/pureadmin/Manifest
+++ b/net-ftp/pureadmin/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 410e8cbf35e8ba297ff5c4cad56e37ed pureadmin-0.1.11.ebuild 1452
+MD5 410e8cbf35e8ba297ff5c4cad56e37ed pureadmin-0.2.2.ebuild 1452
+MD5 02aff17b9bd325da310c2f92772bd940 pureadmin-0.1.10.ebuild 1447
MD5 4926bfd77c8d00434c21c3d667bb7b87 ChangeLog 987
MD5 0c3c3bfe13b2bc8bbd31bb3754f330b1 metadata.xml 331
-MD5 02aff17b9bd325da310c2f92772bd940 pureadmin-0.1.10.ebuild 1447
-MD5 410e8cbf35e8ba297ff5c4cad56e37ed pureadmin-0.1.11.ebuild 1452
MD5 be1c1c77d4ffc790654176a4eabe1e8d files/digest-pureadmin-0.1.10 68
MD5 eb252f7f2582e68e667dc969c5bfe5d8 files/digest-pureadmin-0.1.11 68
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.4 (GNU/Linux)
-
-iD8DBQFBS2/JKSoOBZY9iUIRAj4QAJ9/hBunwpqAZF66r072j9+VBr/MwACeMk09
-woAhT/VOlz++Qd6dGCIKLn8=
-=Jk/k
------END PGP SIGNATURE-----
+MD5 d2555c260ca574d57c4d14dbbf4f29d4 files/digest-pureadmin-0.2.2 67
diff --git a/net-ftp/pureadmin/files/digest-pureadmin-0.2.2 b/net-ftp/pureadmin/files/digest-pureadmin-0.2.2
new file mode 100644
index 000000000000..4c74d787ea2a
--- /dev/null
+++ b/net-ftp/pureadmin/files/digest-pureadmin-0.2.2
@@ -0,0 +1 @@
+MD5 7549ae9278b2dd629058848c86859b4e pureadmin-0.2.2.tar.gz 274465
diff --git a/net-ftp/pureadmin/pureadmin-0.2.2.ebuild b/net-ftp/pureadmin/pureadmin-0.2.2.ebuild
new file mode 100644
index 000000000000..678f733cb8b3
--- /dev/null
+++ b/net-ftp/pureadmin/pureadmin-0.2.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.2.2.ebuild,v 1.1 2005/09/06 22:39:09 humpback Exp $
+
+inherit eutils
+IUSE="debug gnome doc"
+
+DESCRIPTION="PureAdmin is a GUI tool used to make the management of PureFTPd a little easier."
+HOMEPAGE="http://purify.sourceforge.net"
+SRC_URI="mirror://sourceforge/purify/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ~ppc"
+
+DEPEND="sys-libs/glibc
+ sys-libs/zlib
+ >=x11-libs/gtk+-2.0"
+
+src_compile() {
+ local myconf=""
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ # Move the docs to the correct location
+ if use doc; then
+ dodoc ${D}usr/share/doc/pureadmin/*.txt
+ rm -rf ${D}usr/share/doc/pureadmin
+ fi
+
+ make_desktop_entry pureadmin "Pure-ftp menu config" pureadmin
+}
+
+pkg_postinst() {
+ echo
+ ewarn "PureAdmin is at an alpha-stage right now and it may break"
+ ewarn "your configuration. DO NOT use it for safety critical system"
+ ewarn "or production use!"
+ echo
+ einfo "You need root-privileges to be able to use PureAdmin as for now."
+ einfo "This will probably change in the future."
+ echo
+}