summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-02-24 22:00:45 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-02-24 22:00:45 +0000
commit934652fcf9eaf47625292de3155c2b57c30060cb (patch)
tree2696101cfc58fa9460aa0ecc091d31bb28e7ac24 /net-ftp/proftpd
parentLPK patch updated for new OpenSSH release. (diff)
downloadgentoo-2-934652fcf9eaf47625292de3155c2b57c30060cb.tar.gz
gentoo-2-934652fcf9eaf47625292de3155c2b57c30060cb.tar.bz2
gentoo-2-934652fcf9eaf47625292de3155c2b57c30060cb.zip
Add kerberos support, thanks to Martin Mokrejš in bug #134922. Add patch to use system libltdl for the dynamic loader (needed for this new module)
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp/proftpd')
-rw-r--r--net-ftp/proftpd/ChangeLog7
-rw-r--r--net-ftp/proftpd/files/proftpd-1.3.2-system-libltdl.patch55
-rw-r--r--net-ftp/proftpd/proftpd-1.3.2-r2.ebuild33
3 files changed, 91 insertions, 4 deletions
diff --git a/net-ftp/proftpd/ChangeLog b/net-ftp/proftpd/ChangeLog
index 6d8fe2b3f3f0..eea2e60da484 100644
--- a/net-ftp/proftpd/ChangeLog
+++ b/net-ftp/proftpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/proftpd
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.195 2009/02/23 14:00:07 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.196 2009/02/24 22:00:44 voyageur Exp $
+
+ 24 Feb 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +files/proftpd-1.3.2-system-libltdl.patch, proftpd-1.3.2-r2.ebuild:
+ Add kerberos support, thanks to Martin Mokrejš in bug #134922. Add patch
+ to use system libltdl for the dynamic loader (needed for this new module)
*proftpd-1.3.2-r2 (23 Feb 2009)
diff --git a/net-ftp/proftpd/files/proftpd-1.3.2-system-libltdl.patch b/net-ftp/proftpd/files/proftpd-1.3.2-system-libltdl.patch
new file mode 100644
index 000000000000..5a1c175ef4ec
--- /dev/null
+++ b/net-ftp/proftpd/files/proftpd-1.3.2-system-libltdl.patch
@@ -0,0 +1,55 @@
+--- configure.in.orig 2009-02-24 21:58:08.000000000 +0100
++++ configure.in 2009-02-24 22:21:20.000000000 +0100
+@@ -54,8 +54,8 @@
+
+ dnl AC_PROG_LIBTOOL relies on this variable
+ top_builddir=.
+-AC_LIBTOOL_DLOPEN([lib/libltdl])
+-AC_LIBLTDL_CONVENIENCE([lib/libltdl])
++AC_LIBTOOL_DLOPEN
++AC_WITH_LTDL
+
+ dnl Checks for programs.
+ AC_PROG_CC
+@@ -485,18 +485,12 @@
+ ac_core_modules="$ac_core_modules mod_dso.o"
+ ac_build_core_modules="$ac_build_core_modules modules/mod_dso.o"
+
+- MAIN_LDFLAGS="-L\$(top_srcdir)/lib/libltdl -dlopen self -export-dynamic"
++ MAIN_LDFLAGS="-dlopen self -export-dynamic"
+ MAIN_LIBS="\$(LIBLTDL)"
+
+ MODULE_LDFLAGS="-avoid-version -export-dynamic -module"
+
+- INSTALL_DEPS="install-libltdl"
+- LIB_DEPS="libltdl"
+- MODULE_DEPS="libltdl"
+ AC_DEFINE(PR_USE_DSO, 1, [Define if using DSO support.])
+-
+- dnl Run configure scripts in subdirectories
+- AC_CONFIG_SUBDIRS(lib/libltdl)
+ fi
+ ])
+
+--- modules/Makefile.in.orig 2009-02-24 22:34:00.000000000 +0100
++++ modules/Makefile.in 2009-02-24 22:34:13.000000000 +0100
+@@ -229,7 +229,6 @@
+ mod_dso.o: ../include/trace.h ../include/encode.h ../include/compat.h
+ mod_dso.o: ../include/proctitle.h ../include/pidfile.h ../include/env.h
+ mod_dso.o: ../include/pr-syslog.h ../include/mod_ctrls.h
+-mod_dso.o: ../lib/libltdl/ltdl.h
+ mod_facl.o: ../include/conf.h ../include/version.h ../config.h
+ mod_facl.o: ../include/default_paths.h ../include/options.h ../include/pool.h
+ mod_facl.o: ../include/str.h ../include/regexp.h ../include/table.h
+--- modules/mod_dso.c.orig 2009-02-24 22:32:50.000000000 +0100
++++ modules/mod_dso.c 2009-02-24 22:33:03.000000000 +0100
+@@ -31,8 +31,7 @@
+ #include "conf.h"
+ #include "mod_ctrls.h"
+
+-/* Make sure we use the libltdl shipped with proftpd, not the system libltdl. */
+-#include "lib/libltdl/ltdl.h"
++#include <ltdl.h>
+
+ #define MOD_DSO_VERSION "mod_dso/0.4"
+
diff --git a/net-ftp/proftpd/proftpd-1.3.2-r2.ebuild b/net-ftp/proftpd/proftpd-1.3.2-r2.ebuild
index f5644dcd68f4..d8ab0fcd3fd2 100644
--- a/net-ftp/proftpd/proftpd-1.3.2-r2.ebuild
+++ b/net-ftp/proftpd/proftpd-1.3.2-r2.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.3.2-r2.ebuild,v 1.1 2009/02/23 14:00:07 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.3.2-r2.ebuild,v 1.2 2009/02/24 22:00:44 voyageur Exp $
inherit eutils flag-o-matic toolchain-funcs autotools
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="acl authfile ban case clamav deflate hardened ifsession ipv6 ldap mysql ncurses nls noauthunix opensslcrypt pam postgres radius rewrite selinux shaper sitemisc softquota ssl tcpd vroot xinetd"
+IUSE="acl authfile ban case clamav deflate hardened ifsession ipv6 kerberos ldap mysql ncurses nls noauthunix opensslcrypt pam postgres radius rewrite selinux shaper sitemisc softquota ssl tcpd vroot xinetd"
CASE_VER="0.3"
CLAMAV_VER="0.10"
DEFLATE_VER="0.3.1"
+MODGSS_VER="1.3.1"
SHAPER_VER="0.6.5"
VROOT_VER="0.8.3"
@@ -20,18 +21,21 @@ SRC_URI="ftp://ftp.proftpd.org/distrib/source/${P/_/}.tar.bz2
case? ( http://www.castaglia.org/${PN}/modules/${PN}-mod-case-${CASE_VER}.tar.gz )
clamav? ( http://www.thrallingpenguin.com/resources/mod_clamav-${CLAMAV_VER}.tar.gz )
deflate? ( http://www.castaglia.org/${PN}/modules/${PN}-mod-deflate-${DEFLATE_VER}.tar.gz )
+ kerberos? ( mirror://sourceforge/gssmod/mod_gss-${MODGSS_VER}.tar.gz )
shaper? ( http://www.castaglia.org/${PN}/modules/${PN}-mod-shaper-${SHAPER_VER}.tar.gz )
vroot? ( http://www.castaglia.org/${PN}/modules/${PN}-mod-vroot-${VROOT_VER}.tar.gz )"
HOMEPAGE="http://www.proftpd.org/
http://www.castaglia.org/proftpd/
- http://www.thrallingpenguin.com/resources/mod_clamav.htm"
+ http://www.thrallingpenguin.com/resources/mod_clamav.htm
+ http://gssmod.sourceforge.net"
SLOT="0"
LICENSE="GPL-2"
DEPEND="acl? ( sys-apps/acl sys-apps/attr )
clamav? ( app-antivirus/clamav )
+ kerberos? ( || ( app-crypt/mit-krb5 app-crypt/heimdal ) )
ldap? ( >=net-nds/openldap-1.2.11 )
mysql? ( virtual/mysql )
ncurses? ( sys-libs/ncurses )
@@ -65,6 +69,8 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-parallel-build.patch
# Fix mysql include when both backends are enabled
epatch "${FILESDIR}"/${P}-mysql-include.patch
+ # Do not use bundled libltdl when compiling mod_dso
+ epatch "${FILESDIR}"/${P}-system-libltdl.patch
# Fix stripping of files
sed -e "s| @INSTALL_STRIP@||g" -i Make*
@@ -87,6 +93,10 @@ src_unpack() {
cp -f mod_deflate/mod_deflate.html doc/
fi
+ if use kerberos ; then
+ unpack mod_gss-${MODGSS_VER}.tar.gz
+ fi
+
if use shaper ; then
unpack ${PN}-mod-shaper-${SHAPER_VER}.tar.gz
cp -f mod_shaper/mod_shaper.c contrib/
@@ -186,6 +196,23 @@ src_compile() {
myconf="${myconf} --enable-auth-unix"
fi
+ if use kerberos ; then
+ cd "${S}"/mod_gss-${MODGSS_VER}
+ # Generate source files for installed virtual/krb5 provider
+ if has_version app-crypt/mit-krb5; then
+ econf --enable-mit
+ else
+ econf --enable-heimdal
+ fi
+ cd "${S}"
+ # copy the generated files
+ cp -f mod_gss-${MODGSS_VER}/mod_gss.c contrib/
+ cp -f mod_gss-${MODGSS_VER}/mod_gss.h include/
+ cp -f mod_gss-${MODGSS_VER}/mod_auth_gss.c contrib/
+
+ myconf="${myconf} --enable-dso --with-shared=mod_gss:mod_auth_gss"
+ fi
+
LIBS="${mylibs}" econf \
--sbindir=/usr/sbin \
--localstatedir=/var/run \