summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-09-29 16:37:07 +0000
committerJeroen Roovers <jer@gentoo.org>2012-09-29 16:37:07 +0000
commitaf2973233ae5df838bff5a633f35aad993a0bfcb (patch)
treead5ce87398cbb6f686daa5d55153643c72d55d17 /net-ftp/lftp
parentalpha/sparc stable wrt #430638 (diff)
downloadgentoo-2-af2973233ae5df838bff5a633f35aad993a0bfcb.tar.gz
gentoo-2-af2973233ae5df838bff5a633f35aad993a0bfcb.tar.bz2
gentoo-2-af2973233ae5df838bff5a633f35aad993a0bfcb.zip
Version bump.
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-4.4.0.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 638107642274..c6e4039fac17 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.381 2012/09/11 15:50:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.382 2012/09/29 16:37:07 jer Exp $
+
+*lftp-4.4.0 (29 Sep 2012)
+
+ 29 Sep 2012; Jeroen Roovers <jer@gentoo.org> +lftp-4.4.0.ebuild:
+ Version bump.
11 Sep 2012; Raúl Porcel <armin76@gentoo.org> lftp-4.3.8.ebuild:
alpha/ia64/s390/sparc stable wrt #432018
diff --git a/net-ftp/lftp/lftp-4.4.0.ebuild b/net-ftp/lftp/lftp-4.4.0.ebuild
new file mode 100644
index 000000000000..71154f3569d5
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.4.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.4.0.ebuild,v 1.1 2012/09/29 16:37:07 jer Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+
+LFTP_LINGUAS="cs de es fr it ja ko pl pt_BR ru zh_CN zh_HK zh_TW"
+
+IUSE="
+ $( for i in ${LFTP_LINGUAS}; do echo linguas_${i}; done )
+ gnutls nls socks5 +ssl
+"
+
+RDEPEND="
+ dev-libs/expat
+ >=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ >=sys-libs/readline-5.1
+"
+
+DEPEND="
+ ${RDEPEND}
+ =sys-devel/libtool-2*
+ app-arch/xz-utils
+ dev-lang/perl
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=(
+ BUGS ChangeLog FAQ FEATURES MIRRORS NEWS README README.debug-levels
+ README.dnssec README.modules THANKS TODO
+)
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PN}-4.0.2.91-lafile.patch" \
+ "${FILESDIR}/${PN}-4.3.5-autopoint.patch" \
+ "${FILESDIR}/${PN}-4.3.8-gets.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=""
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --enable-packager-mode \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ $(use_enable nls) \
+ ${myconf}
+}