summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2011-11-01 19:23:53 +0000
committerVictor Ostorga <vostorga@gentoo.org>2011-11-01 19:23:53 +0000
commitbd1a8fada1096d991cb91769a71c7311ffe04d10 (patch)
tree7e9655a18ff26c1d98d1f213dea5f8e50d2e954f /net-fs
parentRevbump with a fix for some hardened boxes in infra and OSUOSL. (diff)
downloadgentoo-2-bd1a8fada1096d991cb91769a71c7311ffe04d10.tar.gz
gentoo-2-bd1a8fada1096d991cb91769a71c7311ffe04d10.tar.bz2
gentoo-2-bd1a8fada1096d991cb91769a71c7311ffe04d10.zip
Updating samba 4, based in work of Ewoud Kohl van Wijngaarden <gentoo@kohlvanwijngaarden.nl> bug 195703
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog9
-rw-r--r--net-fs/samba/files/4.0/com_err.patch35
-rw-r--r--net-fs/samba/files/4.0/samba4.initd31
-rw-r--r--net-fs/samba/metadata.xml3
-rw-r--r--net-fs/samba/samba-4.0.0_alpha17.ebuild133
5 files changed, 210 insertions, 1 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index b9a9cc4ba779..64c5b5d7d17f 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.491 2011/10/28 19:56:55 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.492 2011/11/01 19:23:53 vostorga Exp $
+
+*samba-4.0.0_alpha17 (01 Nov 2011)
+
+ 01 Nov 2011; Víctor Ostorga <vostorga@gentoo.org> +files/4.0/com_err.patch,
+ +files/4.0/samba4.initd, +samba-4.0.0_alpha17.ebuild:
+ Updating samba 4, based in work of Ewoud Kohl van Wijngaarden
+ <gentoo@kohlvanwijngaarden.nl> bug 195703
*samba-3.6.1 (28 Oct 2011)
diff --git a/net-fs/samba/files/4.0/com_err.patch b/net-fs/samba/files/4.0/com_err.patch
new file mode 100644
index 000000000000..2c9ad88f01d7
--- /dev/null
+++ b/net-fs/samba/files/4.0/com_err.patch
@@ -0,0 +1,35 @@
+From 2f34bfbc1941127d17a7a91c6598d6a6c35620e2 Mon Sep 17 00:00:00 2001
+From: Ewoud Kohl van Wijngaarden <ewoud@kohlvanwijngaarden.nl>
+Date: Thu, 6 Oct 2011 00:19:01 +0200
+Subject: [PATCH] Add missing com_err dependencies
+
+---
+ auth/kerberos/wscript_build | 2 +-
+ nsswitch/wscript_build | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/auth/kerberos/wscript_build b/auth/kerberos/wscript_build
+index 1070770..2421b16 100644
+--- a/auth/kerberos/wscript_build
++++ b/auth/kerberos/wscript_build
+@@ -1,3 +1,3 @@
+ bld.SAMBA_SUBSYSTEM('KRB5_PAC',
+ source='gssapi_pac.c kerberos_pac.c',
+- deps='gssapi_krb5 krb5 ndr-krb5pac')
++ deps='gssapi_krb5 krb5 ndr-krb5pac com_err')
+diff --git a/nsswitch/wscript_build b/nsswitch/wscript_build
+index 298da06..4e353d3 100644
+--- a/nsswitch/wscript_build
++++ b/nsswitch/wscript_build
+@@ -33,7 +33,7 @@ if bld.CONFIG_SET('WITH_PAM_MODULES') and bld.CONFIG_SET('HAVE_PAM_START'):
+ if bld.CONFIG_SET('HAVE_KRB5_LOCATE_PLUGIN_H'):
+ bld.SAMBA_LIBRARY('winbind_krb5_locator',
+ source='winbind_krb5_locator.c',
+- deps='wbclient krb5',
++ deps='wbclient krb5 com_err',
+ realname='winbind_krb5_locator.so')
+
+ bld.SAMBA_SUBSYSTEM('WB_REQTRANS',
+--
+1.7.3.4
+
diff --git a/net-fs/samba/files/4.0/samba4.initd b/net-fs/samba/files/4.0/samba4.initd
new file mode 100644
index 000000000000..7a09233795e0
--- /dev/null
+++ b/net-fs/samba/files/4.0/samba4.initd
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/files/4.0/samba4.initd,v 1.1 2011/11/01 19:23:53 vostorga Exp $
+
+extra_started_commands="reload"
+
+description="The samba daemon init script"
+description_reload="Reloads the samba daemon"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting samba"
+ start-stop-daemon --start --exec /usr/sbin/samba
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping samba"
+ start-stop-daemon --stop --pidfile /var/run/samba/samba.pid
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading samba"
+ killall -HUP samba
+ eend $?
+}
diff --git a/net-fs/samba/metadata.xml b/net-fs/samba/metadata.xml
index 3289e14490fb..6db9563ef26d 100644
--- a/net-fs/samba/metadata.xml
+++ b/net-fs/samba/metadata.xml
@@ -26,5 +26,8 @@ Samba is an Open Source/Free Software suite that provides seamless file and prin
<flag name="smbclient">Enable smbclient tool</flag>
<flag name="smbsharemodes">Enable special smb share modes (?) </flag>
<flag name="smbtav2">Enable Samba Traffic Analyzer version 2 </flag>
+ <flag name="fulltest">Enabling extra tests in test phase </flag>
+ <flag name="krb5">Enable kerberos support</flag>
+ <flag name="iprint">Enabling iPrint technology by Novell</flag>
</use>
</pkgmetadata>
diff --git a/net-fs/samba/samba-4.0.0_alpha17.ebuild b/net-fs/samba/samba-4.0.0_alpha17.ebuild
new file mode 100644
index 000000000000..98bd7186e712
--- /dev/null
+++ b/net-fs/samba/samba-4.0.0_alpha17.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.0.0_alpha17.ebuild,v 1.1 2011/11/01 19:23:53 vostorga Exp $
+
+EAPI=4
+
+inherit eutils confutils python waf-utils versionator
+
+MY_PV="${PV/_alpha/alpha}"
+MY_P="${PN}-${MY_PV}"
+
+if [ "${PV}" = "4.9999" ]; then
+ EGIT_REPO_URI="git://git.samba.org/samba.git"
+ inherit git-2
+else
+ SRC_URI="mirror://samba/samba4/${MY_P}.tar.gz"
+fi
+
+DESCRIPTION="Samba Server component"
+HOMEPAGE="http://www.samba.org/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acl addns ads aio avahi client cluster cups debug fulltest gnutls iprint
+krb5 ldap pam quota swat syslog winbind"
+
+RDEPEND="dev-libs/popt
+ sys-libs/readline
+ virtual/libiconv
+ >=dev-lang/python-2.4.2
+ dev-python/subunit
+ >=app-crypt/heimdal-1.5[-ssl]
+ >=sys-libs/tdb-1.2.9[python]
+ >=sys-libs/ldb-1.1.2
+ >=sys-libs/talloc-2.0.6[python]
+ >=sys-libs/tevent-0.9.14
+ sys-libs/zlib
+ ads? ( client? ( net-fs/cifs-utils[ads] ) )
+ client? ( net-fs/cifs-utils )
+ cluster? ( >=dev-db/ctdb-1.0.114_p1 )
+ ldap? ( net-nds/openldap )
+ gnutls? ( >=net-libs/gnutls-1.4.0 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ confutils_use_depend_all fulltest test
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ cd "${WORKDIR}/${MY_P}" && epatch "${CONFDIR}"/com_err.patch
+}
+
+src_configure() {
+ local myconf=''
+ if use "debug"; then
+ myconf="${myconf} --enable-developer"
+ fi
+ if use "cluster"; then
+ myconf="${myconf} --with-ctdb-dir=/usr"
+ fi
+ myconf="${myconf} \
+ --enable-fhs \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-rpath \
+ --disable-rpath-install \
+ --nopyc \
+ --nopyo \
+ --bundled-libraries=NONE \
+ --builtin-libraries=replace,ccan \
+ $(use_with addns dnsupdate) \
+ $(use_with acl) \
+ $(use_with ads) \
+ $(use_with aio aio-support) \
+ $(use_enable avahi) \
+ $(use_with cluster cluster-support) \
+ $(use_enable cups) \
+ $(use_enable gnutls) \
+ $(use_enable iprint) \
+ $(use_with krb5) \
+ $(use_with ldap) \
+ $(use_with pam) \
+ $(use_with pam pam_smbpass) \
+ $(use_with quota) \
+ $(use_with syslog) \
+ $(use_with swat) \
+ $(use_with winbind)"
+ waf-utils_src_configure ${myconf}
+}
+
+src_install() {
+ waf-utils_src_install
+
+ newinitd "${CONFDIR}/samba4.initd" samba || die "newinitd failed"
+
+ #remove conflicting file for tevent profided by sys-libs/tevent
+ find "${D}" -type f -name "_tevent.so" -exec rm -f {} \;
+}
+
+src_test() {
+ local extra_opts=""
+ use fulltest || extra_opts+="--quick"
+ "${WAF_BINARY}" test ${extra_opts} || die "test failed"
+}
+
+pkg_postinst() {
+ # Optimize the python modules so they get properly removed
+ python_mod_optimize "${PN}"
+
+ einfo "See http://wiki.samba.org/index.php/Samba4/HOWTO for more"
+ einfo "information about samba 4."
+
+ # Warn that it's an alpha
+ ewarn "Samba 4 is an alpha and therefore not considered stable. It's only"
+ ewarn "meant to test and experiment and definitely not for production"
+}
+
+pkg_postrm() {
+ # Clean up the python modules
+ python_mod_cleanup "${PN}"
+}