summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2008-04-05 09:56:03 +0000
committerStefan Schweizer <genstef@gentoo.org>2008-04-05 09:56:03 +0000
commitb6543effe8f4aad860efb42679a9b0bc2a7abb18 (patch)
tree602d30b279cc88783e79dfe813986cb17ec90853 /net-fs
parentRemove lots of obsolete versions (diff)
downloadgentoo-2-b6543effe8f4aad860efb42679a9b0bc2a7abb18.tar.gz
gentoo-2-b6543effe8f4aad860efb42679a9b0bc2a7abb18.tar.bz2
gentoo-2-b6543effe8f4aad860efb42679a9b0bc2a7abb18.zip
Version bump, bug 214497, also fix mounting in nobody's home, bug 156591
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/davfs2/ChangeLog10
-rw-r--r--net-fs/davfs2/davfs2-1.3.0.ebuild63
-rw-r--r--net-fs/davfs2/files/davfs2-neon-0.28.patch58
3 files changed, 129 insertions, 2 deletions
diff --git a/net-fs/davfs2/ChangeLog b/net-fs/davfs2/ChangeLog
index 54a397fed1f7..4fd56aded105 100644
--- a/net-fs/davfs2/ChangeLog
+++ b/net-fs/davfs2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/davfs2
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/ChangeLog,v 1.36 2007/08/08 23:14:45 genstef Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/ChangeLog,v 1.37 2008/04/05 09:56:02 genstef Exp $
+
+*davfs2-1.3.0 (05 Apr 2008)
+
+ 05 Apr 2008; Stefan Schweizer <genstef@gentoo.org>
+ +files/davfs2-neon-0.28.patch, +davfs2-1.3.0.ebuild:
+ Version bump, bug 214497, also fix mounting in nobody's home, bug 156591
*davfs2-1.2.2 (08 Aug 2007)
diff --git a/net-fs/davfs2/davfs2-1.3.0.ebuild b/net-fs/davfs2/davfs2-1.3.0.ebuild
new file mode 100644
index 000000000000..209aac4ca7e2
--- /dev/null
+++ b/net-fs/davfs2/davfs2-1.3.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/davfs2-1.3.0.ebuild,v 1.1 2008/04/05 09:56:02 genstef Exp $
+
+inherit linux-mod eutils
+
+DESCRIPTION="a Linux file system driver that allows you to mount a WebDAV server as a local disk drive. Davfs2 uses fuse (or coda) for kernel driver and neon for WebDAV interface"
+SRC_URI="mirror://sourceforge/dav/${P}.tar.gz"
+HOMEPAGE="http://dav.sourceforge.net"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ssl debug socks5"
+RESTRICT="test"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ dev-libs/libxml2
+ net-misc/neon
+ sys-libs/zlib"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/davfs2-neon-0.28.patch
+}
+
+src_compile() {
+ local myconf
+
+ if use debug; then
+ myconf="--with-debug"
+ fi
+
+ econf \
+ $(use_with ssl) \
+ $(use_with socks5 socks) \
+ --enable-largefile \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS BUGS ChangeLog FAQ INSTALL.davfs2 NEWS README \
+ README.translators THANKS TODO
+
+ # remove wrong locations created by install
+ rm -r "${D}/usr/share/doc/davfs2"
+ rm -r "${D}/usr/share/davfs2"
+
+ dodir /var/run/mount.davfs
+ keepdir /var/run/mount.davfs
+ fowners root:users /var/run/mount.davfs
+ fperms 1774 /var/run/mount.davfs
+
+ # ignore nobody's home
+ cat>>"${D}/etc/davfs2/davfs2.conf"<<EOF
+
+# nobody is a system account in Gentoo
+ignore_home nobody
+EOF
+}
diff --git a/net-fs/davfs2/files/davfs2-neon-0.28.patch b/net-fs/davfs2/files/davfs2-neon-0.28.patch
new file mode 100644
index 000000000000..fe1dfc407877
--- /dev/null
+++ b/net-fs/davfs2/files/davfs2-neon-0.28.patch
@@ -0,0 +1,58 @@
+Thanks go to debian:
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=473933
+
+diff -uri davfs2-1.3.0.orig/configure davfs2-1.3.0/configure
+--- davfs2-1.3.0.orig/configure 2008-02-06 09:56:13.000000000 +0000
++++ davfs2-1.3.0/configure 2008-04-02 13:28:30.000000000 +0000
+@@ -5546,7 +5546,7 @@
+ echo "${ECHO_T}$ne_cv_lib_neon" >&6; }
+ if test "$ne_cv_lib_neon" = "yes"; then
+ ne_cv_lib_neonver=no
+- for v in 25 26 27; do
++ for v in 25 26 27 28; do
+ case $ne_libver in
+ 0.$v.*) ne_cv_lib_neonver=yes ;;
+ esac
+@@ -5741,8 +5741,8 @@
+ neon_got_library=yes
+
+ else
+- { echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.25 26 27" >&5
+-echo "$as_me: incompatible neon library version $ne_libver: wanted 0.25 26 27" >&6;}
++ { echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.25 26 27 28" >&5
++echo "$as_me: incompatible neon library version $ne_libver: wanted 0.25 26 27 28" >&6;}
+ neon_got_library=no
+ fi
+
+@@ -5823,7 +5823,7 @@
+ echo "${ECHO_T}$ne_cv_lib_neon" >&6; }
+ if test "$ne_cv_lib_neon" = "yes"; then
+ ne_cv_lib_neonver=no
+- for v in 25 26 27; do
++ for v in 25 26 27 28; do
+ case $ne_libver in
+ 0.$v.*) ne_cv_lib_neonver=yes ;;
+ esac
+@@ -6018,8 +6018,8 @@
+ neon_got_library=yes
+
+ else
+- { echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.25 26 27" >&5
+-echo "$as_me: incompatible neon library version $ne_libver: wanted 0.25 26 27" >&6;}
++ { echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.25 26 27 28" >&5
++echo "$as_me: incompatible neon library version $ne_libver: wanted 0.25 26 27 28" >&6;}
+ neon_got_library=no
+ fi
+
+diff -uri davfs2-1.3.0.orig/configure.ac davfs2-1.3.0/configure.ac
+--- davfs2-1.3.0.orig/configure.ac 2008-02-05 20:37:03.000000000 +0000
++++ davfs2-1.3.0/configure.ac 2008-04-02 13:27:27.000000000 +0000
+@@ -17,7 +17,7 @@
+ # Checks for libraries.
+ AM_GNU_GETTEXT_VERSION(0.14.4)
+ AM_GNU_GETTEXT([external])
+-NE_REQUIRE_VERSIONS([0], [25 26 27])
++NE_REQUIRE_VERSIONS([0], [25 26 27 28])
+ DAV_CHECK_NEON
+
+ # Checks for header files.