summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2009-01-04 12:31:28 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2009-01-04 12:31:28 +0000
commit7e6b8ad03c27f96c16f84689d518ce0451ae55be (patch)
tree4a876d22f10104b003e74e42f93973c7d3e95ab7 /net-fs
parentVersion bump (diff)
downloadgentoo-2-7e6b8ad03c27f96c16f84689d518ce0451ae55be.tar.gz
gentoo-2-7e6b8ad03c27f96c16f84689d518ce0451ae55be.tar.bz2
gentoo-2-7e6b8ad03c27f96c16f84689d518ce0451ae55be.zip
Version bump to 5.0.4 + fix bugs #247969 and #253412 concerning LDFLAGS and --as-needed
(Portage version: 2.2_rc20/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/autofs/ChangeLog12
-rw-r--r--net-fs/autofs/autofs-5.0.4.ebuild81
-rw-r--r--net-fs/autofs/files/autofs-5.0.4-user-ldflags-and-as-needed.patch66
3 files changed, 157 insertions, 2 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index 9159568d4125..9cb4c7c59e22 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-fs/autofs
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.76 2008/08/29 13:51:00 robbat2 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.77 2009/01/04 12:31:28 stefaan Exp $
+
+*autofs-5.0.4 (04 Jan 2009)
+
+ 04 Jan 2009; Stefaan De Roeck <stefaan@gentoo.org>
+ +files/autofs-5.0.4-user-ldflags-and-as-needed.patch,
+ +autofs-5.0.4.ebuild:
+ Version bump to 5.0.4 + fix bugs #247969 and #253412 concerning LDFLAGS
+ and --as-needed
29 Aug 2008; Robin H. Johnson <robbat2@gentoo.org> Manifest:
Bug #236051, I had a download failure during digesting, with a zero-byte
diff --git a/net-fs/autofs/autofs-5.0.4.ebuild b/net-fs/autofs/autofs-5.0.4.ebuild
new file mode 100644
index 000000000000..9fe4b4e42c07
--- /dev/null
+++ b/net-fs/autofs/autofs-5.0.4.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.4.ebuild,v 1.1 2009/01/04 12:31:28 stefaan Exp $
+
+inherit eutils multilib autotools
+
+IUSE="ldap sasl"
+DESCRIPTION="Kernel based automounter"
+HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
+SRC_URI_BASE="mirror://kernel/linux/daemons/${PN}/v5"
+# This list is taken directly from http://kernel.org/pub/linux/daemons/autofs/v5/patch_order-5.0.3
+# Please do not modify the order
+PATCH_LIST="
+ ${P}-fix-dumb-libxml2-check.patch
+ ${P}-expire-specific-submount-only.patch
+ ${P}-fix-negative-cache-non-existent-key.patch
+ ${P}-fix-ldap-detection.patch"
+SRC_URI="${SRC_URI_BASE}/${P}.tar.bz2"
+for i in ${PATCH_LIST} ; do
+ SRC_URI="${SRC_URI} ${SRC_URI_BASE}/${i}"
+done ;
+DEPEND="virtual/libc
+ ldap? ( >=net-nds/openldap-2.0 )
+ sasl? ( virtual/krb5 )"
+ # currently, sasl code assumes the presence of kerberosV
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ for i in ${PATCH_LIST}; do
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${DISTDIR}"/${i}
+ done
+
+ cd "${S}"
+
+ # fixes bug #210762
+ epatch "${FILESDIR}"/${PN}-5.0.3-heimdal.patch
+
+ # fixes bugs #253412 and #247969
+ epatch "${FILESDIR}"/${P}-user-ldflags-and-as-needed.patch
+
+ # # use CC and CFLAGS from environment (bug #154797)
+ # write these values in Makefile.conf
+ (echo "# Use the compiler and cflags determined by configure";
+ echo "CC := @CC@"; echo "CFLAGS := @CFLAGS@") >> Makefile.conf.in
+ # make sure Makefile.conf is parsed after Makefile.rules
+ sed -ni '/include Makefile.conf/{x; n; G}; p' Makefile
+ sed -i 's/^\(CC\|CXX\).*//' Makefile.rules
+ sed -i 's/^CFLAGS=-fPIE.*//' configure.in
+
+ # do not include <nfs/nfs.h>, rather <linux/nfs.h>,
+ # as the former is a lame header for the latter (bug #157968)
+ sed -i 's@nfs/nfs.h@linux/nfs.h@' include/rpc_subs.h
+
+ eautoreconf || die "Autoconf failed"
+}
+
+src_compile() {
+ CFLAGS="${CFLAGS}" \
+ econf \
+ $(use_with ldap openldap) \
+ $(use_with sasl) \
+ --enable-ignore-busy \
+ || die "configure failed"
+
+ emake DONTSTRIP=1 || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ newinitd "${FILESDIR}"/autofs5.rc1 autofs
+}
+
+pkg_postinst() {
+ elog "Note: If you plan on using autofs for automounting"
+ elog "remote NFS mounts without having the NFS daemon running"
+ elog "please add portmap to your default run-level."
+}
diff --git a/net-fs/autofs/files/autofs-5.0.4-user-ldflags-and-as-needed.patch b/net-fs/autofs/files/autofs-5.0.4-user-ldflags-and-as-needed.patch
new file mode 100644
index 000000000000..ba650593b92d
--- /dev/null
+++ b/net-fs/autofs/files/autofs-5.0.4-user-ldflags-and-as-needed.patch
@@ -0,0 +1,66 @@
+1/2) Patch 177057 to bug #253412: use user ldflags, don't add pthreads through ldflags
+
+diff -ru a/Makefile.rules b/Makefile.rules
+--- a/Makefile.rules 2009-01-01 21:54:02.000000000 -0600
++++ b/Makefile.rules 2009-01-01 22:17:41.000000000 -0600
+@@ -24,16 +24,16 @@
+
+ ifdef DEBUG
+ CFLAGS ?= -g -Wall -DDEBUG
+-LDFLAGS = -g
++AUTOFS_LDFLAGS = -g
+ STRIP = :
+ else
+ ifdef DONTSTRIP
+ CFLAGS ?= -O2 -g
+-LDFLAGS = -g
++AUTOFS_LDFLAGS = -g
+ STRIP = :
+ else
+ CFLAGS ?= -O2 -Wall
+-LDFLAGS = -s
++AUTOFS_LDFLAGS = -s
+ STRIP = strip --strip-debug
+ endif
+ endif
+@@ -45,10 +45,9 @@
+ SOLDFLAGS = -shared
+
+ CFLAGS += -D_REENTRANT -D_FILE_OFFSET_BITS=64
+-LDFLAGS += -lpthread
+
+ ifdef DMALLOCLIB
+-LDFLAGS += $(DMALLOCLIB)
++AUTOFS_LDFLAGS += $(DMALLOCLIB)
+ endif
+
+ # Standard rules
+diff -ru a/daemon/Makefile b/daemon/Makefile
+--- a/daemon/Makefile 2009-01-01 22:14:10.000000000 -0600
++++ b/daemon/Makefile 2009-01-01 22:24:03.000000000 -0600
+@@ -25,7 +25,7 @@
+ all: automount
+
+ automount: $(OBJS) $(AUTOFS_LIB)
+- $(CC) $(LDFLAGS) $(DAEMON_LDFLAGS) -o automount $(OBJS) $(AUTOFS_LIB) $(LIBS)
++ $(CC) $(AUTOFS_LDFLAGS) $(DAEMON_LDFLAGS) $(LDFLAGS) -o automount $(OBJS) $(AUTOFS_LIB) $(LIBS)
+ $(STRIP) automount
+
+ clean:
+
+
+
+2/2) Patch 177056 to bug #247969: add -lpthread the correct way (removed from LDFLAGS in above patch)
+
+diff -ru a/daemon/Makefile b/daemon/Makefile
+--- a/daemon/Makefile 2009-01-01 22:14:10.000000000 -0600
++++ b/daemon/Makefile 2009-01-01 22:21:16.000000000 -0600
+@@ -20,7 +20,7 @@
+ CFLAGS += -DAUTOFS_FLAG_DIR=\"$(autofsflagdir)\"
+ CFLAGS += -DVERSION_STRING=\"$(version)\"
+ LDFLAGS += -rdynamic
+-LIBS = -ldl
++LIBS = -ldl -lpthread
+
+ all: automount
+