summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2005-07-12 15:32:57 +0000
committerSimon Stelling <blubb@gentoo.org>2005-07-12 15:32:57 +0000
commit40f69d905007768ce517f49f4cbff0d1da692a2a (patch)
treedda4c37b523fa427472a1c85a98e9c4c96e16a8b /net-fs
parentVersion bumped to fix building on ia64. (diff)
downloadgentoo-2-40f69d905007768ce517f49f4cbff0d1da692a2a.tar.gz
gentoo-2-40f69d905007768ce517f49f4cbff0d1da692a2a.tar.bz2
gentoo-2-40f69d905007768ce517f49f4cbff0d1da692a2a.zip
fix bug 81507 and keyword ~amd64
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/davfs2/ChangeLog6
-rw-r--r--net-fs/davfs2/davfs2-0.2.3-r1.ebuild6
-rw-r--r--net-fs/davfs2/files/include_compiler.patch20
3 files changed, 29 insertions, 3 deletions
diff --git a/net-fs/davfs2/ChangeLog b/net-fs/davfs2/ChangeLog
index 411474ede04e..441afc84a769 100644
--- a/net-fs/davfs2/ChangeLog
+++ b/net-fs/davfs2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-fs/davfs2
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/ChangeLog,v 1.11 2005/07/11 15:44:31 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/ChangeLog,v 1.12 2005/07/12 15:32:57 blubb Exp $
+
+ 12 Jul 2005; Simon Stelling <blubb@gentoo.org>
+ +files/include_compiler.patch, davfs2-0.2.3-r1.ebuild:
+ fix bug 81507 and keyword ~amd64
11 Jul 2005; Stefan Schweizer <genstef@gentoo.org> davfs2-0.2.3-r1.ebuild:
Fixing bug 96901 by making the patch conditional (only 2.4 kernel) thanks to
diff --git a/net-fs/davfs2/davfs2-0.2.3-r1.ebuild b/net-fs/davfs2/davfs2-0.2.3-r1.ebuild
index 4d81e2338e4f..67cbe7439db7 100644
--- a/net-fs/davfs2/davfs2-0.2.3-r1.ebuild
+++ b/net-fs/davfs2/davfs2-0.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/davfs2-0.2.3-r1.ebuild,v 1.4 2005/07/11 15:44:31 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/davfs2-0.2.3-r1.ebuild,v 1.5 2005/07/12 15:32:57 blubb Exp $
inherit linux-info eutils
@@ -9,7 +9,7 @@ IUSE="ssl debug"
DESCRIPTION="a Linux file system driver that allows you to mount a WebDAV server as a local disk drive. Davfs2 uses Coda for kernel driver and neon for WebDAV interface"
SRC_URI="mirror://sourceforge/dav/${P}.tar.gz"
HOMEPAGE="http://dav.sourceforge.net"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="~amd64 ~ppc x86"
LICENSE="GPL-2"
DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
@@ -24,6 +24,8 @@ src_unpack() {
unpack ${A}
cd ${S}
kernel_is 2 4 && epatch ${FILESDIR}/${PN}.nokernelsrc.patch
+
+ epatch ${FILESDIR}/include_compiler.patch #81507
}
src_compile() {
diff --git a/net-fs/davfs2/files/include_compiler.patch b/net-fs/davfs2/files/include_compiler.patch
new file mode 100644
index 000000000000..177da3b88931
--- /dev/null
+++ b/net-fs/davfs2/files/include_compiler.patch
@@ -0,0 +1,20 @@
+--- src/davfsd.c.orig 2004-11-02 06:45:26.000000000 +0100
++++ src/davfsd.c 2005-02-10 16:57:36.895959566 +0100
+@@ -38,6 +38,7 @@
+ /* Linux Kernel Source */
+ /* avoid inclusion of kernel time.h, since it conflicts with userland time.h */
+ #define _LINUX_TIME_H
++#include <linux/compiler.h>
+ #include <linux/coda.h>
+
+ /* Neon */
+--- src/mount.c.orig 2004-11-02 06:45:26.000000000 +0100
++++ src/mount.c 2005-02-10 16:58:22.818690708 +0100
+@@ -35,6 +35,7 @@
+ /* Linux coda head file */
+ /* avoid inclusion of kernel time.h, since it conflicts with userland time.h */
+ #define _LINUX_TIME_H
++#include <linux/compiler.h>
+ #include <linux/coda.h>
+
+ /* Neon */