summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-03-23 19:19:22 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-03-23 19:19:22 +0000
commit0fb5c2b9893b04b0adc4df263406e8d0e59e11cf (patch)
tree6c3e917a53c5d09b9a0789a3fd9582b40f4e317a /net-fs
parentadded selinux support (diff)
downloadgentoo-2-0fb5c2b9893b04b0adc4df263406e8d0e59e11cf.tar.gz
gentoo-2-0fb5c2b9893b04b0adc4df263406e8d0e59e11cf.tar.bz2
gentoo-2-0fb5c2b9893b04b0adc4df263406e8d0e59e11cf.zip
Fixed ebuild that mount.* would be installed. Closes #17823.
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/ncpfs/ChangeLog7
-rw-r--r--net-fs/ncpfs/files/digest-ncpfs-2.2.0.19-r21
-rw-r--r--net-fs/ncpfs/ncpfs-2.2.0.19-r2.ebuild40
3 files changed, 47 insertions, 1 deletions
diff --git a/net-fs/ncpfs/ChangeLog b/net-fs/ncpfs/ChangeLog
index a370662b47f9..14b2cdb93555 100644
--- a/net-fs/ncpfs/ChangeLog
+++ b/net-fs/ncpfs/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for net-fs/ncpfs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
# Author Heiko Helmle <helman@gmx.net>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ChangeLog,v 1.3 2003/02/12 07:56:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ChangeLog,v 1.4 2003/03/23 19:19:22 mholzer Exp $
+
+*ncpfs-2.2.0.19-r2 (23 Mar 2003)
+
+ 23 Mar 2003; Martin Holzer <mholzer@gentoo.org> ncpfs-2.2.0.19-r2.ebuild:
+ Fixed ebuild that mount.* would be installed. Closes #17823.
*ncpfs-2.2.0.19 (20 Oct 2002)
diff --git a/net-fs/ncpfs/files/digest-ncpfs-2.2.0.19-r2 b/net-fs/ncpfs/files/digest-ncpfs-2.2.0.19-r2
new file mode 100644
index 000000000000..c547999575bf
--- /dev/null
+++ b/net-fs/ncpfs/files/digest-ncpfs-2.2.0.19-r2
@@ -0,0 +1 @@
+MD5 edaa6df0b892f0948e543b592eca36d3 ncpfs-2.2.0.19.tar.gz 1465012
diff --git a/net-fs/ncpfs/ncpfs-2.2.0.19-r2.ebuild b/net-fs/ncpfs/ncpfs-2.2.0.19-r2.ebuild
new file mode 100644
index 000000000000..bb078dd865c1
--- /dev/null
+++ b/net-fs/ncpfs/ncpfs-2.2.0.19-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+#Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ncpfs-2.2.0.19-r2.ebuild,v 1.1 2003/03/23 19:19:22 mholzer Exp $
+
+inherit eutils
+
+IUSE="nls pam"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Provides Access to Netware services using the NCP protocol (Kernel support must be activated!)"
+SRC_URI="ftp://platan.vc.cvut.cz/pub/linux/${PN}/old/${P}.tar.gz"
+HOMEPAGE="ftp://platan.vc.cvut.cz/pub/linux/ncpfs/latest/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="nls? ( sys-devel/gettext )
+ pam? ( sys-libs/pam )"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+ use pam \
+ && myconf="${myconf} --enable-pam" \
+ || myconf="${myconf} --disable-pam"
+
+ econf ${myconf}
+ emake || die
+}
+
+src_install () {
+ # directory ${D}/lib/security needs to be created or the install fails
+ dodir /lib/security
+ dodir /usr/sbin
+ dodir /sbin
+ make DESTDIR=${D} install || die
+}