summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-04-08 17:51:44 +0000
committerMike Frysinger <vapier@gentoo.org>2007-04-08 17:51:44 +0000
commitfa5463e017b22248f97abb26f9834a87b69c341f (patch)
treee8493bdfb90087dda3b9d1253ab40a46a723c16f /net-firewall
parentPost-stabilization cleanup. (diff)
downloadgentoo-2-fa5463e017b22248f97abb26f9834a87b69c341f.tar.gz
gentoo-2-fa5463e017b22248f97abb26f9834a87b69c341f.tar.bz2
gentoo-2-fa5463e017b22248f97abb26f9834a87b69c341f.zip
By default, let the toolchain worry about kernel header location #172209 by Karl Hiramoto.
(Portage version: 2.1.2.3)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog7
-rw-r--r--net-firewall/iptables/files/iptables-1.3.7-kernel-dir.patch18
-rw-r--r--net-firewall/iptables/iptables-1.3.7.ebuild5
3 files changed, 27 insertions, 3 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index ebdb10fa8bf7..ce69ef9da07c 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.130 2007/04/04 12:55:29 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.131 2007/04/08 17:51:44 vapier Exp $
+
+ 08 Apr 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/iptables-1.3.7-kernel-dir.patch, iptables-1.3.7.ebuild:
+ By default, let the toolchain worry about kernel header location #172209 by
+ Karl Hiramoto.
04 Apr 2007; Gustavo Zacarias <gustavoz@gentoo.org> iptables-1.3.7.ebuild:
Stable on sparc
diff --git a/net-firewall/iptables/files/iptables-1.3.7-kernel-dir.patch b/net-firewall/iptables/files/iptables-1.3.7-kernel-dir.patch
new file mode 100644
index 000000000000..758bc3a0a228
--- /dev/null
+++ b/net-firewall/iptables/files/iptables-1.3.7-kernel-dir.patch
@@ -0,0 +1,18 @@
+let the toolchain figure out the default header location
+
+http://bugs.gentoo.org/172209
+
+--- Makefile
++++ Makefile
+@@ -37,7 +37,10 @@
+ endif
+
+ COPT_FLAGS:=-O2
+-CFLAGS:=$(COPT_FLAGS) -Wall -Wunused -I$(KERNEL_DIR)/include -Iinclude/ -DIPTABLES_VERSION=\"$(IPTABLES_VERSION)\" #-g -DDEBUG #-pg # -DIPTC_DEBUG
++CFLAGS:=$(COPT_FLAGS) -Wall -Wunused -Iinclude/ -DIPTABLES_VERSION=\"$(IPTABLES_VERSION)\" #-g -DDEBUG #-pg # -DIPTC_DEBUG
++ifneq ($(KERNEL_DIR),)
++CFLAGS += -I$(KERNEL_DIR)/include
++endif
+
+ ifdef NO_SHARED_LIBS
+ CFLAGS += -DNO_SHARED_LIBS=1
diff --git a/net-firewall/iptables/iptables-1.3.7.ebuild b/net-firewall/iptables/iptables-1.3.7.ebuild
index 0e12f12cbec0..fc5c315a4d74 100644
--- a/net-firewall/iptables/iptables-1.3.7.ebuild
+++ b/net-firewall/iptables/iptables-1.3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.7.ebuild,v 1.6 2007/04/04 12:55:29 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.7.ebuild,v 1.7 2007/04/08 17:51:44 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs linux-info
@@ -57,6 +57,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-more-exact-check-grep.patch #159162
epatch "${FILESDIR}"/${P}-sparc64.patch #166201
+ epatch "${FILESDIR}"/${P}-kernel-dir.patch #172209
EPATCH_OPTS="-p0" \
epatch "${FILESDIR}"/1.3.1-files/install_ipv6_apps.patch
@@ -110,7 +111,7 @@ src_defs() {
use static && myconf="${myconf} NO_SHARED_LIBS=0"
export myconf
if ! use l7filter && ! use imq && ! use extensions ; then
- export KERNEL_DIR="/usr"
+ export KERNEL_DIR=""
diemsg="failure"
else
diemsg="failure - with l7filter or imq patch added"