summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-25 17:00:00 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-25 17:00:00 +0000
commitbec2034977fdba7f3d6a3b1cd1f2e3255d9ef4c2 (patch)
treec86c88184e14a91afbbf7e3292d112fe504539a6 /net-firewall
parent(QA) Fix deps. bug #151232. (diff)
downloadgentoo-2-bec2034977fdba7f3d6a3b1cd1f2e3255d9ef4c2.tar.gz
gentoo-2-bec2034977fdba7f3d6a3b1cd1f2e3255d9ef4c2.tar.bz2
gentoo-2-bec2034977fdba7f3d6a3b1cd1f2e3255d9ef4c2.zip
Version bump #183146 by Blu3.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog7
-rw-r--r--net-firewall/iptables/files/digest-iptables-1.3.89
-rw-r--r--net-firewall/iptables/iptables-1.3.8.ebuild183
3 files changed, 198 insertions, 1 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 11c8ee4a68a4..8d2c10056f37 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.134 2007/05/12 08:45:03 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.135 2007/06/25 17:00:00 vapier Exp $
+
+*iptables-1.3.8 (25 Jun 2007)
+
+ 25 Jun 2007; Mike Frysinger <vapier@gentoo.org> +iptables-1.3.8.ebuild:
+ Version bump #183146 by Blu3.
12 May 2007; Joshua Kinard <kumba@gentoo.org> iptables-1.3.7.ebuild:
Stable on mips.
diff --git a/net-firewall/iptables/files/digest-iptables-1.3.8 b/net-firewall/iptables/files/digest-iptables-1.3.8
new file mode 100644
index 000000000000..121d177770e2
--- /dev/null
+++ b/net-firewall/iptables/files/digest-iptables-1.3.8
@@ -0,0 +1,9 @@
+MD5 9adae8be9562775a176fc1b275b3cb29 iptables-1.3.0-imq1.diff 5369
+RMD160 8ca1fa3bfea02d27232d8d8cb0a12586dd4537b5 iptables-1.3.0-imq1.diff 5369
+SHA256 0f9d36e48b3f1e83ef9e1d39c19e7271a889a31c65c396c416200eb143f1795b iptables-1.3.0-imq1.diff 5369
+MD5 0a9209f928002e5eee9cdff8fef4d4b3 iptables-1.3.8.tar.bz2 172584
+RMD160 851b223eef0ca008ad1f375aa0ebdab46ff6f886 iptables-1.3.8.tar.bz2 172584
+SHA256 c5c8a091ed9a1fa2dab86b4d87719064b50c202e8503046f50f299a361e6211c iptables-1.3.8.tar.bz2 172584
+MD5 ebf9043a5352ebe6dbd721989ef83dee netfilter-layer7-v2.9.tar.gz 122497
+RMD160 0398b8b61b24eb5d28309a53af0279e9f201318d netfilter-layer7-v2.9.tar.gz 122497
+SHA256 7db0e22297f7ecec41bb973733d6970bab922b4c54f779239616fa26a2315969 netfilter-layer7-v2.9.tar.gz 122497
diff --git a/net-firewall/iptables/iptables-1.3.8.ebuild b/net-firewall/iptables/iptables-1.3.8.ebuild
new file mode 100644
index 000000000000..1fed2199cb7b
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.3.8.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.8.ebuild,v 1.1 2007/06/25 17:00:00 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs linux-info
+
+L7_PV="2.9"
+L7_P="netfilter-layer7-v${L7_PV}"
+L7_PATCH="iptables-layer7-${L7_PV}.patch"
+IMQ_PATCH="iptables-1.3.0-imq1.diff"
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/ http://www.linuximq.net/ http://l7-filter.sf.net/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2
+ imq? ( http://www.linuximq.net/patchs/${IMQ_PATCH} )
+ l7filter? ( mirror://sourceforge/l7-filter/${L7_P}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="extensions imq ipv6 l7filter static"
+
+DEPEND="virtual/os-headers
+ l7filter? ( virtual/linux-sources )
+ imq? ( virtual/linux-sources )"
+RDEPEND=""
+
+pkg_setup() {
+ if use l7filter || use imq || use extensions ; then
+ ewarn "WARNING: 3rd party extensions has been enabled."
+ ewarn "This means that iptables will use your currently installed"
+ ewarn "kernel in ${KERNEL_DIR} as headers for iptables."
+ ewarn
+ if use extensions ; then
+ ewarn "You may have to patch your kernel to allow iptables to build."
+ ewarn "Please check http://ftp.netfilter.org/pub/patch-o-matic-ng/snapshot/ for patches"
+ ewarn "for your kernel."
+ ewarn
+ fi
+ linux-info_pkg_setup
+ fi
+
+ if use l7filter && \
+ [ ! -f "${KERNEL_DIR}/net/ipv4/netfilter/ipt_layer7.c" ]; then
+ die "For layer 7 support emerge net-misc/l7-filter-${L7_PV} before this"
+ fi
+ if use imq && \
+ [ ! -f "${KERNEL_DIR}/net/ipv4/netfilter/ipt_IMQ.c" ]; then
+ die "For IMQ support add a patch from http://www.linuximq.net/patches.html to your kernel"
+ fi
+}
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use l7filter && unpack ${L7_P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.3.7-sparc64.patch #166201
+ epatch "${FILESDIR}"/${PN}-1.3.7-kernel-dir.patch #172209
+
+ EPATCH_OPTS="-p0" \
+ epatch "${FILESDIR}"/1.3.1-files/install_ipv6_apps.patch
+ EPATCH_OPTS="-p1" \
+ epatch "${FILESDIR}"/1.3.1-files/install_all_dev_files.patch-1.3.1
+
+ # this provide's grsec's stealth match
+ EPATCH_OPTS="-p0" \
+ epatch "${FILESDIR}"/1.3.1-files/grsecurity-1.2.8-iptables.patch-1.3.1
+ sed -i \
+ -e "s/PF_EXT_SLIB:=/PF_EXT_SLIB:=stealth /g" \
+ extensions/Makefile || die "failed to enable stealth extension"
+
+ EPATCH_OPTS="-p1" \
+ epatch "${FILESDIR}"/1.3.1-files/${PN}-1.3.1-compilefix.patch
+
+ if use imq ; then
+ EPATCH_OPTS="-p1" epatch "${DISTDIR}"/${IMQ_PATCH}
+ chmod +x extensions/{.IMQ-test*,.childlevel-test*}
+ fi
+ if use l7filter ; then
+ EPATCH_OPTS="-p1" epatch "${WORKDIR}"/${L7_P}/${L7_PATCH}
+ chmod +x extensions/.layer7-test*
+ fi
+
+ # the net directory is moving around so account for new/old locations
+ cd "${S}"/extensions
+ local x
+ for x in .*-test* ; do
+ sed -e 's:net/ipv[46]/netfilter:net/netfilter:g' ${x} > .new-${x}
+ if cmp ${x} .new-${x} > /dev/null ; then
+ rm -f .new-${x}
+ else
+ chmod a+rx .new-${x}
+ fi
+ done
+}
+
+src_defs() {
+ # these are used in both of src_compile and src_install
+ myconf=""
+ myconf="${myconf} PREFIX="
+ myconf="${myconf} LIBDIR=/$(get_libdir)"
+ myconf="${myconf} BINDIR=/sbin"
+ myconf="${myconf} MANDIR=/usr/share/man"
+ myconf="${myconf} INCDIR=/usr/include"
+ # iptables and libraries are now installed to /sbin and /lib, so that
+ # systems with remote network-mounted /usr filesystems can get their
+ # network interfaces up and running correctly without /usr.
+ use ipv6 || myconf="${myconf} DO_IPV6=0"
+ use static && myconf="${myconf} NO_SHARED_LIBS=0"
+ export myconf
+ if ! use l7filter && ! use imq && ! use extensions ; then
+ export KERNEL_DIR=""
+ diemsg="failure"
+ else
+ diemsg="failure - with l7filter or imq patch added"
+ fi
+ export diemsg
+}
+
+src_compile() {
+ src_defs
+
+ # iptables will NOT work correctly unless -O[123] are present!
+ replace-flags -O0 -O2
+ get-flag -O || append-flags -O2
+
+ emake -j1 \
+ COPT_FLAGS="${CFLAGS}" ${myconf} \
+ KERNEL_DIR="${KERNEL_DIR}" \
+ CC="$(tc-getCC)" \
+ || die "${diemsg}"
+}
+
+src_install() {
+ src_defs
+ make ${myconf} \
+ DESTDIR="${D}" \
+ KERNEL_DIR="${KERNEL_DIR}" \
+ install install-devel || die "${diemsg}"
+
+ dodir /usr/$(get_libdir)
+ mv -f "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)
+
+ keepdir /var/lib/iptables
+ newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables
+ newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables
+
+ if use ipv6 ; then
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables
+ fi
+}
+
+pkg_postinst() {
+ elog "This package now includes an initscript which loads and saves"
+ elog "rules stored in /var/lib/iptables/rules-save"
+ use ipv6 && elog "and /var/lib/ip6tables/rules-save"
+ elog "This location can be changed in /etc/conf.d/iptables"
+ elog
+ elog "If you are using the iptables initsscript you should save your"
+ elog "rules using the new iptables version before rebooting."
+ elog
+ elog "If you are upgrading to a >=2.4.21 kernel you may need to rebuild"
+ elog "iptables."
+ elog
+ ewarn "!!! ipforwarding is not a part of the iptables initscripts."
+ ewarn
+ ewarn "To enable ipforwarding at bootup:"
+ ewarn "/etc/sysctl.conf and set net.ipv4.ip_forward = 1"
+ if use ipv6 ; then
+ ewarn "and/or"
+ ewarn " net.ipv6.ip_forward = 1"
+ ewarn "for ipv6."
+ fi
+ if has_version '=net-firewall/iptables-1.2*' ; then
+ ewarn
+ ewarn "When upgrading from iptables-1.2.x, you may be unable to remove"
+ ewarn "rules added with iptables-1.2.x. This is a known issue, please see:"
+ ewarn "http://bugs.gentoo.org/92535"
+ fi
+}