summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-01-09 20:35:29 +0000
committerSergey Popov <pinkbyte@gentoo.org>2015-01-09 20:35:29 +0000
commitd400c355f732c6442de5200810fd87d3695ed5af (patch)
tree1c4a95df845e2285af2096833fd8dd67cc04208e /net-firewall/ipt_netflow
parentVersion bump, EAPI=5, python-single-r1, fixes build with Perl 5.20, bug 536150 (diff)
downloadgentoo-2-d400c355f732c6442de5200810fd87d3695ed5af.tar.gz
gentoo-2-d400c355f732c6442de5200810fd87d3695ed5af.tar.bz2
gentoo-2-d400c355f732c6442de5200810fd87d3695ed5af.zip
Add version check for kernel sources to prevent building on unsupported kernels, drop old
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-firewall/ipt_netflow')
-rw-r--r--net-firewall/ipt_netflow/ChangeLog9
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-2.0-r1.ebuild84
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-2.0.1.ebuild5
3 files changed, 10 insertions, 88 deletions
diff --git a/net-firewall/ipt_netflow/ChangeLog b/net-firewall/ipt_netflow/ChangeLog
index 937b947bb3f7..840223d7841b 100644
--- a/net-firewall/ipt_netflow/ChangeLog
+++ b/net-firewall/ipt_netflow/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/ipt_netflow
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.17 2014/09/16 06:06:52 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.18 2015/01/09 20:35:29 pinkbyte Exp $
+
+ 09 Jan 2015; Sergey Popov <pinkbyte@gentoo.org> -ipt_netflow-2.0-r1.ebuild,
+ ipt_netflow-2.0.1.ebuild:
+ Add version check for kernel sources to prevent building on unsupported
+ kernels, drop old
*ipt_netflow-2.0.1 (16 Sep 2014)
diff --git a/net-firewall/ipt_netflow/ipt_netflow-2.0-r1.ebuild b/net-firewall/ipt_netflow/ipt_netflow-2.0-r1.ebuild
deleted file mode 100644
index d2ade4923940..000000000000
--- a/net-firewall/ipt_netflow/ipt_netflow-2.0-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ipt_netflow-2.0-r1.ebuild,v 1.1 2014/08/19 07:21:25 pinkbyte Exp $
-
-EAPI=5
-inherit eutils linux-info linux-mod multilib toolchain-funcs
-
-DESCRIPTION="Netflow iptables module"
-HOMEPAGE="http://sourceforge.net/projects/ipt-netflow"
-SRC_URI="mirror://sourceforge/ipt-netflow/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="debug pax_kernel"
-
-RDEPEND="net-firewall/iptables"
-DEPEND="${RDEPEND}
- virtual/linux-sources
- virtual/pkgconfig
-"
-
-# set S before MODULE_NAMES
-S="${WORKDIR}/${PN/_/-}-${PV}"
-
-BUILD_TARGETS="all"
-MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
-
-IPT_LIB="/usr/$(get_libdir)/xtables"
-
-pkg_setup() {
- local CONFIG_CHECK="~IP_NF_IPTABLES"
- use debug && CONFIG_CHECK+=" ~DEBUG_FS"
- linux-mod_pkg_setup
-}
-
-src_prepare() {
- sed -i \
- -e 's:make -C:$(MAKE) -C:g' \
- -e 's:gcc -O2:$(CC) $(CFLAGS) $(LDFLAGS):' \
- -e 's:gcc:$(CC) $(CFLAGS) $(LDFLAGS):' \
- Makefile.in || die
-
- # bug #455984
- epatch "${FILESDIR}/${PN}-2.0-configure.patch"
-
- # bugs #466430 and #519480
- if use pax_kernel; then
- epatch "${FILESDIR}/${PN}-2.0-pax-const.patch"
- fi
-
- epatch_user
-}
-
-do_conf() {
- echo ./configure $*
- ./configure $* || die 'configure failed'
-}
-
-src_configure() {
- local IPT_VERSION="$($(tc-getPKG_CONFIG) --modversion xtables)"
- # econf can not be used, cause configure script fails when see unknown parameter
- # ipt-src need to be defined, see bug #455984
- do_conf \
- --ipt-lib="${IPT_LIB}" \
- --ipt-src="/usr/" \
- --ipt-ver="${IPT_VERSION}" \
- --kdir="${KV_DIR}" \
- --kver="${KV_FULL}" \
- $(use debug && echo '--enable-debugfs')
-}
-
-src_compile() {
- emake ARCH="$(tc-arch-kernel)" CC="$(tc-getCC)" all
-}
-
-src_install() {
- linux-mod_src_install
- exeinto "${IPT_LIB}"
- doexe libipt_NETFLOW.so
- doheader ipt_NETFLOW.h
- dodoc README*
-}
diff --git a/net-firewall/ipt_netflow/ipt_netflow-2.0.1.ebuild b/net-firewall/ipt_netflow/ipt_netflow-2.0.1.ebuild
index dd61633afaec..9b5cd6cd633b 100644
--- a/net-firewall/ipt_netflow/ipt_netflow-2.0.1.ebuild
+++ b/net-firewall/ipt_netflow/ipt_netflow-2.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ipt_netflow-2.0.1.ebuild,v 1.1 2014/09/16 06:06:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ipt_netflow-2.0.1.ebuild,v 1.2 2015/01/09 20:35:29 pinkbyte Exp $
EAPI=5
inherit eutils linux-info linux-mod multilib toolchain-funcs
@@ -32,6 +32,7 @@ IPT_LIB="/usr/$(get_libdir)/xtables"
pkg_setup() {
local CONFIG_CHECK="~IP_NF_IPTABLES"
use debug && CONFIG_CHECK+=" ~DEBUG_FS"
+ kernel_is -gt 3 16 && die "${P} requires kernel version < 3.17"
linux-mod_pkg_setup
}