summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2008-02-21 15:54:02 +0000
committerPatrick McLean <chutzpah@gentoo.org>2008-02-21 15:54:02 +0000
commit6cf54aa62e3bb2b5276b04077b1e7dad66f3064e (patch)
treecb993e945e9bd18de8e9dc2488d2855bcd4656da /net-dns
parentVersion bump. (diff)
downloadgentoo-2-6cf54aa62e3bb2b5276b04077b1e7dad66f3064e.tar.gz
gentoo-2-6cf54aa62e3bb2b5276b04077b1e7dad66f3064e.tar.bz2
gentoo-2-6cf54aa62e3bb2b5276b04077b1e7dad66f3064e.zip
Add ipv6 USE flag, fixes bugs #209913 and #210896. Fix some variable quoting problems in older versions.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnsmasq/ChangeLog7
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.39.ebuild8
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.40.ebuild6
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.41.ebuild5
4 files changed, 16 insertions, 10 deletions
diff --git a/net-dns/dnsmasq/ChangeLog b/net-dns/dnsmasq/ChangeLog
index 4cfbb227f892..633ff153ba81 100644
--- a/net-dns/dnsmasq/ChangeLog
+++ b/net-dns/dnsmasq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/dnsmasq
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.144 2008/02/17 08:38:40 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.145 2008/02/21 15:54:02 chutzpah Exp $
+
+ 21 Feb 2008; Patrick McLean <chutzpah@gentoo.org> dnsmasq-2.39.ebuild,
+ dnsmasq-2.40.ebuild, dnsmasq-2.41.ebuild:
+ Add ipv6 USE flag, fixes bugs #209913 and #210896. Fix some variable quoting
+ problems in older versions.
17 Feb 2008; Christian Faulhammer <opfer@gentoo.org> dnsmasq-2.40.ebuild:
stable amd64, bug 195615
diff --git a/net-dns/dnsmasq/dnsmasq-2.39.ebuild b/net-dns/dnsmasq/dnsmasq-2.39.ebuild
index 8589ee9c08e3..b9ecc5b8ebb7 100644
--- a/net-dns/dnsmasq/dnsmasq-2.39.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.39.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.39.ebuild,v 1.11 2007/08/04 11:25:19 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.39.ebuild,v 1.12 2008/02/21 15:54:02 chutzpah Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -24,7 +24,7 @@ S=${WORKDIR}/${PN}-${MY_PV}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# dnsmasq on FreeBSD wants the config file in a silly location, this fixes
epatch "${FILESDIR}/${PN}-fbsd-config.patch"
@@ -58,6 +58,6 @@ src_install() {
if use resolvconf ; then
exeinto /etc/resolvconf/update.d
- newexe ${FILESDIR}/resolvconf.dnsmasq dnsmasq
+ newexe "${FILESDIR}"/resolvconf.dnsmasq dnsmasq
fi
}
diff --git a/net-dns/dnsmasq/dnsmasq-2.40.ebuild b/net-dns/dnsmasq/dnsmasq-2.40.ebuild
index 5bcea9800995..da758472ce2b 100644
--- a/net-dns/dnsmasq/dnsmasq-2.40.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.40.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.40.ebuild,v 1.7 2008/02/17 08:38:40 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.40.ebuild,v 1.8 2008/02/21 15:54:02 chutzpah Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -24,7 +24,7 @@ S=${WORKDIR}/${PN}-${MY_PV}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# dnsmasq on FreeBSD wants the config file in a silly location, this fixes
epatch "${FILESDIR}/${PN}-fbsd-config.patch"
@@ -58,6 +58,6 @@ src_install() {
if use resolvconf ; then
exeinto /etc/resolvconf/update.d
- newexe ${FILESDIR}/resolvconf.dnsmasq dnsmasq
+ newexe "${FILESDIR}"/resolvconf.dnsmasq dnsmasq
fi
}
diff --git a/net-dns/dnsmasq/dnsmasq-2.41.ebuild b/net-dns/dnsmasq/dnsmasq-2.41.ebuild
index 070a4d026470..4d6b12f5cba5 100644
--- a/net-dns/dnsmasq/dnsmasq-2.41.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.41.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.41.ebuild,v 1.2 2008/02/15 15:17:15 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.41.ebuild,v 1.3 2008/02/21 15:54:02 chutzpah Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -13,7 +13,7 @@ SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="dbus isc tftp"
+IUSE="dbus ipv6 isc tftp"
RDEPEND=""
DEPEND="${RDEPEND}
@@ -31,6 +31,7 @@ src_unpack() {
src_compile() {
use tftp || append-flags -DNO_TFTP
+ use ipv6 || append-flags -DNO_IPV6
use isc && append-flags -DHAVE_ISC_READER
use dbus && sed -i '$ a #define HAVE_DBUS' src/config.h