summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2012-02-05 02:34:02 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2012-02-05 02:34:02 +0000
commit3b822483482437859f0e3cd916b79906f54e0b56 (patch)
tree3244f7c5e1dff6798ddadfc034234197acd82467 /net-dns
parentrestore kernel.org mirrors for hjlu snapshots (diff)
downloadgentoo-2-3b822483482437859f0e3cd916b79906f54e0b56.tar.gz
gentoo-2-3b822483482437859f0e3cd916b79906f54e0b56.tar.bz2
gentoo-2-3b822483482437859f0e3cd916b79906f54e0b56.zip
Versionbumped. The ebuild is submitted by TANABE Ken-ichi.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/unbound/ChangeLog7
-rw-r--r--net-dns/unbound/unbound-1.4.16.ebuild109
2 files changed, 115 insertions, 1 deletions
diff --git a/net-dns/unbound/ChangeLog b/net-dns/unbound/ChangeLog
index 048c1e1a0a0c..399b60cb0284 100644
--- a/net-dns/unbound/ChangeLog
+++ b/net-dns/unbound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/unbound
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.35 2012/01/30 15:58:00 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.36 2012/02/05 02:34:02 matsuu Exp $
+
+*unbound-1.4.16 (05 Feb 2012)
+
+ 05 Feb 2012; MATSUU Takuto <matsuu@gentoo.org> +unbound-1.4.16.ebuild:
+ Versionbumped. The ebuild is submitted by TANABE Ken-ichi.
*unbound-1.4.15 (30 Jan 2012)
diff --git a/net-dns/unbound/unbound-1.4.16.ebuild b/net-dns/unbound/unbound-1.4.16.ebuild
new file mode 100644
index 000000000000..45a51b7328ec
--- /dev/null
+++ b/net-dns/unbound/unbound-1.4.16.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.16.ebuild,v 1.1 2012/02/05 02:34:02 matsuu Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils flag-o-matic python
+
+DESCRIPTION="A validating, recursive and caching DNS resolver"
+HOMEPAGE="http://unbound.net/"
+SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="debug gost python static-libs test threads"
+
+RDEPEND="dev-libs/expat
+ dev-libs/libevent
+ >=dev-libs/openssl-0.9.8
+ >=net-libs/ldns-1.6.5[ssl,gost?]"
+
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ test? (
+ net-dns/ldns-utils[examples]
+ dev-util/splint
+ app-text/wdiff
+ )"
+
+# bug #347415
+RDEPEND="${RDEPEND}
+ net-dns/dnssec-root"
+
+pkg_setup() {
+ enewgroup unbound
+ enewuser unbound -1 -1 /etc/unbound unbound
+
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ # To avoid below error messages, set 'trust-anchor-file' to same value in
+ # 'auto-trust-anchor-file'.
+ # [23109:0] error: Could not open autotrust file for writing,
+ # /etc/dnssec/root-anchors.txt: Permission denied
+ epatch "${FILESDIR}/${PN}-1.4.12-gentoo.patch"
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack || die
+ econf \
+ --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
+ --with-ldns="${EPREFIX}"/usr \
+ --with-libevent="${EPREFIX}"/usr \
+ --with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt \
+ $(use_enable debug) \
+ $(use_enable gost) \
+ $(use_enable static-libs static) \
+ $(use_with threads pthreads) \
+ $(use_with python pyunbound) \
+ $(use_with python pythonmodule) \
+ --disable-rpath || die
+
+ # http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
+ # $(use_enable debug lock-checks) \
+ # $(use_enable debug alloc-checks) \
+ # $(use_enable debug alloc-lite) \
+ # $(use_enable debug alloc-nonregional) \
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # bug #299016
+ if use python ; then
+ find "${ED}" -name '_unbound.{la,a}' -delete || die
+ fi
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
+ fi
+
+ newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
+ newconfd "${FILESDIR}/unbound.confd" unbound || die "newconfd failed"
+
+ dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES} || die "dodoc failed"
+
+ # bug #315519
+ #exeinto /usr/libexec/munin/plugins
+ #doexe contrib/unbound_munin_ || die "doexe failed"
+ dodoc contrib/unbound_munin_ || die "dodoc failed"
+
+ docinto selinux
+ dodoc contrib/selinux/* || die "dodoc failed"
+
+ exeinto /usr/share/${PN}
+ doexe contrib/update-anchor.sh || die "doexe failed"
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize unbound.py unboundmodule.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup unbound.py unboundmodule.py
+}