summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2015-02-12 18:14:32 +0000
committerSven Wegener <swegener@gentoo.org>2015-02-12 18:14:32 +0000
commit77b19aa3cd796efffef195992a73650741a37756 (patch)
treee5c9993230a4c8d333ecbd52e69caa617402df61 /net-dns/pdns-recursor
parentfix compile error with 2.4 userland, bug 539462 (diff)
downloadgentoo-2-77b19aa3cd796efffef195992a73650741a37756.tar.gz
gentoo-2-77b19aa3cd796efffef195992a73650741a37756.tar.bz2
gentoo-2-77b19aa3cd796efffef195992a73650741a37756.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x64D4CF24)
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/ChangeLog9
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-3.7.1.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/net-dns/pdns-recursor/ChangeLog b/net-dns/pdns-recursor/ChangeLog
index 863ccbc18c7f..55d6c40c4719 100644
--- a/net-dns/pdns-recursor/ChangeLog
+++ b/net-dns/pdns-recursor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/pdns-recursor
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.53 2014/12/21 18:55:35 zlogene Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.54 2015/02/12 18:14:32 swegener Exp $
+
+*pdns-recursor-3.7.1 (12 Feb 2015)
+
+ 12 Feb 2015; Sven Wegener <swegener@gentoo.org> +pdns-recursor-3.7.1.ebuild:
+ Version bump.
21 Dec 2014; Mikle Kolyada <zlogene@gentoo.org> pdns-recursor-3.6.1-r1.ebuild:
amd64/x86 stable wrt bug #531992
diff --git a/net-dns/pdns-recursor/pdns-recursor-3.7.1.ebuild b/net-dns/pdns-recursor/pdns-recursor-3.7.1.ebuild
new file mode 100644
index 000000000000..37f94a1cde5d
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-3.7.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.7.1.ebuild,v 1.1 2015/02/12 18:14:32 swegener Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="http://www.powerdns.com/"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua"
+
+DEPEND="lua? ( >=dev-lang/lua-5.1 )"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+DEPEND="${DEPEND}
+ >=dev-libs/boost-1.33.1"
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ OPTFLAGS="" \
+ LUA_LIBS_CONFIG="-llua" \
+ LUA_CPPFLAGS_CONFIG="" \
+ LUA="$(use lua && echo 1)" \
+ ./configure
+}
+
+src_compile() {
+ emake \
+ LOCALSTATEDIR=/var/lib/powerdns \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ OPTFLAGS="" \
+ LUA_LIBS_CONFIG="-llua" \
+ LUA_CPPFLAGS_CONFIG="" \
+ LUA="$(use lua && echo 1)"
+}
+
+src_install() {
+ dosbin pdns_recursor rec_control
+ doman pdns_recursor.1 rec_control.1
+
+ insinto /etc/powerdns
+ doins "${FILESDIR}"/recursor.conf
+
+ doinitd "${FILESDIR}"/precursor
+
+ # Pretty ugly, uh?
+ dodir /var/lib/powerdns/var/lib
+ dosym ../.. /var/lib/powerdns/var/lib/powerdns
+}