summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-20 08:23:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-20 08:23:45 +0000
commit4d9d489fe1dffff1edb6180d00c551a4bb93a3f4 (patch)
tree9b6ffbb0f5a0aa9b6b1afc68561edc813436447b /net-dns/ndu/ndu-0.4.ebuild
parentinitial commit (diff)
downloadgentoo-2-4d9d489fe1dffff1edb6180d00c551a4bb93a3f4.tar.gz
gentoo-2-4d9d489fe1dffff1edb6180d00c551a4bb93a3f4.tar.bz2
gentoo-2-4d9d489fe1dffff1edb6180d00c551a4bb93a3f4.zip
initial commit
Diffstat (limited to 'net-dns/ndu/ndu-0.4.ebuild')
-rw-r--r--net-dns/ndu/ndu-0.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-dns/ndu/ndu-0.4.ebuild b/net-dns/ndu/ndu-0.4.ebuild
new file mode 100644
index 000000000000..4134d612e0c5
--- /dev/null
+++ b/net-dns/ndu/ndu-0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ndu/ndu-0.4.ebuild,v 1.1 2003/08/20 08:23:42 robbat2 Exp $
+
+DESCRIPTION="DNS serial number incrementer and reverse zone builder"
+URI_BASE="http://uranus.it.swin.edu.au/~jn/linux/"
+SRC_URI="${URI_BASE}/${P}.tar.gz"
+HOMEPAGE="${URI_BASE}/dns.htm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="sys-apps/sed virtual/glibc"
+RDEPEND="net-dns/bind virtual/glibc"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ cd ${S}/src
+ sed -i 's|gcc|$(CXX)|g' Makefile
+ sed -i 's|#define CONFIG_PATH "/etc/"|#define CONFIG_PATH "/etc/bind/"|g' ndc.c
+ emake
+ sed -i 's|VISUAL|EDITOR|g' dnsedit
+ cd ${S}
+ sed -i 's|0.0.127.in-addr.arpa|127.in-addr.arpa|g' ndu.conf
+ echo '## if you use a chrooted setup, then you need to uncomment these lines:' >>ndu.conf
+ echo '#process "/chroot/dns/named.conf"' >>ndu.conf
+ echo '#chroot "/chroot/dns"' >>ndu.conf
+}
+
+src_install () {
+ into /usr
+ dosbin src/{dnsedit,ndu}
+ dobin src/dnstouch
+ into /
+ insinto /etc/bind
+ doins ndu.conf
+ dodoc README INSTALL
+}