summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-11 11:00:14 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-11 11:00:14 +0000
commit411182c00fc71eed832eff87c7647ce594f824de (patch)
treeb1114fcbb66991a532b9f172da7646a3cb054264 /net-dns/maradns
parentFix help file location - bug #424437 (diff)
downloadgentoo-2-411182c00fc71eed832eff87c7647ce594f824de.tar.gz
gentoo-2-411182c00fc71eed832eff87c7647ce594f824de.tar.bz2
gentoo-2-411182c00fc71eed832eff87c7647ce594f824de.zip
Use a patch to fix build makefiles, as the sed was not good enough. This actually fixes both sides of bug #413989 (build failure with --as-needed and missing failure to make).
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/maradns')
-rw-r--r--net-dns/maradns/ChangeLog8
-rw-r--r--net-dns/maradns/files/maradns-2.0.06-build.patch54
-rw-r--r--net-dns/maradns/maradns-2.0.06.ebuild32
3 files changed, 66 insertions, 28 deletions
diff --git a/net-dns/maradns/ChangeLog b/net-dns/maradns/ChangeLog
index a6dbfddbe55b..406514188f6c 100644
--- a/net-dns/maradns/ChangeLog
+++ b/net-dns/maradns/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/maradns
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/maradns/ChangeLog,v 1.52 2012/06/14 02:13:48 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/maradns/ChangeLog,v 1.53 2012/07/11 11:00:14 flameeyes Exp $
+
+ 11 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/maradns-2.0.06-build.patch, maradns-2.0.06.ebuild:
+ Use a patch to fix build makefiles, as the sed was not good enough. This
+ actually fixes both sides of bug #413989 (build failure with --as-needed and
+ missing failure to make).
14 Jun 2012; Zac Medico <zmedico@gentoo.org> maradns-1.4.09.ebuild,
maradns-1.4.11.ebuild, maradns-1.4.12.ebuild, maradns-2.0.06.ebuild:
diff --git a/net-dns/maradns/files/maradns-2.0.06-build.patch b/net-dns/maradns/files/maradns-2.0.06-build.patch
new file mode 100644
index 000000000000..4a358b61a5d6
--- /dev/null
+++ b/net-dns/maradns/files/maradns-2.0.06-build.patch
@@ -0,0 +1,54 @@
+Index: maradns-2.0.06/build/Makefile.linux
+===================================================================
+--- maradns-2.0.06.orig/build/Makefile.linux
++++ maradns-2.0.06/build/Makefile.linux
+@@ -10,7 +10,7 @@ POBJECTS=parse/ParseMaraRc.o parse/Parse
+ DOBJECTS=dns/Queries.o dns/Compress.o dns/bobbit.o
+ # Secure random number generator objects
+ ROBJECTS=rng/rng-api-fst.o rng/rng-alg-fst.o
+-OBJECTS=$(JOBJS) $(MHOBJS) $(SOBJECTS) $(DOBJECTS) $(POBJECTS) $(DOBJECTS) $(ROBJECTS)
++OBJECTS=$(JOBJS) $(MHOBJS) $(SOBJECTS) $(DOBJECTS) $(POBJECTS) $(DOBJECTS) $(ROBJECTS) -lrt
+ EXECS=server/maradns
+
+ # Uncomment the following three lines to get this to compile on Solaris
+@@ -28,19 +28,21 @@ Q="DEFINES=-DSELECT_PROBLEM"
+
+ # Debug
+
+-FLAGS = -O2 -Wall -DSELECT_PROBLEM
++FLAGS=$(CFLAGS) $(LDFLAGS) -Wall -DSELECT_PROBLEM
+ M="CC=$(CC) $(FLAGS)"
+ D="CC=$(CC) $(FLAGS) -DDEBUG -DTHREADS"
+ #FLAGS = -g
+
+ all:
+- cd libs ; make $(M) ; cd ../dns ; make $(M) ; \
+- cd ../rng ; make $(M) ; cd ../parse ; make $(M) ; \
+- cd ../qual ; make $(M) ; cd ../server ; \
+- make $(M) $(V) COMPILED=\"$(COMPILED)\" ; \
+- cd ../tools ; make $(M) ; \
+- cd ../deadwood-*/src/ ; make FLAGS=-O2 ; \
+- cd ../../tcp ; make $(M) $(V) ; cat ../00README.FIRST
++ $(MAKE) -C libs $(M)
++ $(MAKE) -C dns $(M)
++ $(MAKE) -C rng $(M)
++ $(MAKE) -C parse $(M)
++ $(MAKE_ -C qual $(M)
++ $(MAKE) -C server $(M) $(V) COMPILED=\"$(COMPILED)\"
++ $(MAKE) -C tools $(M)
++ $(MAKE) -C deadwood-*/src $(M)
++ $(MAKE) -C tcp $(M) $(V)
+
+ debug:
+ cd libs ; make $(D) DEBUG="-DDEBUG -DTHREADS" ; \
+Index: maradns-2.0.06/deadwood-3.2.02/src/Makefile.ipv6
+===================================================================
+--- maradns-2.0.06.orig/deadwood-3.2.02/src/Makefile.ipv6
++++ maradns-2.0.06/deadwood-3.2.02/src/Makefile.ipv6
+@@ -86,5 +86,5 @@ Test: Test.c DwStr.o DwStr.h DwStr_func
+ $(CC) $(FLAGS) -Wall -o Test Test.c $(OBJS)
+
+ Deadwood: DwMain.c $(OBJS) DwStr_functions.h version.h
+- $(CC) $(FLAGS) -DIPV6 -Wall -o Deadwood DwMain.c $(OBJS)
++ $(CC) $(FLAGS) -DIPV6 -Wall -o Deadwood DwMain.c $(OBJS) -lrt
+
diff --git a/net-dns/maradns/maradns-2.0.06.ebuild b/net-dns/maradns/maradns-2.0.06.ebuild
index 40e104ca836b..f9b409a1590f 100644
--- a/net-dns/maradns/maradns-2.0.06.ebuild
+++ b/net-dns/maradns/maradns-2.0.06.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/maradns/maradns-2.0.06.ebuild,v 1.2 2012/06/14 02:13:48 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/maradns/maradns-2.0.06.ebuild,v 1.3 2012/07/11 11:00:14 flameeyes Exp $
EAPI="4"
inherit eutils toolchain-funcs flag-o-matic user
@@ -26,19 +26,8 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-askmara-tcp.patch
epatch "${FILESDIR}"/${P}-duende-man.patch
- # In order for Deadwood to build correctly, it needs to know where
- # clock_getttime is at, and on Linux/glibc, this is in librt.
- # Hopefully, other systems won't have issues.
- use elibc_glibc && myflags="-lrt"
-
- # Honor system CFLAGS.
- # Need to append -lrt to build Deadwood properly.
- sed -i \
- -e "s:FLAGS=-O2:\$(M):g" \
- -e "s:-O2:\$(CFLAGS) \$(LDFLAGS) ${myflags}:" \
- -e "s:\$(CC):$(tc-getCC):g" \
- -e "s:make:\$(MAKE):g" \
- build/Makefile.linux || die
+ # And one from Gentoo
+ epatch "${FILESDIR}"/${P}-build.patch
}
src_configure() {
@@ -47,23 +36,12 @@ src_configure() {
# Use duende-ng.c.
cp "${S}/tools/duende-ng.c" "${S}/tools/duende.c"
+ tc-export CC
+
use ipv6 && myconf="${myconf} --ipv6"
./configure ${myconf} || die "Failed to configure ${PN}."
}
-src_compile() {
- make ${MAKEOPTS} || die "Filed to compile ${PN}."
-
- # On linux/glibc, we forced -lrt into the build flags to make sure
- # that clock_getttime() was found in the correct library. But to
- # catch this error on other platforms, we'll see if DwSys.o is
- # present, which indicates a successful build or not.
- [[ ! -f "${S}/deadwood-${DEADWOOD_VER}/src/DwSys.o" ]] \
- && die "Deadwood failed to build, possibly due to a " \
- "missing reference to clock_gettime. Please " \
- "report this in a bug!"
-}
-
src_install() {
# Install the MaraDNS binaries.
dosbin server/maradns