summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-12-29 11:06:56 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-12-29 11:06:56 +0000
commit32b67f4311d07c945bbecef79157c7e418be0095 (patch)
treee0e9946aa078129134e61341aed950bb1cd9daae /net-dns/knot/knot-0.8.1.ebuild
parentInitial commit. Package required for knot dns and others. Added to base-syste... (diff)
downloadgentoo-2-32b67f4311d07c945bbecef79157c7e418be0095.tar.gz
gentoo-2-32b67f4311d07c945bbecef79157c7e418be0095.tar.bz2
gentoo-2-32b67f4311d07c945bbecef79157c7e418be0095.zip
Initial commit of knot dns authoritative server used by NIC.cz. Added to herd bind as it is closest herd. Can't do much runtime testing on gentoo but possibly can fix packaging errors.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/knot/knot-0.8.1.ebuild')
-rw-r--r--net-dns/knot/knot-0.8.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-dns/knot/knot-0.8.1.ebuild b/net-dns/knot/knot-0.8.1.ebuild
new file mode 100644
index 000000000000..ef8e27555cbd
--- /dev/null
+++ b/net-dns/knot/knot-0.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/knot-0.8.1.ebuild,v 1.1 2011/12/29 11:06:56 scarabeus Exp $
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="http://www.knot-dns.cz/"
+SRC_URI="http://public.nic.cz/files/knot-dns/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/openssl
+ dev-libs/userspace-rcu
+"
+# sys-libs/glibc
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+"
+
+src_prepare() {
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
+ --libexecdir="${EPREFIX}/usr/libexec/${PN}" \
+ --enable-recvmmsg \
+ $(use_enable debug debug verbose)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/knot.init" knot-dns
+}