summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-11 11:18:37 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-11 11:18:37 +0000
commit42c2db2e16c59164d15d1acd68c7a78f201ef8ff (patch)
tree33a77809314fc923178a3178246ecc3c7095f919 /net-dns/hesinfo/hesinfo-3.1.0.ebuild
parents390/sparc stable wrt #321951, drop alpha (diff)
downloadgentoo-2-42c2db2e16c59164d15d1acd68c7a78f201ef8ff.tar.gz
gentoo-2-42c2db2e16c59164d15d1acd68c7a78f201ef8ff.tar.bz2
gentoo-2-42c2db2e16c59164d15d1acd68c7a78f201ef8ff.zip
Initial commit. Fixes bug #309179. Thanks to Doktor Notor <notordoktor@gmail.com> for the ebuild
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/hesinfo/hesinfo-3.1.0.ebuild')
-rw-r--r--net-dns/hesinfo/hesinfo-3.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-dns/hesinfo/hesinfo-3.1.0.ebuild b/net-dns/hesinfo/hesinfo-3.1.0.ebuild
new file mode 100644
index 000000000000..01394e1f34f8
--- /dev/null
+++ b/net-dns/hesinfo/hesinfo-3.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/hesinfo/hesinfo-3.1.0.ebuild,v 1.1 2010/07/11 11:18:36 hwoarang Exp $
+
+EAPI="2"
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="A simple command-line interface to the net-dns/hesiod service library"
+HOMEPAGE="ftp://athena-dist.mit.edu/pub/ATHENA/hesiod"
+SRC_URI="ftp://athena-dist.mit.edu/pub/ATHENA/hesiod/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=net-dns/hesiod-${PV}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rm -f aclocal.m4 || die "rm failed"
+ epatch "${FILESDIR}/${P}-autotools.patch"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc NEWS README || die
+}