summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-19 19:14:47 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-19 19:14:47 +0000
commit4cf727f52dba3ddeb4d7673a8d82efe7f4b8667f (patch)
treecc1f5366a5f4afd2ad2545b19890fd174cf1ce2b /net-dns/avahi/avahi-0.6.25.ebuild
parentVersion Bump, Python ABIs fixes #316249 thanks Arfrever for helping me, EAPI=3 (diff)
downloadgentoo-2-4cf727f52dba3ddeb4d7673a8d82efe7f4b8667f.tar.gz
gentoo-2-4cf727f52dba3ddeb4d7673a8d82efe7f4b8667f.tar.bz2
gentoo-2-4cf727f52dba3ddeb4d7673a8d82efe7f4b8667f.zip
Use Python 2 (bug #315093).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/avahi/avahi-0.6.25.ebuild')
-rw-r--r--net-dns/avahi/avahi-0.6.25.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/net-dns/avahi/avahi-0.6.25.ebuild b/net-dns/avahi/avahi-0.6.25.ebuild
index cac6c381b30e..92d55563a341 100644
--- a/net-dns/avahi/avahi-0.6.25.ebuild
+++ b/net-dns/avahi/avahi-0.6.25.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.25.ebuild,v 1.5 2010/01/03 15:23:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.25.ebuild,v 1.6 2010/05/19 19:14:47 arfrever Exp $
EAPI="1"
+PYTHON_DEPEND="python? 2"
inherit eutils mono python multilib autotools flag-o-matic
@@ -43,7 +44,6 @@ RDEPEND=">=dev-libs/libdaemon-0.11-r1
howl-compat? ( !net-misc/howl )
mdnsresponder-compat? ( !net-misc/mDNSResponder )
python? (
- >=virtual/python-2.4
gtk? ( >=dev-python/pygtk-2 )
)
bookmarks? (
@@ -60,7 +60,12 @@ DEPEND="${RDEPEND}
)"
pkg_setup() {
- if use python && ! built_with_use dev-lang/python gdbm
+ if use python
+ then
+ python_set_active_version 2
+ fi
+
+ if use python && ! built_with_use "=dev-lang/python-2*" gdbm
then
die "For python support you need dev-lang/python compiled with gdbm support!"
fi
@@ -153,8 +158,7 @@ src_compile() {
--disable-qt3 \
$(use_enable qt4) \
$(use_enable gdbm) \
- ${myconf} \
- || die "econf failed"
+ ${myconf}
emake || die "emake failed"
use doc && emake avahi.devhelp
@@ -187,13 +191,14 @@ src_install() {
}
pkg_postrm() {
- use python && python_mod_cleanup
+ if use python; then
+ python_mod_cleanup $(python_get_sitedir)/avahi $(python_get_sitedir)/avahi_discover
+ fi
}
pkg_postinst() {
if use python; then
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/avahi
+ python_mod_optimize $(python_get_sitedir)/avahi $(python_get_sitedir)/avahi_discover
fi
if use autoipd