summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-06-22 15:34:04 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-06-22 15:34:04 +0000
commitefa02b1a131e4e189f7a80015d10fcf2a589fd59 (patch)
treec70c8777ae4cb6b427fcfea2f1c5ed105d92e3ce /net-dialup
parentmedia-libs/sg: Add missing dep, #514052 (diff)
downloadgentoo-2-efa02b1a131e4e189f7a80015d10fcf2a589fd59.tar.gz
gentoo-2-efa02b1a131e4e189f7a80015d10fcf2a589fd59.tar.bz2
gentoo-2-efa02b1a131e4e189f7a80015d10fcf2a589fd59.zip
Improve fix for bug #511800 by utilizing versionator eclass
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/capi4k-utils/ChangeLog6
-rw-r--r--net-dialup/capi4k-utils/capi4k-utils-20050718-r6.ebuild7
2 files changed, 9 insertions, 4 deletions
diff --git a/net-dialup/capi4k-utils/ChangeLog b/net-dialup/capi4k-utils/ChangeLog
index cc19101f4196..400f2a24945b 100644
--- a/net-dialup/capi4k-utils/ChangeLog
+++ b/net-dialup/capi4k-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/capi4k-utils
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/ChangeLog,v 1.77 2014/06/16 12:19:03 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/ChangeLog,v 1.78 2014/06/22 15:34:04 pinkbyte Exp $
+
+ 22 Jun 2014; Sergey Popov <pinkbyte@gentoo.org>
+ capi4k-utils-20050718-r6.ebuild:
+ Improve fix for bug #511800 by utilizing versionator eclass
16 Jun 2014; Sergey Popov <pinkbyte@gentoo.org>
capi4k-utils-20050718-r6.ebuild:
diff --git a/net-dialup/capi4k-utils/capi4k-utils-20050718-r6.ebuild b/net-dialup/capi4k-utils/capi4k-utils-20050718-r6.ebuild
index b641f1b064c3..89fd1ec6efb8 100644
--- a/net-dialup/capi4k-utils/capi4k-utils-20050718-r6.ebuild
+++ b/net-dialup/capi4k-utils/capi4k-utils-20050718-r6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/capi4k-utils-20050718-r6.ebuild,v 1.2 2014/06/16 12:19:03 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/capi4k-utils-20050718-r6.ebuild,v 1.3 2014/06/22 15:34:04 pinkbyte Exp $
EAPI=5
-inherit eutils linux-info multilib
+inherit eutils linux-info multilib versionator
YEAR_PV="${PV:0:4}"
MON_PV="${PV:4:2}"
@@ -50,6 +50,7 @@ pkg_setup() {
if use pppd; then
local INSTALLED_PPP="$(best_version net-dialup/ppp)"
PPPVERSION="${INSTALLED_PPP#net-dialup/ppp-}"
+ PPPVERSION="$(version_format_string '$1.$2.$3' ${PPPVERSION})"
if [ -z "${PPPVERSION}" ]; then
die "No pppd installation found"
fi
@@ -101,7 +102,7 @@ src_prepare() {
# workaround for bug #511800
if has_version \>=net-dialup/ppp-2.4.6; then
pushd pppdcapiplugin &>/dev/null || die
- ln -s ppp-2.4.5 "ppp-${PPPVERSION}" || die
+ mv ppp-2.4.5 "ppp-${PPPVERSION}" || die
popd &>/dev/null
fi
else