summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-05-14 10:17:20 +0000
committerSergey Popov <pinkbyte@gentoo.org>2015-05-14 10:17:20 +0000
commit6e2b152e8b7b8cc6e7134a7f26ae0b493a71bdc2 (patch)
treead0df57b58145c32e6de2115971ea4cd13940d9c /net-dialup
parentFix a parallel make issue where ncat is being built when liblua has not yet b... (diff)
downloadgentoo-2-6e2b152e8b7b8cc6e7134a7f26ae0b493a71bdc2.tar.gz
gentoo-2-6e2b152e8b7b8cc6e7134a7f26ae0b493a71bdc2.tar.bz2
gentoo-2-6e2b152e8b7b8cc6e7134a7f26ae0b493a71bdc2.zip
Initial commit
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x60C0742D1F357D42)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ppp-scripts/ChangeLog10
-rw-r--r--net-dialup/ppp-scripts/metadata.xml5
-rw-r--r--net-dialup/ppp-scripts/ppp-scripts-0.ebuild28
3 files changed, 43 insertions, 0 deletions
diff --git a/net-dialup/ppp-scripts/ChangeLog b/net-dialup/ppp-scripts/ChangeLog
new file mode 100644
index 000000000000..025a962f80f0
--- /dev/null
+++ b/net-dialup/ppp-scripts/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-dialup/ppp-scripts
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp-scripts/ChangeLog,v 1.1 2015/05/14 10:17:20 pinkbyte Exp $
+
+*ppp-scripts-0 (14 May 2015)
+
+ 14 May 2015; Sergey Popov <pinkbyte@gentoo.org> +ppp-scripts-0.ebuild,
+ +metadata.xml:
+ Initial commit
+
diff --git a/net-dialup/ppp-scripts/metadata.xml b/net-dialup/ppp-scripts/metadata.xml
new file mode 100644
index 000000000000..a34223d15ce6
--- /dev/null
+++ b/net-dialup/ppp-scripts/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+</pkgmetadata>
diff --git a/net-dialup/ppp-scripts/ppp-scripts-0.ebuild b/net-dialup/ppp-scripts/ppp-scripts-0.ebuild
new file mode 100644
index 000000000000..99b4c4303f18
--- /dev/null
+++ b/net-dialup/ppp-scripts/ppp-scripts-0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp-scripts/ppp-scripts-0.ebuild,v 1.1 2015/05/14 10:17:20 pinkbyte Exp $
+
+EAPI=5
+
+DESCRIPTION="Common set of scripts for various PPP implementations"
+HOMEPAGE="http://gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~pinkbyte/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="!<net-dialup/ppp-2.4.7-r1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ exeinto /etc/ppp
+ for i in ip-up ip-down ; do
+ doexe "scripts/${i}"
+ insinto /etc/ppp/${i}.d
+ dosym ${i} /etc/ppp/${i/ip/ipv6}
+ doins "scripts/${i}.d"/*
+ done
+}