summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-11-17 19:54:34 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-11-17 19:54:34 +0000
commit6e0706874e0c0611ac4c019f238d1355179143e8 (patch)
tree93e4ae439779bdf9023a5d535d8f731e3335200f /net-dialup
parentbump (diff)
downloadgentoo-2-6e0706874e0c0611ac4c019f238d1355179143e8.tar.gz
gentoo-2-6e0706874e0c0611ac4c019f238d1355179143e8.tar.bz2
gentoo-2-6e0706874e0c0611ac4c019f238d1355179143e8.zip
moved l2tpd from net-misc to net-dialup
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/l2tpd/ChangeLog17
-rw-r--r--net-dialup/l2tpd/Manifest4
-rw-r--r--net-dialup/l2tpd/files/digest-l2tpd-0.692
-rw-r--r--net-dialup/l2tpd/files/l2tpd-init20
-rw-r--r--net-dialup/l2tpd/l2tpd-0.69.ebuild54
5 files changed, 97 insertions, 0 deletions
diff --git a/net-dialup/l2tpd/ChangeLog b/net-dialup/l2tpd/ChangeLog
new file mode 100644
index 000000000000..34c85bbbed0a
--- /dev/null
+++ b/net-dialup/l2tpd/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for net-misc/l2tpd
+# Copyright 2003 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/l2tpd/ChangeLog,v 1.1 2003/11/17 19:54:29 lanius Exp $
+
+*l2tpd-0.69 (17 Nov 2003)
+
+ 17 Nov 2003; Heinrich Wendel <lanius@gentoo.org> l2tpd-0.69.ebuild,
+ files/l2tpd-init:
+ moved from net-misc to net-dialup
+
+ 10 Jul 2003; Donny Davies <woodchip@gentoo.org> l2tpd-0.69.ebuild:
+ Close #23945.
+
+*l2tpd-0.69 (24 Feb 2003)
+
+ 24 Feb 2003; Donny Davies <woodchip@gentoo.org> :
+ Initial import, created by me.
diff --git a/net-dialup/l2tpd/Manifest b/net-dialup/l2tpd/Manifest
new file mode 100644
index 000000000000..79cfa17bd1d6
--- /dev/null
+++ b/net-dialup/l2tpd/Manifest
@@ -0,0 +1,4 @@
+MD5 d4f6874da5b90aa21f386c5c54a1f6de l2tpd-0.69.ebuild 1559
+MD5 a4f5ad0d50f15435218f983f7ce212f9 ChangeLog 556
+MD5 d6a701a4f443b06067841f3f72714b00 files/digest-l2tpd-0.69 131
+MD5 daabc665d740579405c1922c734392ee files/l2tpd-init 383
diff --git a/net-dialup/l2tpd/files/digest-l2tpd-0.69 b/net-dialup/l2tpd/files/digest-l2tpd-0.69
new file mode 100644
index 000000000000..93c48b7b8412
--- /dev/null
+++ b/net-dialup/l2tpd/files/digest-l2tpd-0.69
@@ -0,0 +1,2 @@
+MD5 c5dba6b80f583070fe9e6ed6e0c2162e l2tpd-0.69.tar.gz 127693
+MD5 d41902cd6965d8789fdde67c9232f4d9 freeswanl2tpconfig-1.1.tgz 1943
diff --git a/net-dialup/l2tpd/files/l2tpd-init b/net-dialup/l2tpd/files/l2tpd-init
new file mode 100644
index 000000000000..3dee1dd9a199
--- /dev/null
+++ b/net-dialup/l2tpd/files/l2tpd-init
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting l2tpd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/l2tpd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping l2tpd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/l2tpd.pid
+ eend $?
+}
diff --git a/net-dialup/l2tpd/l2tpd-0.69.ebuild b/net-dialup/l2tpd/l2tpd-0.69.ebuild
new file mode 100644
index 000000000000..a7575892aa4f
--- /dev/null
+++ b/net-dialup/l2tpd/l2tpd-0.69.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/l2tpd/l2tpd-0.69.ebuild,v 1.1 2003/11/17 19:54:29 lanius Exp $
+
+DESCRIPTION="Layer 2 Tunnelling Protocol Daemon"
+HOMEPAGE="http://www.l2tpd.org/"
+SRC_URI="http://www.l2tpd.org/downloads/${P}.tar.gz"
+# http://www.jacco2.dds.nl/networking/freeswanl2tpconfig-1.1.tgz"
+DEPEND="virtual/glibc"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+IUSE=""
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+
+ #compile optimized
+ cp Makefile Makefile.orig
+ sed -e "s|-g -O2|${CFLAGS}|" Makefile.orig >Makefile
+ #-e "s|^#\(OSFLAGS+= -DUSE_KERNEL\)|\1|" \
+ #^wants an #include <linux/l2tp>
+
+ #make sure these stay just like so
+ cp file.h file.h.orig
+ sed -e 's|\(#define DEFAULT_AUTH_FILE \).*|\1"/etc/l2tpd/l2tp-secrets"|' \
+ -e 's|\(#define DEFAULT_CONFIG_FILE \).*|\1"/etc/l2tpd/l2tpd.conf"|' \
+ -e 's|\(#define DEFAULT_PID_FILE \).*|\1"/var/run/l2tpd.pid"|' \
+ file.h.orig >file.h
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dosbin l2tpd
+ doman doc/*.[85]
+
+ dodoc BUGS CHANGELOG LICENSE CREDITS README TODO \
+ doc/rfc2661.txt doc/*.sample
+ #cp -a ../freeswanl2tpconfig ${D}/usr/share/doc/${PF}
+ #chown -R root.root ${D}/usr/share/doc/${PF}
+ #mv ${D}/usr/share/doc/${PF}/freeswanl2tpconfig \
+ # ${D}/usr/share/doc/${PF}/samples
+
+ insinto /etc/l2tpd
+ newins doc/l2tp-secrets.sample l2tp-secrets
+ newins doc/l2tpd.conf.sample l2tpd.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/l2tpd-init l2tpd
+}