summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2003-09-24 07:18:34 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2003-09-24 07:18:34 +0000
commit3498aaa55c1116e324e18d7b0dff0461a93897b4 (patch)
treec567cf2eef0cabcfadd9c61604e1ae23ac979184 /net-dialup
parentPatchset 2.1.14. Adding patches 0261 and 0262 to fix module loading issues on... (diff)
downloadgentoo-2-3498aaa55c1116e324e18d7b0dff0461a93897b4.tar.gz
gentoo-2-3498aaa55c1116e324e18d7b0dff0461a93897b4.tar.bz2
gentoo-2-3498aaa55c1116e324e18d7b0dff0461a93897b4.zip
Initial commit, thanks to Matt Levandowski <rayor@gmx.net> on bug #19626.
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/penggy/ChangeLog10
-rw-r--r--net-dialup/penggy/Manifest5
-rw-r--r--net-dialup/penggy/files/digest-penggy-0.2.11
-rw-r--r--net-dialup/penggy/files/rc_net.aol51
-rw-r--r--net-dialup/penggy/metadata.xml8
-rw-r--r--net-dialup/penggy/penggy-0.2.1.ebuild42
6 files changed, 117 insertions, 0 deletions
diff --git a/net-dialup/penggy/ChangeLog b/net-dialup/penggy/ChangeLog
new file mode 100644
index 000000000000..064d2419bff0
--- /dev/null
+++ b/net-dialup/penggy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-dialup/penggy
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/penggy/ChangeLog,v 1.1 2003/09/24 07:18:29 spyderous Exp $
+
+*penggy-0.2.1 (24 Sep 2003)
+
+ 24 Sep 2003; Donnie Berkholz <spyderous@gentoo.org>; penggy-0.2.1.ebuild,
+ files/rc_net.aol:
+ Initial commit, thanks to Matt Levandowski <rayor@gmx.net> on bug #19626.
+
diff --git a/net-dialup/penggy/Manifest b/net-dialup/penggy/Manifest
new file mode 100644
index 000000000000..d3160ad0dfa5
--- /dev/null
+++ b/net-dialup/penggy/Manifest
@@ -0,0 +1,5 @@
+MD5 97258d12ba2d446448f53cb90cd07a19 penggy-0.2.1.ebuild 1284
+MD5 e439b445fe5008b6d9efab530d5d4294 ChangeLog 421
+MD5 60f93915838cb266eef644d5f73c9d19 metadata.xml 225
+MD5 1e9adbd211c3b056d79a8f8368ab63ba files/rc_net.aol 1026
+MD5 0fea2d99dcce8ec0912ba6875a84c8e3 files/digest-penggy-0.2.1 64
diff --git a/net-dialup/penggy/files/digest-penggy-0.2.1 b/net-dialup/penggy/files/digest-penggy-0.2.1
new file mode 100644
index 000000000000..6876ad43c811
--- /dev/null
+++ b/net-dialup/penggy/files/digest-penggy-0.2.1
@@ -0,0 +1 @@
+MD5 7ea9ce65634e39a5dd478f9ea02c518a penggy-0.2.1.tar.gz 455909
diff --git a/net-dialup/penggy/files/rc_net.aol b/net-dialup/penggy/files/rc_net.aol
new file mode 100644
index 000000000000..733064596d6a
--- /dev/null
+++ b/net-dialup/penggy/files/rc_net.aol
@@ -0,0 +1,51 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author: Brice Arnould
+# Credits: To all those I got ideas from :)
+#
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/penggy/files/rc_net.aol,v 1.1 2003/09/24 07:18:29 spyderous Exp $
+
+# NB: Config is in /etc/penggy/
+
+depend() {
+ need modules net
+}
+
+checkconfig() {
+
+ if [ ! -x /usr/sbin/penggy ]
+ then
+ eerror "Penggy needs to be installed"
+ return 1
+ fi
+
+ if [ -e /var/run/penggy.pid -a "${FUNCT}" = "start" ]
+ then
+ eerror "Penggy is already started"
+ return 1
+ fi
+
+ if [ ! -e /var/run/penggy.pid -a "${FUNCT}" = "stop" ]
+ then
+ eerror "Penggy is not started"
+ return 1
+ fi
+
+}
+
+start() {
+
+ checkconfig || return 1
+ ebegin "Connecting to the AOL/Compuserve network"
+ /usr/sbin/penggy -r -d
+ eend $? "Failed to etablish the connection"
+}
+
+stop() {
+
+ checkconfig || return 1
+ ebegin "Closing the connection to the AOL/Compuserve network"
+ kill $(cat /var/run/penggy.pid)
+ eend
+}
diff --git a/net-dialup/penggy/metadata.xml b/net-dialup/penggy/metadata.xml
new file mode 100644
index 000000000000..3de0ad83f213
--- /dev/null
+++ b/net-dialup/penggy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>spyderous@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-dialup/penggy/penggy-0.2.1.ebuild b/net-dialup/penggy/penggy-0.2.1.ebuild
new file mode 100644
index 000000000000..e3e79153cefd
--- /dev/null
+++ b/net-dialup/penggy/penggy-0.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/penggy/penggy-0.2.1.ebuild,v 1.1 2003/09/24 07:18:29 spyderous Exp $
+
+DESCRIPTION="Provide access to Internet using the AOL/Compuserve network."
+HOMEPAGE="http://www.peng.apinc.org/"
+SRC_URI="ftp://ftp.penggy.org/birdy57/penggy/sources/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-util/guile-1.4.0"
+
+src_compile() {
+ # Without localstatedir=/var, it would use /usr/var/run/ .
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc_net.aol net.aol
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The penggy AOL/Compuserve IP tunneling package has been installed."
+ einfo
+ einfo "You now need to configure it by editing penggy.cfg, aol-secrets, and phonetab in /etc/penggy."
+ einfo "Also you will need to have tuntap, built into your kernel or compiled as a module."
+ einfo
+ einfo "IMPORTANT: Penggy is neither endorsed by or affiliated with"
+ einfo "AOL."
+ einfo
+}