summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-04-10 00:56:20 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-04-10 00:56:20 +0000
commit189f36357164e01cf6397cffbf30ebd752ad26b0 (patch)
treeff840dea016a8e8c93e3bfafaa2f8691940caa25 /net-dialup
parentupdate for the new apache package (diff)
downloadgentoo-2-189f36357164e01cf6397cffbf30ebd752ad26b0.tar.gz
gentoo-2-189f36357164e01cf6397cffbf30ebd752ad26b0.tar.bz2
gentoo-2-189f36357164e01cf6397cffbf30ebd752ad26b0.zip
closing bug #1628
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ppp/ChangeLog7
-rw-r--r--net-dialup/ppp/files/digest-ppp-2.4.1-r81
-rw-r--r--net-dialup/ppp/ppp-2.4.1-r8.ebuild99
3 files changed, 106 insertions, 1 deletions
diff --git a/net-dialup/ppp/ChangeLog b/net-dialup/ppp/ChangeLog
index e40d459aeec4..c6b3b08b92c5 100644
--- a/net-dialup/ppp/ChangeLog
+++ b/net-dialup/ppp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/ppp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.2 2002/04/08 05:07:37 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.3 2002/04/10 00:56:20 drobbins Exp $
+
+*ppp-2.4.1-r8 (09 Apr 2002)
+
+ 09 Apr 2002; Daniel Robbins <drobbins@gentoo.org> : fixed plugin installation
+ path; closing bug #1629.
*ppp-2.4.1-r7 (08 Apr 2002)
diff --git a/net-dialup/ppp/files/digest-ppp-2.4.1-r8 b/net-dialup/ppp/files/digest-ppp-2.4.1-r8
new file mode 100644
index 000000000000..b3c7b1676065
--- /dev/null
+++ b/net-dialup/ppp/files/digest-ppp-2.4.1-r8
@@ -0,0 +1 @@
+MD5 7f655448fbb6bebcede7a515fbcd481e ppp-2.4.1-pppoe4.tgz 556218
diff --git a/net-dialup/ppp/ppp-2.4.1-r8.ebuild b/net-dialup/ppp/ppp-2.4.1-r8.ebuild
new file mode 100644
index 000000000000..8dcef210efc6
--- /dev/null
+++ b/net-dialup/ppp/ppp-2.4.1-r8.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+
+# modified by Christian Loitsch <gentoo00@loitsch.org>
+
+S=${WORKDIR}/${P}.pppoe4
+DESCRIPTION="Point-to-point protocol - patched for pppoe"
+SRC_URI="http://www.shoshin.uwaterloo.ca/~mostrows/${P}-pppoe4.tgz"
+HOMEPAGE="http://www.shoshin.uwaterloo.ca/~mostrows/index.html"
+
+DEPEND="virtual/glibc"
+PROVIDE="virtual/pppd"
+
+src_compile() {
+
+ ./configure --prefix=/usr || die
+
+ #fix Makefiles to compile optimized
+ cd pppd
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS = -O2 -pipe -Wall -g:COPTS = ${CFLAGS}:" \
+ -e "s/LIBS =/LIBS = -lcrypt/" \
+ Makefile.orig > Makefile
+ cd plugins
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS\t= -g -O2:CFLAGS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd pppoe
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS\t= -g :CFLAGS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd ../../../pppstats
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS= -O:COPTS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd ../chat
+ mv Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ../pppdump
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS= -O:CFLAGS= ${CFLAGS}:" Makefile.orig > Makefile
+ cd ..
+
+ export CC=gcc
+
+ emake || die
+}
+
+src_install() {
+ for y in chat pppd pppdump pppstats
+ do
+ doman ${y}/${y}.8
+ dosbin ${y}/${y}
+ done
+
+ chmod u+s-w ${D}/usr/sbin/pppd
+ chown root:daemon ${D}/usr/sbin/pppstats
+
+ dodir /etc/ppp/peers
+ insinto /etc/ppp
+ insopts -m0600
+ doins etc.ppp/pap-secrets etc.ppp/chap-secrets
+ insopts -m0644
+ doins etc.ppp/options
+
+ dolib.so pppd/plugins/minconn.so
+ dolib.so pppd/plugins/passprompt.so
+ dolib.so pppd/plugins/pppoe/pppoe.so
+ dodir /usr/lib/pppd/$(awk -F '"' '/VERSION/ {print $2}' pppd/patchlevel.h)
+ mv ${D}/usr/lib/*.so ${D}/usr/lib/pppd/$(awk -F '"' '/VERSION/ {print $2}' pppd/patchlevel.h)
+ insinto /etc/modules.d
+ newins ${FILESDIR}/modules.ppp ppp
+
+ dodoc PLUGINS README* SETUP Changes-2.3 FAQ
+ dohtml ${FILESDIR}/pppoe.html
+
+# This will have to be updated to work with the new net.ppp0
+# # Added a couple scripts to simplify dialing up
+# # borrowed from debian, man they got some nice little apps :-)
+# dosbin ${FILESDIR}/pon
+# dosbin ${FILESDIR}/poff
+# doman ${FILESDIR}/pon.1
+}
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}dev/.devfsd ]
+ then
+ if [ ! -e ${ROOT}dev/ppp ]; then
+ mknod ${ROOT}dev/ppp c 108 0
+ fi
+ fi
+ if [ "$ROOT" = "/" ]
+ then
+ /usr/sbin/update-modules
+ fi
+ einfo "to enable kernel-pppoe read html/pppoe.html in the doc-directory"
+}