summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2004-11-09 22:39:23 +0000
committerAlin Năstac <mrness@gentoo.org>2004-11-09 22:39:23 +0000
commit4b1c33c0a7471e9b8fa6531f5f9e2a98e33cff66 (patch)
tree32c7233b6257848c5a63e2db784a9f59d5614293 /net-dialup/trayimonc/trayimonc-0.7.1.ebuild
parentadd ~alpha and ~ia64 (Manifest recommit) (diff)
downloadgentoo-2-4b1c33c0a7471e9b8fa6531f5f9e2a98e33cff66.tar.gz
gentoo-2-4b1c33c0a7471e9b8fa6531f5f9e2a98e33cff66.tar.bz2
gentoo-2-4b1c33c0a7471e9b8fa6531f5f9e2a98e33cff66.zip
initial ebuild (see bug 38610)
Diffstat (limited to 'net-dialup/trayimonc/trayimonc-0.7.1.ebuild')
-rw-r--r--net-dialup/trayimonc/trayimonc-0.7.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-dialup/trayimonc/trayimonc-0.7.1.ebuild b/net-dialup/trayimonc/trayimonc-0.7.1.ebuild
new file mode 100644
index 000000000000..b23dafe88cde
--- /dev/null
+++ b/net-dialup/trayimonc/trayimonc-0.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/trayimonc/trayimonc-0.7.1.ebuild,v 1.1 2004/11/09 22:39:23 mrness Exp $
+
+inherit kde
+
+DESCRIPTION="TrayImonc, a KDE based imond client for fli4l"
+SRC_URI="http://www.trayimonc.de/${P}${V}.tar.bz2"
+HOMEPAGE="http://www.trayimonc.de/"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="xinerama debug"
+
+need-kde 3
+
+src_compile() {
+ local myconf=""
+ set-kdedir 3
+
+ useq xinerama && \
+ myconf="${myconf} --enable-Xinerama"
+ useq debug && \
+ myconf="${myconf} --enable-debug=full"
+
+ econf $myconf && \
+ emake || die "Compile has failed!"
+}
+
+src_install() {
+ einstall || die "make install has failed"
+}