summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-09-05 08:05:53 +0000
committerJustin Lecher <jlec@gentoo.org>2012-09-05 08:05:53 +0000
commitf40a14edf2442fbff6f86731bcd09d8486e84586 (patch)
treeb97e2192a5f9a6eaa02df9e8bbe360a80e9393a1 /net-dialup/tkvoice
parentUse domenu instead insinto + doins to install .desktop files (diff)
downloadgentoo-2-f40a14edf2442fbff6f86731bcd09d8486e84586.tar.gz
gentoo-2-f40a14edf2442fbff6f86731bcd09d8486e84586.tar.bz2
gentoo-2-f40a14edf2442fbff6f86731bcd09d8486e84586.zip
Use domenu instead insinto + doins to install .desktop files
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup/tkvoice')
-rw-r--r--net-dialup/tkvoice/ChangeLog9
-rw-r--r--net-dialup/tkvoice/files/tkvoice.desktop4
-rw-r--r--net-dialup/tkvoice/tkvoice-1.5.ebuild39
3 files changed, 27 insertions, 25 deletions
diff --git a/net-dialup/tkvoice/ChangeLog b/net-dialup/tkvoice/ChangeLog
index f32ac9aa1074..99f3eaafb035 100644
--- a/net-dialup/tkvoice/ChangeLog
+++ b/net-dialup/tkvoice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/tkvoice
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/tkvoice/ChangeLog,v 1.2 2007/05/06 08:16:05 genone Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/tkvoice/ChangeLog,v 1.3 2012/09/05 08:05:53 jlec Exp $
+
+ 05 Sep 2012; Justin Lecher <jlec@gentoo.org> files/tkvoice.desktop,
+ tkvoice-1.5.ebuild:
+ Use domenu instead insinto + doins to install .desktop files
06 May 2007; Marius Mauch <genone@gentoo.org> tkvoice-1.5.ebuild:
Replacing einfo with elog
@@ -10,4 +14,3 @@
02 Apr 2006; Alin Nastac <mrness@gentoo.org> +files/tkvoice.desktop,
+metadata.xml, +tkvoice-1.5.ebuild:
Initial import from bug #125266, thanks to Peter Hyman <pete4abw@comcast.net>.
-
diff --git a/net-dialup/tkvoice/files/tkvoice.desktop b/net-dialup/tkvoice/files/tkvoice.desktop
index a6dd88faf52d..389305340e08 100644
--- a/net-dialup/tkvoice/files/tkvoice.desktop
+++ b/net-dialup/tkvoice/files/tkvoice.desktop
@@ -1,9 +1,7 @@
[Desktop Entry]
-Encoding=UTF-8
-Version=1.5
Name=TkVoice
Type=Application
Comment=Phone/Fax Utility
Exec=tkvoice
Icon=tkvoice
-Categories=Application;Utility;
+Categories=Utility;
diff --git a/net-dialup/tkvoice/tkvoice-1.5.ebuild b/net-dialup/tkvoice/tkvoice-1.5.ebuild
index 4df2c7d5eddd..7a5e7e92dcd3 100644
--- a/net-dialup/tkvoice/tkvoice-1.5.ebuild
+++ b/net-dialup/tkvoice/tkvoice-1.5.ebuild
@@ -1,8 +1,12 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/tkvoice/tkvoice-1.5.ebuild,v 1.3 2007/05/06 08:16:05 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/tkvoice/tkvoice-1.5.ebuild,v 1.4 2012/09/05 08:05:53 jlec Exp $
-DESCRIPTION="TkVoice - Voice mail and Fax frontend program"
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Voice mail and Fax frontend program"
HOMEPAGE="http://tkvoice.netfirms.com"
SRC_URI="http://tkvoice.netfirms.com/${P}.tar.gz"
@@ -11,22 +15,21 @@ SLOT="0"
KEYWORDS="~x86"
IUSE=""
-RDEPEND="dev-lang/tk
- media-libs/netpbm
- media-sound/sox
- net-dialup/mgetty"
-
-src_unpack() {
- unpack ${A}
+RDEPEND="
+ dev-lang/tk
+ media-libs/netpbm
+ media-sound/sox
+ net-dialup/mgetty"
+DEPEND="${DEPEND}"
+src_prepare() {
sed -i -e "s:/usr/local/etc:/etc:g; s:/usr/local/bin:/usr/bin:g; s:/usr/local/tkvoice:/usr/lib/${P}:g" \
- "${S}/tkvoice" "${S}/TCL/tkvfaq.tcl" "${S}/TCL/tkvsetupvoice.tcl"
+ "${S}/tkvoice" "${S}/TCL/tkvfaq.tcl" "${S}/TCL/tkvsetupvoice.tcl" || die
sed -i -e "s:set STARTDIR .*:set STARTDIR /usr/lib/${P}:" \
- "${S}/tkvoice"
+ "${S}/tkvoice" || die
}
-src_install()
-{
+src_install() {
exeinto /usr/lib/${P}
doexe ${PN}
dodir /usr/bin
@@ -36,17 +39,15 @@ src_install()
insinto /usr/lib/${P}/image
doins image/*
- insinto /usr/share/applications
- doins "${FILESDIR}/${PN}.desktop"
+ domenu "${FILESDIR}/${PN}.desktop"
insinto /usr/share/pixmaps
doins ${PN}.xpm
dodoc BUGS FAQ README TODO
}
-pkg_postinst()
-{
- elog "${P} has been installed. Run /usr/bin/${PN}."
+pkg_postinst() {
+ elog "${P} has been installed. Run ${EPREFIX}/usr/bin/${PN}."
elog "For more information, see the home page, ${HOMEPAGE}"
elog "or consult the documentation for this program as well as"
elog "for mgetty/vgetty."