summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-01-29 22:16:59 +0000
committerAlin Năstac <mrness@gentoo.org>2008-01-29 22:16:59 +0000
commit677ca7f9f3de465459b5e62628a918b921001a4c (patch)
treefa33abb0e497eeab4b5acb26a98b46bee9d80d10 /net-dialup/mingetty/mingetty-1.08.ebuild
parentMake it _p25 rather than _p33... (diff)
downloadgentoo-2-677ca7f9f3de465459b5e62628a918b921001a4c.tar.gz
gentoo-2-677ca7f9f3de465459b5e62628a918b921001a4c.tar.bz2
gentoo-2-677ca7f9f3de465459b5e62628a918b921001a4c.zip
Version bump (#208053).
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-dialup/mingetty/mingetty-1.08.ebuild')
-rw-r--r--net-dialup/mingetty/mingetty-1.08.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-dialup/mingetty/mingetty-1.08.ebuild b/net-dialup/mingetty/mingetty-1.08.ebuild
new file mode 100644
index 000000000000..15058212dda6
--- /dev/null
+++ b/net-dialup/mingetty/mingetty-1.08.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mingetty/mingetty-1.08.ebuild,v 1.1 2008/01/29 22:16:58 mrness Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A compact getty program for virtual consoles only."
+HOMEPAGE="http://sourceforge.net/projects/mingetty"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="unicode"
+
+src_unpack() {
+ unpack ${A}
+
+ use unicode && epatch "${FILESDIR}"/${P}-utf8.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -Wall -W -pipe -D_GNU_SOURCE" CC="$(tc-getCC)" || die "compile failed"
+}
+
+src_install () {
+ dodir /sbin /usr/share/man/man8
+ emake DESTDIR="${D}" install || die "install failed"
+}