summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:30:56 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:30:56 +0000
commit15fbb8e0c971f8d3e37a09a8511cae959754a081 (patch)
treebb6a608bc95133f9770ea7f7e466392a07e8987c /net-dialup/fcdslsl
parentStable on x86 wrt bug #207748 (diff)
downloadgentoo-2-15fbb8e0c971f8d3e37a09a8511cae959754a081.tar.gz
gentoo-2-15fbb8e0c971f8d3e37a09a8511cae959754a081.tar.bz2
gentoo-2-15fbb8e0c971f8d3e37a09a8511cae959754a081.zip
fixing string.h problem (see bug #202385) + patches for kernel 2.6.24 (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
(Portage version: 2.1.4)
Diffstat (limited to 'net-dialup/fcdslsl')
-rw-r--r--net-dialup/fcdslsl/ChangeLog9
-rw-r--r--net-dialup/fcdslsl/fcdslsl-0.1-r1.ebuild60
-rw-r--r--net-dialup/fcdslsl/files/digest-fcdslsl-0.1-r13
-rw-r--r--net-dialup/fcdslsl/files/fcdslsl_kernel-2.6.24.diff47
4 files changed, 118 insertions, 1 deletions
diff --git a/net-dialup/fcdslsl/ChangeLog b/net-dialup/fcdslsl/ChangeLog
index 9bfeb24c131d..c7db0342df44 100644
--- a/net-dialup/fcdslsl/ChangeLog
+++ b/net-dialup/fcdslsl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/fcdslsl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdslsl/ChangeLog,v 1.1 2008/01/06 01:42:08 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdslsl/ChangeLog,v 1.2 2008/01/30 01:30:55 sbriesen Exp $
+
+*fcdslsl-0.1-r1 (30 Jan 2008)
+
+ 30 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/fcdslsl_kernel-2.6.24.diff, +fcdslsl-0.1-r1.ebuild:
+ fixing string.h problem (see bug #202385) + patches for kernel 2.6.24
+ (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
*fcdslsl-0.1 (06 Jan 2008)
diff --git a/net-dialup/fcdslsl/fcdslsl-0.1-r1.ebuild b/net-dialup/fcdslsl/fcdslsl-0.1-r1.ebuild
new file mode 100644
index 000000000000..645019311123
--- /dev/null
+++ b/net-dialup/fcdslsl/fcdslsl-0.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdslsl/fcdslsl-0.1-r1.ebuild,v 1.1 2008/01/30 01:30:55 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!Card DSL SL PCI"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ local BIT="" PAT="01234"
+ if use amd64; then
+ BIT="64bit-" PAT="1234"
+ fi
+
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-suse[0-9][0-9]-${BIT}[0-9].[0-9]*-[0-9]*.tar.gz
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[${PAT}]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ epatch "${FILESDIR}/${PN}_kernel-2.6.24.diff"
+ convert_to_m src/Makefile
+
+ for i in lib/*-lib.o; do
+ einfo "Localize symbols in ${i##*/} ..."
+ objcopy -L memcmp -L memcpy -L memmove -L memset -L strcat \
+ -L strcmp -L strcpy -L strlen -L strncmp -L strncpy "${i}"
+ done
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /lib/firmware/isdn
+ doins ../*.bin
+ dodoc CAPI*.txt
+ dohtml *.html
+}
diff --git a/net-dialup/fcdslsl/files/digest-fcdslsl-0.1-r1 b/net-dialup/fcdslsl/files/digest-fcdslsl-0.1-r1
new file mode 100644
index 000000000000..791905d5b09e
--- /dev/null
+++ b/net-dialup/fcdslsl/files/digest-fcdslsl-0.1-r1
@@ -0,0 +1,3 @@
+MD5 424c635d50a7f945c93238f7f1615a7a fcdslsl-0.1-0.src.rpm 2218332
+RMD160 b70881f51a0de4e11a5a791a8b5aafc7387fe783 fcdslsl-0.1-0.src.rpm 2218332
+SHA256 f9cb5f93bef90f8a4e72cacd7cf77ebd935322a5cf5127a9de808deed32c93d2 fcdslsl-0.1-0.src.rpm 2218332
diff --git a/net-dialup/fcdslsl/files/fcdslsl_kernel-2.6.24.diff b/net-dialup/fcdslsl/files/fcdslsl_kernel-2.6.24.diff
new file mode 100644
index 000000000000..e9b51ed36a2d
--- /dev/null
+++ b/net-dialup/fcdslsl/files/fcdslsl_kernel-2.6.24.diff
@@ -0,0 +1,47 @@
+--- src/driver.c.orig 2008-01-27 05:38:50.000000000 +0100
++++ src/driver.c 2008-01-27 05:38:50.000000000 +0100
+@@ -116,7 +116,10 @@
+ static DECLARE_WAIT_QUEUE_HEAD(capi_wait);
+ static DECLARE_WAIT_QUEUE_HEAD(dbg_wait);
+
++static DECLARE_COMPLETION(thread_sync); /* New DECLARE, <arnd.feldmueller@web.de> */
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ static DECLARE_MUTEX_LOCKED(thread_sync);
++#endif
+
+ #define SCHED_WAKEUP_CAPI { atomic_set (&thread_capi_flag, 1); wake_up_interruptible (&capi_wait); }
+ #define SCHED_WAKEUP { atomic_set (&got_kicked, 1); wake_up_interruptible (&wait); }
+@@ -1405,7 +1409,10 @@
+ }
+ }
+ LOG("Scheduler thread stopped.\n");
++ complete(&thread_sync); /* Complete Thread Sync here <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ up (&thread_sync);
++ #endif
+ return 0;
+ } /* sched_thread */
+
+@@ -1439,7 +1448,10 @@
+ SCHED_WAKEUP;
+ }
+ LOG("Thread signalled, waiting for termination...\n");
++ wait_for_completion(&thread_sync); /* Wait for complete Thread Sync <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ down (&thread_sync);
++ #endif
+ LOG("Thread[%d] terminated.\n", thread_pid);
+ }
+ thread_pid = -1;
+--- src/common.h.orig 2005-07-07 00:00:00.000000000 +0200
++++ src/common.h 2008-01-27 05:38:50.000000000 +0100
+@@ -44,7 +44,9 @@
+ /*---------------------------------------------------------------------------*\
+ \*---------------------------------------------------------------------------*/
+ typedef long intptr_t;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ typedef unsigned long uintptr_t;
++#endif
+
+ /*---------------------------------------------------------------------------*\
+ \*---------------------------------------------------------------------------*/