summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-10-28 09:32:49 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-10-28 09:32:49 +0000
commit5a132b6b68d42661baf3c24597b3782dec02cc4c (patch)
tree6ef357c81449a95c93e59da632cc9ffe06444acd /net-dialup/bewan-adsl
parentmark stable (Manifest recommit) (diff)
downloadgentoo-2-5a132b6b68d42661baf3c24597b3782dec02cc4c.tar.gz
gentoo-2-5a132b6b68d42661baf3c24597b3782dec02cc4c.tar.bz2
gentoo-2-5a132b6b68d42661baf3c24597b3782dec02cc4c.zip
eclass kmod -> kernel-mod bug #68447
Diffstat (limited to 'net-dialup/bewan-adsl')
-rw-r--r--net-dialup/bewan-adsl/ChangeLog6
-rw-r--r--net-dialup/bewan-adsl/bewan-adsl-0.8.7.ebuild47
2 files changed, 28 insertions, 25 deletions
diff --git a/net-dialup/bewan-adsl/ChangeLog b/net-dialup/bewan-adsl/ChangeLog
index f5f789143689..6c6dd04684ba 100644
--- a/net-dialup/bewan-adsl/ChangeLog
+++ b/net-dialup/bewan-adsl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/bewan-adsl
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/bewan-adsl/ChangeLog,v 1.1 2004/09/27 14:14:59 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/bewan-adsl/ChangeLog,v 1.2 2004/10/28 09:32:49 dragonheart Exp $
+
+ 28 Oct 2004; Daniel Black <dragonheart@gentoo.org> bewan-adsl-0.8.7.ebuild:
+ eclass kmod -> kernel-mod thanks to Stefan Schweizer <sschweizer@gmail.com> in
+ bug #68447
*bewan-adsl-0.8.7 (27 Sep 2004)
diff --git a/net-dialup/bewan-adsl/bewan-adsl-0.8.7.ebuild b/net-dialup/bewan-adsl/bewan-adsl-0.8.7.ebuild
index 38ea4e89d1a8..32557eeaf429 100644
--- a/net-dialup/bewan-adsl/bewan-adsl-0.8.7.ebuild
+++ b/net-dialup/bewan-adsl/bewan-adsl-0.8.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/bewan-adsl/bewan-adsl-0.8.7.ebuild,v 1.1 2004/09/27 14:14:59 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/bewan-adsl/bewan-adsl-0.8.7.ebuild,v 1.2 2004/10/28 09:32:49 dragonheart Exp $
-inherit eutils kmod
+inherit eutils kernel-mod
DESCRIPTION="Bewan ADSL PCI&USB st driver"
SRC_URI="http://www.bewan.com/bewan/drivers/bast-${PV}.tgz"
@@ -15,30 +15,21 @@ IUSE="usb doc"
S="${WORKDIR}/unicorn"
src_compile() {
- get_kernel_info || die
- #kmod_make_linux_writable || die #without this we cannot compile this driver for 2.6 kernels
einfo "Build common library"
cd ${S}/libm
emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die
+ unset ARCH #unset ARCH because interfere with 2.6 kernel makefiles
- (
- unset ARCH #unset ARCH because interfere with 2.6 kernel makefiles
+ einfo "Build PCI driver"
+ cd ${S}/unicorn_pci
+ emake || die "Failed to build PCI driver"
- einfo "Build PCI driver"
- cd ${S}/unicorn_pci
- emake || die
- [ -f unicorn_pci_atm.${KV_OBJ} ] && [ -f unicorn_pci_eth.${KV_OBJ} ] \
- || die "Failed to build PCI driver"
-
- if use usb; then
- einfo "Build USB driver"
- cd ${S}/unicorn_usb
- emake || die
- [ -f unicorn_usb_atm.${KV_OBJ} ] && [ -f unicorn_usb_eth.${KV_OBJ} ] \
- || die "Failed to build USB driver"
- fi
- )
+ if use usb; then
+ einfo "Build USB driver"
+ cd ${S}/unicorn_usb
+ emake || die "Failed to build USB driver"
+ fi
#Build tools
cd ${S}/tools
@@ -46,6 +37,13 @@ src_compile() {
}
src_install() {
+ if kernel-mod_is_2_6_kernel
+ then
+ KV_OBJ="ko"
+ else
+ KV_OBJ="o"
+ fi
+
cd ${S}
insinto "/lib/modules/${KV}/kernel/drivers/atm"
doins unicorn_pci/unicorn_pci_atm.${KV_OBJ} && \
@@ -76,14 +74,15 @@ src_install() {
}
pkg_postinst() {
- einfo "Regenerate modules dependencies for kernel ${KV}"
- depmod -ae ${KV}
- eend $?
- einfo ""
einfo "To load the driver do 'insmod unicorn_atm' and 'insmod unicorn_pci' "
einfo "and then do what you want with it (configure your pppd)"
einfo "OR"
einfo "it's time to look at the README file, the scripts directory gives you"
einfo "two comprehensive ways to load the driver, configure pppd and launch it."
+ einfo ""
+
+ einfo "Checking kernel module dependencies"
+ test -r "${ROOT}/usr/src/linux/System.map" && \
+ depmod -ae -F "${ROOT}/usr/src/linux/System.map" -b "${ROOT}" -r ${KV}
}