summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-20 12:21:01 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-20 12:21:01 +0000
commitd887ae181e7c05ce0a1107d5294d3ac26e6e9445 (patch)
treeaab3128ed863096064cad817d4f7ad676b71bbc8 /net-analyzer
parentVersion bump, thanks to scarabeus for his help. (diff)
downloadgentoo-2-d887ae181e7c05ce0a1107d5294d3ac26e6e9445.tar.gz
gentoo-2-d887ae181e7c05ce0a1107d5294d3ac26e6e9445.tar.bz2
gentoo-2-d887ae181e7c05ce0a1107d5294d3ac26e6e9445.zip
Version BUmp, #265555, #228007, #196035, #210006, #276982; CLeaned old, #276982
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nessus-bin/ChangeLog11
-rw-r--r--net-analyzer/nessus-bin/files/nessusd-initd12
-rw-r--r--net-analyzer/nessus-bin/nessus-bin-3.0.5.ebuild70
-rw-r--r--net-analyzer/nessus-bin/nessus-bin-4.4.1.ebuild (renamed from net-analyzer/nessus-bin/nessus-bin-3.2.0.ebuild)53
4 files changed, 33 insertions, 113 deletions
diff --git a/net-analyzer/nessus-bin/ChangeLog b/net-analyzer/nessus-bin/ChangeLog
index 91634ce6c124..18e7c71dc86c 100644
--- a/net-analyzer/nessus-bin/ChangeLog
+++ b/net-analyzer/nessus-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/nessus-bin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/ChangeLog,v 1.13 2010/11/24 02:30:15 mattst88 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/ChangeLog,v 1.14 2011/04/20 12:21:00 jlec Exp $
+
+*nessus-bin-4.4.1 (20 Apr 2011)
+
+ 20 Apr 2011; Justin Lecher <jlec@gentoo.org> -nessus-bin-3.0.5.ebuild,
+ -nessus-bin-3.2.0.ebuild, +nessus-bin-4.4.1.ebuild, files/nessusd-initd:
+ Version BUmp, #265555, #228007, #196035, #210006, #276982; CLeaned old,
+ #276982
24 Nov 2010; <mattst88@gentoo.org> nessus-bin-3.2.0.ebuild:
Remove redundant dependency on rpm2targz.
diff --git a/net-analyzer/nessus-bin/files/nessusd-initd b/net-analyzer/nessus-bin/files/nessusd-initd
index 6cb213812e82..291df15b6ae6 100644
--- a/net-analyzer/nessus-bin/files/nessusd-initd
+++ b/net-analyzer/nessus-bin/files/nessusd-initd
@@ -1,21 +1,21 @@
#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/files/nessusd-initd,v 1.1 2006/11/29 16:53:30 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/files/nessusd-initd,v 1.2 2011/04/20 12:21:01 jlec Exp $
depend() {
need net
}
start() {
- ebegin "Starting nessusd"
- start-stop-daemon --start --quiet --exec /opt/nessus/sbin/nessusd -- -D --quiet
+ ebegin "Starting nessus-service"
+ start-stop-daemon --start --quiet --exec /opt/nessus/sbin/nessus-service -- -D --quiet
eend $?
}
stop() {
- ebegin "Stop nessusd"
- start-stop-daemon --stop --quiet --exec /opt/nessus/sbin/nessusd
+ ebegin "Stopping nessus-service"
+ start-stop-daemon --stop --quiet --exec /opt/nessus/sbin/nessus-service
einfo "Waiting for the environment to be sane"
while [ -n "$RUNNING" ] ; do
sleep 1
diff --git a/net-analyzer/nessus-bin/nessus-bin-3.0.5.ebuild b/net-analyzer/nessus-bin/nessus-bin-3.0.5.ebuild
deleted file mode 100644
index 8d8548c8bfb3..000000000000
--- a/net-analyzer/nessus-bin/nessus-bin-3.0.5.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/nessus-bin-3.0.5.ebuild,v 1.4 2007/07/02 14:39:26 peper Exp $
-
-inherit rpm
-
-MY_P="Nessus-${PV}-suse10.0.i586"
-# We are using SuSE's binary
-
-DESCRIPTION="A remote security scanner for Linux"
-HOMEPAGE="http://www.nessus.org"
-SRC_URI="${MY_P}.rpm"
-RESTRICT="mirror fetch strip"
-
-LICENSE="Nessus-EULA"
-SLOT="0"
-KEYWORDS="x86"
-IUSE="X"
-
-DEPEND="=sys-libs/db-4.3*
- dev-libs/openssl"
-
-PDEPEND="X? ( net-analyzer/nessus-client )"
-
-pkg_nofetch() {
- einfo "Please download ${MY_P}.rpm from ${HOMEPAGE}/download"
- einfo "The archive should then be placed into ${DISTDIR}."
-}
-
-pkg_setup() {
- case ${CHOST} in
- i586-pc-linux-gnu*) einfo "Found compatible architecture." ;;
- i686-pc-linux-gnu*) einfo "Found compatible architecture." ;;
- *) die "No compatible architecture found." ;;
- esac
-}
-
-src_install() {
- # copy files
- cp -pPR "${WORKDIR}"/opt "${D}"
-
- # make sure these directories do not vanish
- # nessus will not run properly without them
- keepdir /opt/nessus/etc/nessus
- keepdir /opt/nessus/var/nessus/jobs
- keepdir /opt/nessus/var/nessus/logs
- keepdir /opt/nessus/var/nessus/tmp
- keepdir /opt/nessus/var/nessus/users
-
- # add /opt/nessus/lib to LD_PATH
- # nessus will not run properly without it
- doenvd "${FILESDIR}"/90nessus-bin
-
- # we have /bin/gzip, not /usr/bin/gzip
- sed -i -e "s:/usr/bin/gzip:/bin/gzip:g" \
- "${D}"/opt/nessus/sbin/nessus-update-plugins
-
- # init script
- newinitd "${FILESDIR}"/nessusd-initd nessusd-bin
-}
-
-pkg_postinst() {
- elog "You can get started running the following commands:"
- elog "/opt/nessus/sbin/nessus-add-first-user"
- elog "/opt/nessus/sbin/nessus-mkcert"
- elog "/etc/init.d/nessusd-bin start"
- elog
- elog "For more information about nessus, please visit"
- elog "${HOMEPAGE}/documentation/"
-}
diff --git a/net-analyzer/nessus-bin/nessus-bin-3.2.0.ebuild b/net-analyzer/nessus-bin/nessus-bin-4.4.1.ebuild
index 5fd7a8e7613c..80c82cb9ad42 100644
--- a/net-analyzer/nessus-bin/nessus-bin-3.2.0.ebuild
+++ b/net-analyzer/nessus-bin/nessus-bin-4.4.1.ebuild
@@ -1,52 +1,40 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/nessus-bin-3.2.0.ebuild,v 1.4 2010/11/24 02:30:15 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/nessus-bin-4.4.1.ebuild,v 1.1 2011/04/20 12:21:00 jlec Exp $
inherit rpm
-MY_P="Nessus-${PV}-es5"
+MY_P="Nessus-${PV}-es6"
# We are using the Red Hat/CentOS binary
DESCRIPTION="A remote security scanner for Linux"
-HOMEPAGE="http://www.nessus.org"
-SRC_URI="x86? ( ${MY_P}.i386.rpm )
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="
+ x86? ( ${MY_P}.i686.rpm )
amd64? ( ${MY_P}.x86_64.rpm )"
+
RESTRICT="mirror fetch strip"
LICENSE="Nessus-EULA"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
IUSE="X"
-DEPEND="=sys-libs/db-4.3*
- >=dev-libs/openssl-0.9.8"
-
-PDEPEND="X? ( net-analyzer/nessus-client )"
-
pkg_nofetch() {
- if use x86; then
- elog "Please download ${MY_P}.i386.rpm from ${HOMEPAGE}/download"
- elog "The archive should then be placed into ${DISTDIR}."
- fi
-
- if use amd64; then
- elog "Please download ${MY_P}.x86_64.rpm from ${HOMEPAGE}/download"
- elog "The archive should then be placed into ${DISTDIR}."
- fi
+ einfo "Please download ${A} from ${HOMEPAGE}/download"
+ einfo "The archive should then be placed into ${DISTDIR}."
}
pkg_setup() {
case ${CHOST} in
- i586-pc-linux-gnu*) einfo "Found compatible architecture." ;;
- i686-pc-linux-gnu*) einfo "Found compatible architecture." ;;
- x86_64-pc-linux-gnu*) einfo "Found compatible architecture." ;;
- *) die "No compatible architecture found." ;;
+ i686-pc-linux-gnu*) einfo "Found compatible architecture." ;;
+ x86_64-pc-linux-gnu*) einfo "Found compatible architecture." ;;
+ *) die "No compatible architecture found." ;;
esac
}
src_install() {
- # copy files
- cp -pPR "${WORKDIR}"/opt "${D}"
+ cp -pPR "${WORKDIR}"/opt "${D}"/
# make sure these directories do not vanish
# nessus will not run properly without them
@@ -56,25 +44,20 @@ src_install() {
keepdir /opt/nessus/var/nessus/tmp
keepdir /opt/nessus/var/nessus/users
- # add /opt/nessus/lib to LD_PATH
- # nessus will not run properly without it
+ # add PATH and MANPATH for convenience
doenvd "${FILESDIR}"/90nessus-bin
- # we have /bin/gzip, not /usr/bin/gzip
- sed -i -e "s:/usr/bin/gzip:/bin/gzip:g" \
- "${D}"/opt/nessus/sbin/nessus-update-plugins
-
# init script
newinitd "${FILESDIR}"/nessusd-initd nessusd-bin
-
- dosym /usr/lib/libssl.so.0.9.8 /usr/lib/libssl.so.6
- dosym /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.6
+ dosym libssl.so /usr/$(get_libdir)/libssl.so.10
+ dosym libcrypto.so /usr/$(get_libdir)/libcrypto.so.10
}
pkg_postinst() {
elog "You can get started running the following commands:"
elog "/opt/nessus/sbin/nessus-adduser"
elog "/opt/nessus/sbin/nessus-mkcert"
+ elog "/opt/nessus/bin/nessus-fetch --register <your registration code>"
elog "/etc/init.d/nessusd-bin start"
elog
elog "If you had a previous version of Nessus installed, use"