summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-10-17 10:15:20 +0000
committerPeter Volkov <pva@gentoo.org>2008-10-17 10:15:20 +0000
commitb8e0f9c1d8df097f09b177884a5d1f14d1534baa (patch)
tree04459747955d7e5206b92495f069098a48439a3d /net-analyzer
parentchangelog email updated to g.o address (diff)
downloadgentoo-2-b8e0f9c1d8df097f09b177884a5d1f14d1534baa.tar.gz
gentoo-2-b8e0f9c1d8df097f09b177884a5d1f14d1534baa.tar.bz2
gentoo-2-b8e0f9c1d8df097f09b177884a5d1f14d1534baa.zip
Fixed build issue with --as-needed and lua enabled. Fixed build issues with -ftracer, bug #239941, thank Thomas Pegeot for report.
(Portage version: 2.2_rc12/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog8
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.1.1--as-needed.patch11
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.1.1-misc-warnings.patch134
-rw-r--r--net-analyzer/wireshark/wireshark-1.1.1.ebuild7
4 files changed, 157 insertions, 3 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 7a2ac5d2d5a5..d9406615c15f 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.124 2008/10/10 19:14:20 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.125 2008/10/17 10:15:20 pva Exp $
+
+ 17 Oct 2008; Peter Volkov <pva@gentoo.org>
+ +files/wireshark-1.1.1--as-needed.patch,
+ +files/wireshark-1.1.1-misc-warnings.patch, wireshark-1.1.1.ebuild:
+ Fixed build issue with --as-needed and lua enabled. Fixed build issues with
+ -ftracer, bug #239941, thank Thomas Pegeot for report.
*wireshark-1.1.1 (10 Oct 2008)
diff --git a/net-analyzer/wireshark/files/wireshark-1.1.1--as-needed.patch b/net-analyzer/wireshark/files/wireshark-1.1.1--as-needed.patch
new file mode 100644
index 000000000000..bf708c5b98f8
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.1.1--as-needed.patch
@@ -0,0 +1,11 @@
+--- ./epan/wslua/Makefile.am.orig 2008-10-17 12:08:43.000000000 +0400
++++ ./epan/wslua/Makefile.am 2008-10-17 12:08:48.000000000 +0400
+@@ -47,7 +47,7 @@
+ init_wslua.c \
+ wslua.h
+
+-libwslua_la_LIBADD = @LUA_LIBS@
++libwslua_la_LIBADD = @LUA_LIBS@ ../../wiretap/libwiretap.la
+
+ BUILT_SOURCES = \
+ taps_wslua.c \
diff --git a/net-analyzer/wireshark/files/wireshark-1.1.1-misc-warnings.patch b/net-analyzer/wireshark/files/wireshark-1.1.1-misc-warnings.patch
new file mode 100644
index 000000000000..8a5e26a0a4e9
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.1.1-misc-warnings.patch
@@ -0,0 +1,134 @@
+--- ./epan/dissectors/packet-ldp.c.orig 2008-10-16 22:58:47.000000000 +0400
++++ ./epan/dissectors/packet-ldp.c 2008-10-16 22:59:03.000000000 +0400
+@@ -2484,7 +2484,7 @@
+ int length_remaining;
+ guint16 plen;
+ int length;
+- tvbuff_t *next_tvb;
++ tvbuff_t *volatile next_tvb;
+
+ while (tvb_reported_length_remaining(tvb, offset) != 0) {
+ length_remaining = tvb_length_remaining(tvb, offset);
+--- ./epan/dissectors/packet-tpkt.c.orig 2008-10-16 23:24:58.000000000 +0400
++++ ./epan/dissectors/packet-tpkt.c 2008-10-16 23:25:27.000000000 +0400
+@@ -217,7 +217,7 @@
+ int mgcp_version = 0;
+ int mgcp_reserved = 0;
+ volatile int length;
+- tvbuff_t *next_tvb;
++ tvbuff_t *volatile next_tvb;
+ const char *saved_proto;
+ guint8 string[4];
+ /*
+@@ -372,7 +372,7 @@
+ int length_remaining;
+ int data_len;
+ volatile int length;
+- tvbuff_t *next_tvb;
++ tvbuff_t *volatile next_tvb;
+ const char *saved_proto;
+
+ /*
+--- ./epan/dissectors/packet-gssapi.c.orig 2008-10-16 22:55:09.000000000 +0400
++++ ./epan/dissectors/packet-gssapi.c 2008-10-16 22:56:06.000000000 +0400
+@@ -172,8 +172,8 @@
+ dissect_gssapi_work(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree,
+ gboolean is_verifier)
+ {
+- proto_item *item;
+- proto_tree *subtree;
++ proto_item *volatile item;
++ proto_tree *volatile subtree;
+ volatile int return_offset = 0;
+ gssapi_conv_info_t *volatile gss_info;
+ gssapi_oid_value *oidvalue;
+--- ./epan/dissectors/packet-tds.c.orig 2008-10-16 23:22:27.000000000 +0400
++++ ./epan/dissectors/packet-tds.c 2008-10-16 23:22:40.000000000 +0400
+@@ -1725,7 +1725,7 @@
+ guint8 type;
+ guint16 plen;
+ guint length;
+- tvbuff_t *next_tvb;
++ tvbuff_t *volatile next_tvb;
+ proto_item *tds_item = NULL;
+ proto_tree *tds_tree = NULL;
+
+--- ./epan/dissectors/packet-isl.c.orig 2008-10-16 22:57:53.000000000 +0400
++++ ./epan/dissectors/packet-isl.c 2008-10-16 22:58:15.000000000 +0400
+@@ -149,7 +149,7 @@
+ {
+ proto_tree *volatile fh_tree = NULL;
+ proto_item *ti, *hidden_item;
+- guint8 type;
++ volatile guint8 type;
+ volatile guint16 length;
+ gint captured_length;
+ tvbuff_t *volatile payload_tvb = NULL;
+--- ./epan/dissectors/packet-ieee802154.c.orig 2008-10-16 22:56:53.000000000 +0400
++++ ./epan/dissectors/packet-ieee802154.c 2008-10-16 22:57:23.000000000 +0400
+@@ -484,7 +484,7 @@
+ static void
+ dissect_ieee802154_common(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree, guint options)
+ {
+- tvbuff_t *payload_tvb;
++ tvbuff_t *volatile payload_tvb;
+ proto_tree *volatile ieee802154_tree = NULL;
+ proto_item *volatile proto_root = NULL;
+ proto_item *ti;
+--- ./epan/dissectors/packet-tr.c.orig 2008-10-16 23:25:37.000000000 +0400
++++ ./epan/dissectors/packet-tr.c 2008-10-16 23:26:20.000000000 +0400
+@@ -326,10 +326,10 @@
+ {
+ proto_tree *tr_tree, *bf_tree;
+ proto_item *ti, *hidden_item;
+- int frame_type;
+ guint8 rcf1, rcf2;
+ tvbuff_t *next_tvb;
+
++ volatile int frame_type;
+ volatile int fixoffset = 0;
+ volatile int source_routed = 0;
+ volatile guint8 trn_rif_bytes;
+--- ./epan/dissectors/packet-bgp.c.orig 2008-10-16 22:40:35.000000000 +0400
++++ ./epan/dissectors/packet-bgp.c 2008-10-16 22:49:31.000000000 +0400
+@@ -2623,7 +2623,7 @@
+ }
+
+ static void
+-dissect_bgp_pdu(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree,
++dissect_bgp_pdu(tvbuff_t *volatile tvb, packet_info *pinfo, proto_tree *tree,
+ gboolean first)
+ {
+ guint16 bgp_len; /* Message length */
+@@ -2740,7 +2740,7 @@
+ guint length_remaining;
+ guint length;
+ volatile gboolean first = TRUE; /* TRUE for the first BGP message in packet */
+- tvbuff_t *next_tvb;
++ tvbuff_t *volatile next_tvb;
+
+ if (check_col(pinfo->cinfo, COL_PROTOCOL))
+ col_set_str(pinfo->cinfo, COL_PROTOCOL, "BGP");
+--- ./epan/dissectors/packet-ethertype.c.orig 2008-10-16 22:51:48.000000000 +0400
++++ ./epan/dissectors/packet-ethertype.c 2008-10-16 22:52:25.000000000 +0400
+@@ -193,7 +193,7 @@
+ guint length_before;
+ gint captured_length, reported_length;
+ volatile gboolean dissector_found = FALSE;
+- const char *saved_proto;
++ const char *volatile saved_proto;
+
+ /* Add the Ethernet type to the protocol tree */
+ if (tree) {
+--- ./epan/dissectors/packet-vlan.c.orig 2008-10-16 23:26:42.000000000 +0400
++++ ./epan/dissectors/packet-vlan.c 2008-10-16 23:27:07.000000000 +0400
+@@ -74,7 +74,8 @@
+ dissect_vlan(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree)
+ {
+ proto_tree *ti;
+- guint16 tci,encap_proto;
++ guint16 tci;
++ volatile guint16 encap_proto;
+ volatile gboolean is_802_2;
+ proto_tree *volatile vlan_tree;
+
diff --git a/net-analyzer/wireshark/wireshark-1.1.1.ebuild b/net-analyzer/wireshark/wireshark-1.1.1.ebuild
index 96cc10e2bd3a..0be238641cb9 100644
--- a/net-analyzer/wireshark/wireshark-1.1.1.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.1.1.ebuild,v 1.1 2008/10/10 19:14:20 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.1.1.ebuild,v 1.2 2008/10/17 10:15:20 pva Exp $
EAPI=1
inherit autotools libtool flag-o-matic eutils toolchain-funcs
@@ -67,9 +67,12 @@ src_unpack() {
# our hardened toolchain bug...
cd "${S}"/epan
- epatch "${FILESDIR}"/wireshark-except-double-free.diff
+ epatch "${FILESDIR}/wireshark-except-double-free.diff"
cd "${S}"
+ epatch "${FILESDIR}/${P}-misc-warnings.patch"
+ # made dependent on lua as generally dissectors shouldn't depend on wiretap
+ use lua && epatch "${FILESDIR}/${P}--as-needed.patch"
eautoreconf
}