summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-04-27 13:50:15 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-04-27 13:50:15 +0000
commitb1bcb8596ba387a4def6804dcc1bf2e3033eb98d (patch)
tree127c940acec6586f70233a912f240676db91da91 /net-analyzer
parentppc/ppc64 stable wrt #364973 (diff)
downloadgentoo-2-b1bcb8596ba387a4def6804dcc1bf2e3033eb98d.tar.gz
gentoo-2-b1bcb8596ba387a4def6804dcc1bf2e3033eb98d.tar.bz2
gentoo-2-b1bcb8596ba387a4def6804dcc1bf2e3033eb98d.zip
Version bump to 1.1.10_p1.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/mk-livestatus/ChangeLog8
-rw-r--r--net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild112
-rw-r--r--net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild4
3 files changed, 121 insertions, 3 deletions
diff --git a/net-analyzer/mk-livestatus/ChangeLog b/net-analyzer/mk-livestatus/ChangeLog
index 6b7447d1f34b..c92dd73439a6 100644
--- a/net-analyzer/mk-livestatus/ChangeLog
+++ b/net-analyzer/mk-livestatus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/mk-livestatus
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/ChangeLog,v 1.2 2011/03/11 08:49:47 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/ChangeLog,v 1.3 2011/04/27 13:50:15 idl0r Exp $
+
+*mk-livestatus-1.1.10_p1 (27 Apr 2011)
+
+ 27 Apr 2011; Christian Ruppert <idl0r@gentoo.org> mk-livestatus-1.1.8.ebuild,
+ +mk-livestatus-1.1.10_p1.ebuild:
+ Version bump to 1.1.10_p1.
11 Mar 2011; Torsten Veller <tove@gentoo.org> mk-livestatus-1.1.8.ebuild:
Change dependency: Thread-Queue is a core module
diff --git a/net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild b/net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild
new file mode 100644
index 000000000000..04b05c9babed
--- /dev/null
+++ b/net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild,v 1.1 2011/04/27 13:50:15 idl0r Exp $
+
+EAPI=3
+
+GENTOO_DEPEND_ON_PERL=no
+PERL_EXPORT_PHASE_FUNCTIONS=no
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+
+inherit perl-module python
+
+DESCRIPTION="Nagios/Icinga event broker module that allows quick/direct access to your status data"
+HOMEPAGE="http://mathias-kettner.de/checkmk_livestatus.html"
+SRC_URI="http://mathias-kettner.de/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples perl python test"
+
+RDEPEND="perl? (
+ dev-lang/perl
+ virtual/perl-Digest-MD5
+ virtual/perl-Thread-Queue
+ )"
+DEPEND="${RDEPEND}
+ perl? (
+ dev-perl/Module-Install
+ test? (
+ dev-perl/File-Copy-Recursive
+ dev-perl/Test-Pod
+ dev-perl/Test-Perl-Critic
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Perl-Critic
+ dev-perl/Perl-Critic-Policy-Dynamic-NoIndirect
+ dev-perl/Perl-Critic-Deprecated
+ dev-perl/Perl-Critic-Nits
+ )
+ )"
+
+# For perl test
+SRC_TEST="parallel"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Use system Module::Install instead, it will be copied to $S by
+ # Module::install itself.
+ rm -rf api/perl/inc
+
+ if use perl; then
+ perl-module_src_prepare
+ fi
+
+ sed -i -e 's:$(LDFLAGS) -s:$(LDFLAGS):' src/Makefile.in || die
+}
+
+src_configure() {
+ econf
+
+ if use perl; then
+ cd api/perl/
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ emake || die
+
+ if use perl; then
+ cd api/perl
+ perl-module_src_compile
+ fi
+}
+
+src_test() {
+ if use perl; then
+ cd api/perl
+
+ export TEST_AUTHOR="Test Author"
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ emake -C src/ DESTDIR="${D}" install-binPROGRAMS install-data-local || die
+
+ if use perl; then
+ cd api/perl
+ perl-module_src_install
+ cd "${S}"
+
+ if use examples; then
+ docinto examples/
+ dodoc api/perl/examples/dump.pl || die
+ fi
+ fi
+ if use python; then
+ insinto $(python_get_sitedir)
+ doins api/python/livestatus.py || die
+
+ if use examples; then
+ newdoc api/python/README README.python || die
+
+ docinto examples/
+ dodoc api/python/{example,example_multisite,make_nagvis_map}.py || die
+ fi
+ fi
+}
diff --git a/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild b/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild
index e276c223693d..586f0260a751 100644
--- a/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild
+++ b/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild,v 1.2 2011/03/11 08:49:47 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild,v 1.3 2011/04/27 13:50:15 idl0r Exp $
EAPI=3
@@ -42,7 +42,7 @@ DEPEND="${RDEPEND}
SRC_TEST="parallel"
src_prepare() {
- # Use system Module::Install instead, it will be copied to $WORKDIR by
+ # Use system Module::Install instead, it will be copied to $S by
# Module::install itself.
rm -rf api/perl/inc