summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2013-07-01 10:29:06 +0000
committerHanno Böck <hanno@gentoo.org>2013-07-01 10:29:06 +0000
commit9a66e4e7b8bf731cde4ac1b263b084e5ae8148e2 (patch)
treed5f20541361c335f89a957d7fa6360fdba6945ba /net-analyzer
parentgreenbone-security-assistant: Bump, EAPI 5 port, remove old workarounds. (diff)
downloadgentoo-2-9a66e4e7b8bf731cde4ac1b263b084e5ae8148e2.tar.gz
gentoo-2-9a66e4e7b8bf731cde4ac1b263b084e5ae8148e2.tar.bz2
gentoo-2-9a66e4e7b8bf731cde4ac1b263b084e5ae8148e2.zip
openvas-cli: Bump, EAPI 5.
(Portage version: 2.1.12.11/cvs/Linux x86_64, signed Manifest commit with key 0xA5880072BBB51E42)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/openvas-cli/ChangeLog9
-rw-r--r--net-analyzer/openvas-cli/openvas-cli-1.2.0.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/net-analyzer/openvas-cli/ChangeLog b/net-analyzer/openvas-cli/ChangeLog
index 71adf883a8ae..8efa7b3c0592 100644
--- a/net-analyzer/openvas-cli/ChangeLog
+++ b/net-analyzer/openvas-cli/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/openvas-cli
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-cli/ChangeLog,v 1.2 2012/05/04 06:08:09 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-cli/ChangeLog,v 1.3 2013/07/01 10:29:06 hanno Exp $
+
+*openvas-cli-1.2.0 (01 Jul 2013)
+
+ 01 Jul 2013; Hanno Boeck <hanno@gentoo.org> +openvas-cli-1.2.0.ebuild:
+ Bump, EAPI 5.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> openvas-cli-1.1.2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/net-analyzer/openvas-cli/openvas-cli-1.2.0.ebuild b/net-analyzer/openvas-cli/openvas-cli-1.2.0.ebuild
new file mode 100644
index 000000000000..905ddd045730
--- /dev/null
+++ b/net-analyzer/openvas-cli/openvas-cli-1.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-cli/openvas-cli-1.2.0.ebuild,v 1.1 2013/07/01 10:29:06 hanno Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A remote security scanner for Linux (openvas-cli)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/1323/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=net-analyzer/openvas-libraries-6.0.0
+ !net-analyzer/openvas-client"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/cmake"
+
+src_configure() {
+ local mycmakeargs="-DLOCALSTATEDIR=/var -DSYSCONFDIR=/etc"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog CHANGES README || die "dodoc failed"
+}