summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-11 03:43:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-11 03:43:28 +0000
commit9616c4a6cbbd3ff8c50dcdf697d9ea67e61113e1 (patch)
treedd9601484f057ec07eedc11d924261207ee0c0ea /net-analyzer
parentFix building with OpenSSL >= 1.0.0 wrt #326531 by Daniel Black. Revision bump... (diff)
downloadgentoo-2-9616c4a6cbbd3ff8c50dcdf697d9ea67e61113e1.tar.gz
gentoo-2-9616c4a6cbbd3ff8c50dcdf697d9ea67e61113e1.tar.bz2
gentoo-2-9616c4a6cbbd3ff8c50dcdf697d9ea67e61113e1.zip
Fix building with OpenSSL >= 1.0.0 wrt #326545.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/libnasl/ChangeLog6
-rw-r--r--net-analyzer/libnasl/files/libnasl-2.2.9-openssl-1.patch45
-rw-r--r--net-analyzer/libnasl/libnasl-2.2.9.ebuild26
3 files changed, 67 insertions, 10 deletions
diff --git a/net-analyzer/libnasl/ChangeLog b/net-analyzer/libnasl/ChangeLog
index d0db0cbfedef..f829fb600bdc 100644
--- a/net-analyzer/libnasl/ChangeLog
+++ b/net-analyzer/libnasl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/libnasl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/ChangeLog,v 1.85 2010/01/01 17:38:22 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/ChangeLog,v 1.86 2010/07/11 03:43:28 ssuominen Exp $
+
+ 11 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> libnasl-2.2.9.ebuild,
+ +files/libnasl-2.2.9-openssl-1.patch:
+ Fix building with OpenSSL >= 1.0.0 wrt #326545.
01 Jan 2010; Christian Faulhammer <fauli@gentoo.org> libnasl-2.3.1.ebuild:
Transfer Prefix keywords
diff --git a/net-analyzer/libnasl/files/libnasl-2.2.9-openssl-1.patch b/net-analyzer/libnasl/files/libnasl-2.2.9-openssl-1.patch
new file mode 100644
index 000000000000..7d620256a5b5
--- /dev/null
+++ b/net-analyzer/libnasl/files/libnasl-2.2.9-openssl-1.patch
@@ -0,0 +1,45 @@
+http://bugs.gentoo.org/326545
+
+--- nasl/nasl_crypto.c
++++ nasl/nasl_crypto.c
+@@ -22,7 +22,9 @@
+ */
+ #include <includes.h>
+ #ifdef HAVE_SSL
++#ifdef HAVE_OPENSSL_MD2_H
+ #include <openssl/md2.h>
++#endif
+ #include <openssl/md4.h>
+ #include <openssl/md5.h>
+ #include <openssl/ripemd.h>
+@@ -45,6 +47,7 @@
+
+
+ /*-------------------[ Std. HASH ]-------------------------------------*/
++#ifdef HAVE_OPENSSL_MD2_H
+ tree_cell * nasl_md2(lex_ctxt * lexic)
+ {
+ char * data = get_str_var_by_num(lexic, 0);
+@@ -63,6 +66,7 @@
+ retc->size = MD2_DIGEST_LENGTH;
+ return retc;
+ }
++#endif
+
+ tree_cell * nasl_md4(lex_ctxt * lexic)
+ {
+@@ -192,12 +196,12 @@
+ return retc;
+ }
+
+-
++#ifdef HAVE_OPENSSL_MD2_H
+ tree_cell * nasl_hmac_md2(lex_ctxt * lexic)
+ {
+ return nasl_hmac(lexic, EVP_md2());
+ }
+-
++#endif
+
+ tree_cell * nasl_hmac_md5(lex_ctxt * lexic)
+ {
diff --git a/net-analyzer/libnasl/libnasl-2.2.9.ebuild b/net-analyzer/libnasl/libnasl-2.2.9.ebuild
index a0797181885e..e5e1ec1edf97 100644
--- a/net-analyzer/libnasl/libnasl-2.2.9.ebuild
+++ b/net-analyzer/libnasl/libnasl-2.2.9.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/libnasl-2.2.9.ebuild,v 1.2 2007/04/11 13:50:23 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/libnasl-2.2.9.ebuild,v 1.3 2010/07/11 03:43:28 ssuominen Exp $
-inherit toolchain-funcs
+EAPI=2
+inherit eutils toolchain-funcs
DESCRIPTION="A remote security scanner for Linux (libnasl)"
HOMEPAGE="http://www.nessus.org/"
@@ -15,16 +16,23 @@ IUSE=""
DEPEND="=net-analyzer/nessus-libraries-${PV}"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-openssl-1.patch
+}
+
+src_configure() {
+ tc-export CC
+ econf
+}
src_compile() {
- export CC="$(tc-getCC)"
- econf || die "configuration failed"
# emake fails for >= -j2. bug #16471.
- emake -C nasl cflags
- emake || die "make failed"
+ emake -C nasl cflags || die
+ emake || die
}
src_install() {
- make DESTDIR="${D}" install || die "Install failed libnasl"
+ emake DESTDIR="${D}" install || die
}