summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-12-01 10:40:10 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-12-01 10:40:10 +0000
commit6a27f4e0aabc5d41512c89ff72a5b64b92b43b05 (patch)
tree1f05c47fa0da2159d9c2d7eff4994f39ed6e8031 /net-analyzer
parentadns USE flag support (diff)
downloadgentoo-2-6a27f4e0aabc5d41512c89ff72a5b64b92b43b05.tar.gz
gentoo-2-6a27f4e0aabc5d41512c89ff72a5b64b92b43b05.tar.bz2
gentoo-2-6a27f4e0aabc5d41512c89ff72a5b64b92b43b05.zip
adns USE flag support
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ethereal/ChangeLog8
-rw-r--r--net-analyzer/ethereal/Manifest4
-rw-r--r--net-analyzer/ethereal/ethereal-0.9.16-r1.ebuild84
-rw-r--r--net-analyzer/ethereal/files/digest-ethereal-0.9.16-r11
4 files changed, 94 insertions, 3 deletions
diff --git a/net-analyzer/ethereal/ChangeLog b/net-analyzer/ethereal/ChangeLog
index 65ddc2e08b28..9e89e0068ca4 100644
--- a/net-analyzer/ethereal/ChangeLog
+++ b/net-analyzer/ethereal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/ethereal
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.43 2003/11/28 02:05:18 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.44 2003/12/01 10:40:04 phosphan Exp $
+
+*ethereal-0.9.16-r1 (01 Dec 2003)
+
+ 01 Dec 2003; Patrick Kursawe <phosphan@gentoo.org>
+ ethereal-0.9.16-r1.ebuild:
+ Added "adns" USE flag.
28 Nov 2003; <spider@gentoo.org> ethereal-0.9.16.ebuild:
added a !gtk ( ) catch for glib.
diff --git a/net-analyzer/ethereal/Manifest b/net-analyzer/ethereal/Manifest
index 178c1b7aaad1..dae471fa83ac 100644
--- a/net-analyzer/ethereal/Manifest
+++ b/net-analyzer/ethereal/Manifest
@@ -1,9 +1,9 @@
MD5 dfba4396f60b494565bbfc3845e09cec ethereal-0.9.13.ebuild 2129
MD5 713ccb1a29559f9aec965e29109f1921 ethereal-0.9.15.ebuild 1992
MD5 fbffd5111c567be992554eacb269ba64 ethereal-0.9.14.ebuild 2082
-MD5 95e8be66c7f7908ab2ce8a1b61492b5d ChangeLog 6570
+MD5 9764c95cba63550a95788480acf075da ChangeLog 6572
MD5 e1a4d9cc59f15fc1849d3a6653eded3e ethereal-0.9.16.ebuild 2262
-MD5 fe66f8d52b505b10ab6a450b9c8c9516 ethereal-0.9.16-r1.ebuild 2332
+MD5 c76656ffb308c4f9bc6b6afae1e5c9d5 ethereal-0.9.16-r1.ebuild 2335
MD5 3ce13570e210d6dc1669b91936d2f051 files/digest-ethereal-0.9.16-r1 69
MD5 44dcde01bfc4b986a229fa28dee9f9e7 files/digest-ethereal-0.9.13 69
MD5 380524e1a6116898080fe64bed810144 files/digest-ethereal-0.9.14 69
diff --git a/net-analyzer/ethereal/ethereal-0.9.16-r1.ebuild b/net-analyzer/ethereal/ethereal-0.9.16-r1.ebuild
new file mode 100644
index 000000000000..3f5a2bfdb680
--- /dev/null
+++ b/net-analyzer/ethereal/ethereal-0.9.16-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.9.16-r1.ebuild,v 1.1 2003/12/01 10:40:04 phosphan Exp $
+
+IUSE="adns gtk ipv6 snmp ssl gtk2"
+inherit libtool
+S=${WORKDIR}/${P}
+DESCRIPTION="A commercial-quality network protocol analyzer"
+SRC_URI="http://www.ethereal.com/distribution/${P}.tar.bz2"
+HOMEPAGE="http://www.ethereal.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha amd64"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ snmp? ( virtual/snmp )
+ gtk? (
+ gtk2? ( >=dev-libs/glib-2.0.4 =x11-libs/gtk+-2* )
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ )
+ !gtk ( =dev-libs/glib-1.2* )
+ ssl? ( >=dev-libs/openssl-0.9.6e )
+ >=net-libs/libpcap-0.7.1
+ adns? ( net-libs/adns )"
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-devel/bison
+ sys-devel/flex"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # re-declaring functions is no good idea
+ sed -i 's/getline/packet_giop_getline/g' packet-giop.c
+ elibtoolize
+ # gcc related configure script braindamage
+ sed -i "s|-I/usr/local/include||" configure
+ chmod +x ./configure
+ sed -i "s|@PCAP_LIBS@ @SOCKET_LIBS@ @NSL_LIBS@|@PCAP_LIBS@ @SOCKET_LIBS@ @NSL_LIBS@ @ADNS_LIBS@|" \
+ Makefile.am
+}
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use gtk`" ] && [ -z "`use gtk2`" ]; then
+ myconf="${myconf} --disable-ethereal"
+ # the asn1 plugin needs gtk
+ sed -i -e '/plugins\/asn1/c\' Makefile.in
+ sed -i -e 's/\(^SUBDIRS.*\)asn1\(.*\)/\1\2/' plugins/Makefile.in
+ fi
+
+ use gtk2 && myconf="${myconf} --enable-gtk2"
+ use ssl || myconf="${myconf} --without-ssl"
+ use snmp || myconf="${myconf} --without-ucd-snmp --without-net-snmp"
+ myconf="${myconf} $(use_enable ipv6)"
+ myconf="${myconf} $(use_with adns)"
+
+ econf \
+ --enable-pcap \
+ --enable-zlib \
+ --enable-tethereal \
+ --enable-editcap \
+ --enable-mergecap \
+ --enable-text2cap \
+ --enable-idl2eth \
+ --enable-dftest \
+ --enable-randpkt \
+ --sysconfdir=/etc/ethereal \
+ --with-plugindir=/usr/lib/ethereal/plugins/${PV} \
+ ${myconf} || die "bad ./configure"
+ addwrite "/usr/share/snmp/mibs/.index"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ addwrite "/usr/share/snmp/mibs/.index"
+ dodir /usr/lib/ethereal/plugins/${PV}
+ make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog INSTALL.* NEWS README* TODO
+}
diff --git a/net-analyzer/ethereal/files/digest-ethereal-0.9.16-r1 b/net-analyzer/ethereal/files/digest-ethereal-0.9.16-r1
new file mode 100644
index 000000000000..9c887b98c6cd
--- /dev/null
+++ b/net-analyzer/ethereal/files/digest-ethereal-0.9.16-r1
@@ -0,0 +1 @@
+MD5 ab33d191f3cca324e5c819e9e4c034e1 ethereal-0.9.16.tar.bz2 4288070