summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-08-15 23:44:20 +0000
committerJeroen Roovers <jer@gentoo.org>2010-08-15 23:44:20 +0000
commit57ac5197a37383caccaef2120c5d9c7d0c5d31bb (patch)
treec48a312db026b98c1968700ce4cde687662f0d5e /net-analyzer
parentwhitespace (diff)
downloadgentoo-2-57ac5197a37383caccaef2120c5d9c7d0c5d31bb.tar.gz
gentoo-2-57ac5197a37383caccaef2120c5d9c7d0c5d31bb.tar.bz2
gentoo-2-57ac5197a37383caccaef2120c5d9c7d0c5d31bb.zip
Respect LDFLAGS (bug #332831). Do not hardwire CC in Makefile.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/amap/ChangeLog9
-rw-r--r--net-analyzer/amap/amap-5.2-r2.ebuild73
2 files changed, 80 insertions, 2 deletions
diff --git a/net-analyzer/amap/ChangeLog b/net-analyzer/amap/ChangeLog
index ab3d3a5ec93a..68de89391b6d 100644
--- a/net-analyzer/amap/ChangeLog
+++ b/net-analyzer/amap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/amap
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/amap/ChangeLog,v 1.44 2009/08/25 23:59:07 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/amap/ChangeLog,v 1.45 2010/08/15 23:44:20 jer Exp $
+
+*amap-5.2-r2 (15 Aug 2010)
+
+ 15 Aug 2010; Jeroen Roovers <jer@gentoo.org> +amap-5.2-r2.ebuild:
+ Respect LDFLAGS (bug #332831). Do not hardwire CC in Makefile.
25 Aug 2009; Jeroen Roovers <jer@gentoo.org> -amap-4.8-r1.ebuild,
-files/amap-4.8-fix-icky-lvalue-casts.diff, -files/amap-4.8-gcc4.patch,
diff --git a/net-analyzer/amap/amap-5.2-r2.ebuild b/net-analyzer/amap/amap-5.2-r2.ebuild
new file mode 100644
index 000000000000..a3eef76b6667
--- /dev/null
+++ b/net-analyzer/amap/amap-5.2-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/amap/amap-5.2-r2.ebuild,v 1.1 2010/08/15 23:44:20 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A network scanning tool for pentesters"
+HOMEPAGE="http://www.thc.org/thc-amap/"
+SRC_URI="http://www.thc.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl"
+
+DEPEND="
+ dev-libs/libpcre
+ ssl? ( >=dev-libs/openssl-0.9.6j )
+"
+RDEPEND="
+ ${DEPEND}
+ !sci-biology/amap
+"
+
+src_prepare() {
+ rm -rf pcre-3.9
+ sed -i -e "s:etc/:share/amap/:g" amap-lib.c || die "sed amap-lib.c failed"
+ # Above change requires below change. See sources...
+ sed -i '/strlen(AMAP_PREFIX/s: 5 : 12 :' amap-lib.c || die "sed amap-lib.c failed"
+ sed -i 's:/usr/local:/usr:' amap.h || die "sed amap.h failed"
+ # Files to be updated are at different location, bug 207839.
+ sed -i '/AMAP_RESOURCE/s:www:freeworld:' amap.h || die "sed amap.h failed"
+
+ sed -i '/DATADIR/s:/etc:/share/amap:' Makefile.am || die "sed Makefile.am failed"
+
+ epatch "${FILESDIR}"/4.8-system-pcre.patch
+}
+
+src_configure() {
+ # has it's own stupid custom configure script
+ ./configure || die "configure failed"
+ sed -i \
+ -e '/^XDEFINES=/s:=.*:=:' \
+ -e '/^XLIBS=/s:=.*:=:' \
+ -e '/^XLIBPATHS/s:=.*:=:' \
+ -e '/^XIPATHS=/s:=.*:=:' \
+ -e "/^CC=/d" \
+ Makefile || die "pruning vars"
+ if use ssl ; then
+ sed -i \
+ -e '/^XDEFINES=/s:=:=-DOPENSSL:' \
+ -e '/^XLIBS=/s:=:=-lcrypto -lssl:' \
+ Makefile || die "adding ssl"
+ fi
+ sed -i Makefile \
+ -e '/-o amap/{s|(OPT) |(OPT) $(LDFLAGS) |g}' \
+ || die "respecting LDFLAGS failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin amap amapcrap || die "dobin failed"
+ insinto /usr/share/amap
+ doins appdefs.* || die "doins failed"
+
+ doman ${PN}.1
+ dodoc README TODO CHANGES
+}