summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2014-01-12 11:10:54 +0000
committerFabio Erculiani <lxnay@gentoo.org>2014-01-12 11:10:54 +0000
commit4db8c8cd931b2d7ee1cd2e31627a8267f382f031 (patch)
tree9c59b7c637c389ce5edc6ba66bf3ffd723c5527d /net-analyzer
parentVersion bump by David Abbott <dabbott@gentoo.org>. Bug #497724 (diff)
downloadgentoo-2-4db8c8cd931b2d7ee1cd2e31627a8267f382f031.tar.gz
gentoo-2-4db8c8cd931b2d7ee1cd2e31627a8267f382f031.tar.bz2
gentoo-2-4db8c8cd931b2d7ee1cd2e31627a8267f382f031.zip
add systemd support to the logrotate file, call init.d only when running with openrc, revbump 2.0.19-r1, drop unstable-only 2.0.14 (there is 2.0.14-r1 which is also stable...). All this on behalf of flameeyes@g.o.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key ADC916E5)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/munin/ChangeLog12
-rw-r--r--net-analyzer/munin/files/logrotate.d-munin.331
-rw-r--r--net-analyzer/munin/munin-2.0.19-r1.ebuild (renamed from net-analyzer/munin/munin-2.0.14.ebuild)28
-rw-r--r--net-analyzer/munin/munin-2.1.9999.ebuild6
4 files changed, 61 insertions, 16 deletions
diff --git a/net-analyzer/munin/ChangeLog b/net-analyzer/munin/ChangeLog
index 5ee11d791a0e..f0c3961d51b7 100644
--- a/net-analyzer/munin/ChangeLog
+++ b/net-analyzer/munin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/munin
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.152 2013/12/23 13:26:31 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.153 2014/01/12 11:10:54 lxnay Exp $
+
+*munin-2.0.19-r1 (12 Jan 2014)
+
+ 12 Jan 2014; Fabio Erculiani <lxnay@gentoo.org> -munin-2.0.14.ebuild,
+ +munin-2.0.19-r1.ebuild, munin-2.1.9999.ebuild, +files/logrotate.d-munin.3:
+ add systemd support to the logrotate file, call init.d only when running with
+ openrc, revbump 2.0.19-r1, drop unstable-only 2.0.14 (there is 2.0.14-r1
+ which is also stable...). All this on behalf of flameeyes@g.o.
23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> munin-2.0.19.ebuild:
Stable for amd64, wrt bug #493290
diff --git a/net-analyzer/munin/files/logrotate.d-munin.3 b/net-analyzer/munin/files/logrotate.d-munin.3
new file mode 100644
index 000000000000..e7e1dda3fc65
--- /dev/null
+++ b/net-analyzer/munin/files/logrotate.d-munin.3
@@ -0,0 +1,31 @@
+/var/log/munin/munin-node.log {
+ daily
+ missingok
+ rotate 7
+ compress
+ copytruncate
+ notifempty
+ create 640 root root
+ postrotate
+ test -e /run/openrc/softlevel && /etc/init.d/munin-node restart 1>/dev/null || true
+ test -e /run/systemd/system && systemctl restart munin-node 1>/dev/null || true
+ endscript
+}
+
+/var/log/munin/munin-update.log /var/log/munin/munin-graph.log /var/log/munin/munin-html.log /var/log/munin/munin-limits.log {
+ daily
+ missingok
+ rotate 7
+ compress
+ notifempty
+ nocreate
+}
+
+/var/log/munin/munin-cgi-graph.log /var/log/munin/munin-cgi-html.log {
+ daily
+ missingok
+ rotate 7
+ compress
+ notifempty
+ create 640 @CGIUSER@
+}
diff --git a/net-analyzer/munin/munin-2.0.14.ebuild b/net-analyzer/munin/munin-2.0.19-r1.ebuild
index e0fa013c9cfe..c4c984db6e77 100644
--- a/net-analyzer/munin/munin-2.0.14.ebuild
+++ b/net-analyzer/munin/munin-2.0.19-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-2.0.14.ebuild,v 1.2 2013/06/11 19:08:25 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-2.0.19-r1.ebuild,v 1.1 2014/01/12 11:10:54 lxnay Exp $
EAPI=5
PATCHSET=1
-inherit eutils user java-pkg-opt-2
+inherit eutils user java-pkg-opt-2 systemd
MY_P=${P/_/-}
@@ -51,6 +51,7 @@ DEPEND_COM="dev-lang/perl[berkdb]
dev-perl/List-MoreUtils
dev-perl/Log-Log4perl
dev-perl/Net-CIDR
+ dev-perl/Net-DNS
dev-perl/Net-Netmask
dev-perl/Net-SNMP
dev-perl/net-server[ipv6(-)?]
@@ -185,11 +186,21 @@ src_install() {
insinto /etc/munin/plugin-conf.d/
newins "${FILESDIR}"/${PN}-1.3.2-plugins.conf munin-node
- newinitd "${FILESDIR}"/munin-node_init.d_2.0.7 munin-node
+ newinitd "${FILESDIR}"/munin-node_init.d_2.0.19 munin-node
newconfd "${FILESDIR}"/munin-node_conf.d_1.4.6-r2 munin-node
newinitd "${FILESDIR}"/munin-asyncd.init.2 munin-asyncd
+ dodir /usr/lib/tmpfiles.d
+ cat - > "${D}"/usr/lib/tmpfiles.d/${CATEGORY}:${PN}:${SLOT}.conf <<EOF
+d /run/munin 0700 munin munin - -
+EOF
+
+ systemd_dounit "${FILESDIR}"/munin-async.service
+ systemd_dounit "${FILESDIR}"/munin-graph.{service,socket}
+ systemd_dounit "${FILESDIR}"/munin-html.{service,socket}
+ systemd_dounit "${FILESDIR}"/munin-node.service
+
cat - >> "${T}"/munin.env <<EOF
CONFIG_PROTECT=/var/spool/munin-async/.ssh
EOF
@@ -204,7 +215,7 @@ EOF
dodir /etc/logrotate.d/
sed -e "s:@CGIUSER@:$(usex apache apache munin):g" \
- "${FILESDIR}"/logrotate.d-munin.2 > "${D}"/etc/logrotate.d/munin
+ "${FILESDIR}"/logrotate.d-munin.3 > "${D}"/etc/logrotate.d/munin
dosym ipmi_ /usr/libexec/munin/plugins/ipmi_sensor_
@@ -230,11 +241,6 @@ EOF
# the non-minimal install...
rm "${D}"/usr/libexec/munin/plugins/munin_stats
else
- dodir /usr/lib/tmpfiles.d
- cat - > "${D}"/usr/lib/tmpfiles.d/${CATEGORY}:${PN}:${SLOT}.conf <<EOF
-d /run/munin 0700 munin munin - -
-EOF
-
# remove font files so that we don't have to keep them around
rm "${D}"/usr/libexec/${PN}/*.ttf || die
@@ -349,7 +355,7 @@ pkg_config() {
pkg_postinst() {
elog "Please follow the munin documentation to set up the plugins you"
- elog "need, afterwards start munin-node via /etc/init.d/munin-node."
+ elog "need, afterwards start munin-node."
elog ""
elog "To make use of munin-async, make sure to set up the corresponding"
elog "SSH key in /var/lib/munin-async/.ssh/authorized_keys"
diff --git a/net-analyzer/munin/munin-2.1.9999.ebuild b/net-analyzer/munin/munin-2.1.9999.ebuild
index 82fee3edb868..c7b29544ddb4 100644
--- a/net-analyzer/munin/munin-2.1.9999.ebuild
+++ b/net-analyzer/munin/munin-2.1.9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-2.1.9999.ebuild,v 1.1 2013/01/19 15:26:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-2.1.9999.ebuild,v 1.2 2014/01/12 11:10:54 lxnay Exp $
EAPI=5
@@ -194,7 +194,7 @@ EOF
dodir /etc/logrotate.d/
sed -e "s:@CGIUSER@:$(usex apache apache munin):g" \
- "${FILESDIR}"/logrotate.d-munin.2 > "${D}"/etc/logrotate.d/munin
+ "${FILESDIR}"/logrotate.d-munin.3 > "${D}"/etc/logrotate.d/munin
dosym ipmi_ /usr/libexec/munin/plugins/ipmi_sensor_