summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-12-17 12:20:24 +0000
committerJeroen Roovers <jer@gentoo.org>2012-12-17 12:20:24 +0000
commit41aa9be522a009e08c905f5f50cd6dfb0cc301e1 (patch)
tree4efc8941a1adeb45e9871449afd6dcd460eee41f /net-analyzer
parentRemove direct uses of /dev/urandom — if the user wants to, they can do it e... (diff)
downloadgentoo-2-41aa9be522a009e08c905f5f50cd6dfb0cc301e1.tar.gz
gentoo-2-41aa9be522a009e08c905f5f50cd6dfb0cc301e1.tar.bz2
gentoo-2-41aa9be522a009e08c905f5f50cd6dfb0cc301e1.zip
Version bump by Mario Kicherer (bug #447572).
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/fail2ban/ChangeLog7
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.8.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/net-analyzer/fail2ban/ChangeLog b/net-analyzer/fail2ban/ChangeLog
index fccb29c7140a..3b2d02754580 100644
--- a/net-analyzer/fail2ban/ChangeLog
+++ b/net-analyzer/fail2ban/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/fail2ban
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.86 2012/09/07 12:10:52 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.87 2012/12/17 12:20:24 jer Exp $
+
+*fail2ban-0.8.8 (17 Dec 2012)
+
+ 17 Dec 2012; Jeroen Roovers <jer@gentoo.org> +fail2ban-0.8.8.ebuild:
+ Version bump by Mario Kicherer (bug #447572).
*fail2ban-0.8.7.1 (07 Sep 2012)
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.8.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.8.ebuild
new file mode 100644
index 000000000000..483d13dc9bc2
--- /dev/null
+++ b/net-analyzer/fail2ban/fail2ban-0.8.8.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.8.ebuild,v 1.1 2012/12/17 12:20:24 jer Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit distutils eutils vcs-snapshot
+
+DESCRIPTION="Bans IP that make too many password failures"
+HOMEPAGE="http://www.fail2ban.org/"
+SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="selinux"
+
+DEPEND="selinux? ( sec-policy/selinux-fail2ban )"
+RDEPEND="net-misc/whois
+ virtual/mta
+ virtual/logger
+ net-firewall/iptables
+ selinux? ( sec-policy/selinux-fail2ban )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install
+
+ newconfd files/gentoo-confd fail2ban
+ newinitd files/gentoo-initd fail2ban
+ dodoc ChangeLog README TODO
+ doman man/*.1
+
+ # Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
+ # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}-logrotate ${PN}
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
+ elog
+ elog "Configuration files are now in /etc/fail2ban/"
+ elog "You probably have to manually update your configuration"
+ elog "files before restarting Fail2ban!"
+ elog
+ elog "Fail2ban is not installed under /usr/lib anymore. The"
+ elog "new location is under /usr/share."
+ elog
+ elog "You are upgrading from version 0.6.x, please see:"
+ elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ fi
+}