summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-15 01:22:16 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-15 01:22:16 +0000
commit04a17a208e67e43c5a284c5584db61df7d33c07c (patch)
tree4afb84913e0ce8db6e6119cb22c4a23b7e7b4604 /net-analyzer
parentVersion bump with Python 2 restriction (diff)
downloadgentoo-2-04a17a208e67e43c5a284c5584db61df7d33c07c.tar.gz
gentoo-2-04a17a208e67e43c5a284c5584db61df7d33c07c.tar.bz2
gentoo-2-04a17a208e67e43c5a284c5584db61df7d33c07c.zip
Respect LDFLAGS (bug #337309). Fix some missing includes/declarations.
(Portage version: 2.2_rc81/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nbtscan/ChangeLog8
-rw-r--r--net-analyzer/nbtscan/files/nbtscan-1.5.1-includes-declarations.patch42
-rw-r--r--net-analyzer/nbtscan/nbtscan-1.5.1-r2.ebuild36
3 files changed, 85 insertions, 1 deletions
diff --git a/net-analyzer/nbtscan/ChangeLog b/net-analyzer/nbtscan/ChangeLog
index f40453d49923..495e9c7aa9b4 100644
--- a/net-analyzer/nbtscan/ChangeLog
+++ b/net-analyzer/nbtscan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nbtscan
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbtscan/ChangeLog,v 1.29 2010/05/26 16:22:25 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbtscan/ChangeLog,v 1.30 2010/09/15 01:22:16 jer Exp $
+
+*nbtscan-1.5.1-r2 (15 Sep 2010)
+
+ 15 Sep 2010; Jeroen Roovers <jer@gentoo.org> +nbtscan-1.5.1-r2.ebuild,
+ +files/nbtscan-1.5.1-includes-declarations.patch:
+ Respect LDFLAGS (bug #337309). Fix some missing includes/declarations.
26 May 2010; Jonathan Callen <abcd@gentoo.org> nbtscan-1.5.1-r1.ebuild:
Fix QA violations (quoting, use econf), add prefix keywords
diff --git a/net-analyzer/nbtscan/files/nbtscan-1.5.1-includes-declarations.patch b/net-analyzer/nbtscan/files/nbtscan-1.5.1-includes-declarations.patch
new file mode 100644
index 000000000000..a585d4495fb5
--- /dev/null
+++ b/net-analyzer/nbtscan/files/nbtscan-1.5.1-includes-declarations.patch
@@ -0,0 +1,42 @@
+--- a/list.h
++++ b/list.h
+@@ -19,3 +19,5 @@
+ int compare(struct list_item* item1, struct list_item* item2);
+
+ int insert(struct list* lst, unsigned long content);
++
++int in_list(struct list* lst, unsigned long content);
+--- a/nbtscan.c
++++ b/nbtscan.c
+@@ -5,6 +5,8 @@
+ #include <stdlib.h>
+ #include <sys/time.h>
+ #include <string.h>
++#include <ctype.h>
++#include <unistd.h>
+ #if HAVE_STDINT_H
+ #include <stdint.h>
+ #endif
+--- a/statusq.h
++++ b/statusq.h
+@@ -103,4 +103,10 @@
+ char* service_name;
+ } nb_service_t ;
+
++char* getnbservicename(my_uint8_t service, int unique, char* name);
++
++struct nb_host_info* parse_response(char* buff, int buffsize);
++
++int send_query(int sock, struct in_addr dest_addr, my_uint32_t rtt_base);
++
+ #endif /* STATUSQ_H */
+--- a/statusq.c
++++ b/statusq.c
+@@ -29,6 +29,7 @@
+ #include <sys/time.h>
+ #include "statusq.h"
+ #include <string.h>
++#include <ctype.h>
+ #include <stdio.h>
+ #include <stddef.h>
+ #include "errors.h"
diff --git a/net-analyzer/nbtscan/nbtscan-1.5.1-r2.ebuild b/net-analyzer/nbtscan/nbtscan-1.5.1-r2.ebuild
new file mode 100644
index 000000000000..9a315bd5a1c0
--- /dev/null
+++ b/net-analyzer/nbtscan/nbtscan-1.5.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbtscan/nbtscan-1.5.1-r2.ebuild,v 1.1 2010/09/15 01:22:16 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="NBTscan is a program for scanning IP networks for NetBIOS name information"
+HOMEPAGE="http://www.inetcat.net/software/nbtscan.html"
+SRC_URI="http://www.sourcefiles.org/Networking/Tools/Miscellanenous/${P}.tar.gz"
+SRC_URI="http://www.inetcat.net/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${P}a
+
+src_prepare() {
+ sed -i Makefile.in \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ -e 's| \($(BINDIR)\)| $(DESTDIR)/\1|g' \
+ || die "sed Makefile.in"
+ epatch \
+ "${FILESDIR}"/${P}-script-whitespace.patch \
+ "${FILESDIR}"/${P}-includes-declarations.patch
+}
+
+src_install () {
+ dobin ${PN} || die "dobin ${PN}"
+ dodoc ChangeLog README
+}