summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-06-24 05:33:29 +0000
committerJeroen Roovers <jer@gentoo.org>2010-06-24 05:33:29 +0000
commit03fc097563a8da8f0dfc06cd119b372fedfb1ac5 (patch)
treeefcc3bf4bfd7ad092c0076cfeada6b5300ed265c /net-analyzer
parentStable on amd64 wrt bug #322791 (diff)
downloadgentoo-2-03fc097563a8da8f0dfc06cd119b372fedfb1ac5.tar.gz
gentoo-2-03fc097563a8da8f0dfc06cd119b372fedfb1ac5.tar.bz2
gentoo-2-03fc097563a8da8f0dfc06cd119b372fedfb1ac5.zip
SRC_URI fix and version bump thanks to Nico Baggus (bug #324805).
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpslice/ChangeLog10
-rw-r--r--net-analyzer/tcpslice/tcpslice-1.2_alpha2.ebuild9
-rw-r--r--net-analyzer/tcpslice/tcpslice-1.2a_p3.ebuild38
3 files changed, 50 insertions, 7 deletions
diff --git a/net-analyzer/tcpslice/ChangeLog b/net-analyzer/tcpslice/ChangeLog
index cbe9547f6cd2..4cc894b2bae0 100644
--- a/net-analyzer/tcpslice/ChangeLog
+++ b/net-analyzer/tcpslice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/tcpslice
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/ChangeLog,v 1.17 2009/09/23 18:24:24 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/ChangeLog,v 1.18 2010/06/24 05:33:29 jer Exp $
+
+*tcpslice-1.2a_p3 (24 Jun 2010)
+
+ 24 Jun 2010; Jeroen Roovers <jer@gentoo.org> tcpslice-1.2_alpha2.ebuild,
+ +tcpslice-1.2a_p3.ebuild:
+ SRC_URI fix and version bump thanks to Nico Baggus (bug #324805).
23 Sep 2009; Patrick Lauer <patrick@gentoo.org>
tcpslice-1.2_alpha2.ebuild:
diff --git a/net-analyzer/tcpslice/tcpslice-1.2_alpha2.ebuild b/net-analyzer/tcpslice/tcpslice-1.2_alpha2.ebuild
index 585f389a7e0a..457b9bff4124 100644
--- a/net-analyzer/tcpslice/tcpslice-1.2_alpha2.ebuild
+++ b/net-analyzer/tcpslice/tcpslice-1.2_alpha2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/tcpslice-1.2_alpha2.ebuild,v 1.6 2009/09/23 18:24:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/tcpslice-1.2_alpha2.ebuild,v 1.7 2010/06/24 05:33:29 jer Exp $
inherit eutils versionator
@@ -8,9 +8,8 @@ MY_P="${PN}_$(get_version_component_range 1-2)a2"
DESCRIPTION="Tcpslice is a program for extracting portions of packet-trace files generated using tcpdump's -w flag. It can also be used to glue together pcap dump files."
HOMEPAGE="http://www.tcpdump.org/"
-SRC_URI="mirror://debian/pool/main/t/tcpslice/${MY_P}.orig.tar.gz
- mirror://debian/pool/main/t/tcpslice/${MY_P}-4.diff.gz"
-RESTRICT="mirror"
+SRC_URI="mirror://gentoo/${MY_P}.orig.tar.gz
+ mirror://gentoo/${MY_P}-4.diff.gz"
LICENSE="BSD"
SLOT="0"
diff --git a/net-analyzer/tcpslice/tcpslice-1.2a_p3.ebuild b/net-analyzer/tcpslice/tcpslice-1.2a_p3.ebuild
new file mode 100644
index 000000000000..6c3db44caaf8
--- /dev/null
+++ b/net-analyzer/tcpslice/tcpslice-1.2a_p3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/tcpslice-1.2a_p3.ebuild,v 1.1 2010/06/24 05:33:29 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_P="${PN}_${PV/_p/}"
+
+DESCRIPTION="a program for extracting portions of packet-trace files generated using tcpdump's -w flag, and to glue together pcap dump files"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="mirror://debian/pool/main/t/tcpslice/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/t/tcpslice/${MY_P}-4.debian.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="net-libs/libpcap"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${MY_P/_/-}"
+
+src_prepare() {
+ epatch "${WORKDIR}/debian/patches/"
+ sed -i -e 's:net/bpf.h:pcap-bpf.h:g' tcpslice.{h,c} || die
+}
+
+src_install() {
+ dosbin tcpslice || die "dosbin failed"
+ doman tcpslice.1
+ dodoc README
+}