summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-03-08 11:54:00 +0000
committerPeter Volkov <pva@gentoo.org>2009-03-08 11:54:00 +0000
commit12fa14a944725ee8c112b1c18dcfbb347c908b13 (patch)
tree8e831335f0244600e1e9acb1687faa60b773c80f /net-analyzer/wireshark
parentDropped obsolete warning: After upgrading to freetype-2.3.5, it is necessary ... (diff)
downloadgentoo-2-12fa14a944725ee8c112b1c18dcfbb347c908b13.tar.gz
gentoo-2-12fa14a944725ee8c112b1c18dcfbb347c908b13.tar.bz2
gentoo-2-12fa14a944725ee8c112b1c18dcfbb347c908b13.zip
Fixed build failure in function 'dissect_sflow_sample_rawheaderdata'
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/wireshark')
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.1.2-misc-warnings.patch24
-rw-r--r--net-analyzer/wireshark/wireshark-1.1.2.ebuild3
3 files changed, 31 insertions, 2 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 7fb30eb94adf..df086c6d98c2 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.153 2009/03/05 17:57:30 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.154 2009/03/08 11:54:00 pva Exp $
+
+ 08 Mar 2009; Peter Volkov <pva@gentoo.org>
+ +files/wireshark-1.1.2-misc-warnings.patch, wireshark-1.1.2.ebuild:
+ Fixed build failure in function 'dissect_sflow_sample_rawheaderdata'
*wireshark-1.0.6-r1 (05 Mar 2009)
diff --git a/net-analyzer/wireshark/files/wireshark-1.1.2-misc-warnings.patch b/net-analyzer/wireshark/files/wireshark-1.1.2-misc-warnings.patch
new file mode 100644
index 000000000000..2da9a5224ea4
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.1.2-misc-warnings.patch
@@ -0,0 +1,24 @@
+https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=3314
+
+=== modified file 'epan/dissectors/packet-sflow.c'
+--- epan/dissectors/packet-sflow.c 2009-03-08 10:18:22 +0000
++++ epan/dissectors/packet-sflow.c 2009-03-08 10:22:32 +0000
+@@ -563,13 +563,13 @@
+ {
+ guint32 header_proto, frame_length;
+ volatile guint32 header_length;
+- tvbuff_t *next_tvb;
+- proto_tree *sflow_header_tree;
++ tvbuff_t *volatile next_tvb;
++ proto_tree *volatile sflow_header_tree;
+ proto_item *ti;
+ /* stuff for saving column state before calling other dissectors.
+ * Thanks to Guy Harris for the tip. */
+- gboolean save_writable;
+- gboolean save_in_error_pkt;
++ volatile gboolean save_writable;
++ volatile gboolean save_in_error_pkt;
+ volatile address save_dl_src;
+ volatile address save_dl_dst;
+ volatile address save_net_src;
+
diff --git a/net-analyzer/wireshark/wireshark-1.1.2.ebuild b/net-analyzer/wireshark/wireshark-1.1.2.ebuild
index 003b1f9f7f75..12a7a0632a82 100644
--- a/net-analyzer/wireshark/wireshark-1.1.2.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.1.2.ebuild,v 1.1 2009/01/19 09:40:18 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.1.2.ebuild,v 1.2 2009/03/08 11:54:00 pva Exp $
EAPI=1
inherit autotools libtool flag-o-matic eutils toolchain-funcs
@@ -71,6 +71,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${PN}-1.1.2--as-needed.patch"
+ epatch "${FILESDIR}/${P}-misc-warnings.patch"
eautoreconf
}