summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-19 00:12:14 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-19 00:12:14 +0000
commita5846482ff0147d4e0110209a887ba3cc85c0bfe (patch)
treeb67fdacfc7319517bfabb2fa4abe82c48c26248d /net-analyzer/tleds
parentRespect LDFLAGS (bug #337896). Do not hardcode CC, CFLAGS. (diff)
downloadgentoo-2-a5846482ff0147d4e0110209a887ba3cc85c0bfe.tar.gz
gentoo-2-a5846482ff0147d4e0110209a887ba3cc85c0bfe.tar.bz2
gentoo-2-a5846482ff0147d4e0110209a887ba3cc85c0bfe.zip
Respect LDFLAGS (bug #337907). Do not hard-wire CC and CFLAGS (or do any of that other funky stuff). Set RDEPEND. Annotate ebuild.
(Portage version: 2.2_rc83/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/tleds')
-rw-r--r--net-analyzer/tleds/ChangeLog10
-rw-r--r--net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild62
2 files changed, 70 insertions, 2 deletions
diff --git a/net-analyzer/tleds/ChangeLog b/net-analyzer/tleds/ChangeLog
index 9f1dad2d854a..d8a3c1a958c4 100644
--- a/net-analyzer/tleds/ChangeLog
+++ b/net-analyzer/tleds/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/tleds
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tleds/ChangeLog,v 1.19 2007/07/22 08:04:24 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tleds/ChangeLog,v 1.20 2010/09/19 00:12:14 jer Exp $
+
+*tleds-1.05_beta11-r2 (19 Sep 2010)
+
+ 19 Sep 2010; Jeroen Roovers <jer@gentoo.org> +tleds-1.05_beta11-r2.ebuild:
+ Respect LDFLAGS (bug #337907). Do not hard-wire CC and CFLAGS (or do any
+ of that other funky stuff). Set RDEPEND. Annotate ebuild.
22 Jul 2007; <pva@gentoo.org> metadata.xml, tleds-1.05_beta11-r1.ebuild:
Removed virtual/x11 dependency.
diff --git a/net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild b/net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild
new file mode 100644
index 000000000000..3fe5a326518c
--- /dev/null
+++ b/net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild,v 1.1 2010/09/19 00:12:14 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P/eta11/}"
+DESCRIPTION="Blinks keyboard LEDs indicating outgoing and incoming network packets on selected network interface"
+HOMEPAGE="http://www.hut.fi/~jlohikos/tleds_orig.html"
+SRC_URI="http://www.hut.fi/~jlohikos/tleds/public/${MY_P/11/10}.tgz
+ http://www.hut.fi/~jlohikos/tleds/public/${MY_P}.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="X"
+
+DEPEND="X? ( >=x11-libs/libX11-1.0.0 )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ # unpack only original sources, not patches
+ unpack tleds-1.05beta10.tgz
+}
+
+src_prepare() {
+ # code patches
+ epatch \
+ "${DISTDIR}"/${MY_P}.patch.bz2 \
+ "${FILESDIR}"/${P}-gentoo.patch
+
+ # respect CC/CFLAGS/LDFLAGS, new X11 prefix
+ local opts="$(echo '$(GCCOPTS)')"
+ sed -i Makefile \
+ -e 's:-O3 -Wall:$(CFLAGS) $(LDFLAGS) -Wall:' \
+ -e 's:gcc \($(GCCOPTS)\):$(CC) \1:' \
+ -e 's:gcc \(-DNO_X_SUPPORT\):$(CC) \1:' \
+ -e 's:/usr/X11R6:/usr:g' \
+ || die "sed failed in Makefile"
+}
+
+src_compile() {
+ if use X ; then
+ emake CC=$(tc-getCC) all || die "make failed"
+ else
+ emake CC=$(tc-getCC) tleds || die "make tleds failed"
+ fi
+}
+
+src_install() {
+ dosbin tleds
+ use X && dosbin xtleds
+
+ doman tleds.1
+ dodoc README Changes
+
+ newinitd "${FILESDIR}"/tleds.init.d tleds
+ newconfd "${FILESDIR}"/tleds.conf.d tleds
+}