summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-11-28 04:57:43 +0000
committerTim Harder <radhermit@gentoo.org>2013-11-28 04:57:43 +0000
commiteba194c17b4db8961b4160f0911de9e6c3593c82 (patch)
tree8adacbc93c265856f5b13f2582731abbbf2e6f18 /net-analyzer/tcpdump/tcpdump-4.5.1.ebuild
parentVersion bump, add dbus use flag. (diff)
downloadgentoo-2-eba194c17b4db8961b4160f0911de9e6c3593c82.tar.gz
gentoo-2-eba194c17b4db8961b4160f0911de9e6c3593c82.tar.bz2
gentoo-2-eba194c17b4db8961b4160f0911de9e6c3593c82.zip
Version bump, fix test logic.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-analyzer/tcpdump/tcpdump-4.5.1.ebuild')
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.5.1.ebuild111
1 files changed, 111 insertions, 0 deletions
diff --git a/net-analyzer/tcpdump/tcpdump-4.5.1.ebuild b/net-analyzer/tcpdump/tcpdump-4.5.1.ebuild
new file mode 100644
index 000000000000..6377c565589e
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-4.5.1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-4.5.1.ebuild,v 1.1 2013/11/28 04:57:43 radhermit Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTO_DEPEND="no" # Only cross-compiling
+inherit autotools eutils flag-o-matic toolchain-funcs user
+
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+drop-root smi ssl ipv6 -samba suid test"
+
+RDEPEND="
+ drop-root? ( sys-libs/libcap-ng )
+ net-libs/libpcap
+ smi? ( net-libs/libsmi )
+ ssl? ( >=dev-libs/openssl-0.9.6m )
+"
+DEPEND="
+ ${RDEPEND}
+ drop-root? ( virtual/pkgconfig )
+ test? (
+ || ( app-arch/sharutils sys-freebsd/freebsd-ubin )
+ dev-lang/perl
+ )
+"
+
+pkg_setup() {
+ if use samba ; then
+ ewarn
+ ewarn "CAUTION !!! CAUTION !!! CAUTION"
+ ewarn
+ ewarn "You're about to compile tcpdump with samba printing support"
+ ewarn "Upstream tags it with:"
+ ewarn "WARNING: The SMB printer may have exploitable buffer overflows!!!"
+ ewarn "So think twice whether this is fine with you"
+ ewarn
+ ewarn "CAUTION !!! CAUTION !!! CAUTION"
+ ewarn
+ fi
+ if use drop-root || use suid; then
+ enewgroup tcpdump
+ enewuser tcpdump -1 -1 -1 tcpdump
+ fi
+}
+
+src_prepare() {
+ sed -i aclocal.m4 -e 's|\"-O2\"|\"\"|g' || die
+ eautoconf
+}
+src_configure() {
+ # tcpdump needs some optimization. see bug #108391
+ # but do not replace -Os
+ filter-flags -O[0-9]
+ has -O? ${CFLAGS} || append-cflags -O2
+
+ filter-flags -finline-functions
+
+ if use drop-root; then
+ append-cppflags -DHAVE_CAP_NG_H
+ export LIBS=$( $(tc-getPKG_CONFIG) --libs libcap-ng )
+ fi
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable samba smb) \
+ $(use_with drop-root chroot '') \
+ $(use_with smi) \
+ $(use_with ssl crypto "${EPREFIX}/usr") \
+ --with-user=tcpdump
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]] || ! use drop-root; then
+ sed -i '/^\(espudp1\|eapon1\)/d;' -i tests/TESTLIST
+ emake check
+ else
+ ewarn "If you want to run the test suite, make sure you either"
+ ewarn "set FEATURES=userpriv or set USE=-drop-root"
+ fi
+}
+
+src_install() {
+ dosbin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc CHANGES CREDITS README.md
+
+ if use suid; then
+ fowners root:tcpdump /usr/sbin/tcpdump
+ fperms 4110 /usr/sbin/tcpdump
+ fi
+}
+
+pkg_preinst() {
+ if use drop-root || use suid; then
+ enewgroup tcpdump
+ enewuser tcpdump -1 -1 -1 tcpdump
+ fi
+}
+
+pkg_postinst() {
+ use suid && elog "To let normal users run tcpdump add them into tcpdump group."
+}