summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-09-10 09:09:03 +0000
committerPeter Volkov <pva@gentoo.org>2006-09-10 09:09:03 +0000
commit6180cd25bf0e120d4e0458c4c86f01168afad872 (patch)
tree6b9158a592096d618a0d5bc4575b30bf6360215d /net-analyzer/sussen
parents390 stable (diff)
downloadgentoo-2-6180cd25bf0e120d4e0458c4c86f01168afad872.tar.gz
gentoo-2-6180cd25bf0e120d4e0458c4c86f01168afad872.tar.bz2
gentoo-2-6180cd25bf0e120d4e0458c4c86f01168afad872.zip
Version bump. Thank upstream dev Loren Bandiera for report. Ebuild polishing (gnome2.eclass functions are used only with gnome in USE, changed location of www/asp/*). Removed broken sussen versions.
(Portage version: 2.1-r2)
Diffstat (limited to 'net-analyzer/sussen')
-rw-r--r--net-analyzer/sussen/ChangeLog10
-rw-r--r--net-analyzer/sussen/files/digest-sussen-0.293
-rw-r--r--net-analyzer/sussen/sussen-0.29.ebuild91
3 files changed, 103 insertions, 1 deletions
diff --git a/net-analyzer/sussen/ChangeLog b/net-analyzer/sussen/ChangeLog
index cc9a6c1d298b..af05d86f4913 100644
--- a/net-analyzer/sussen/ChangeLog
+++ b/net-analyzer/sussen/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/sussen
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.29 2006/09/07 13:45:22 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.30 2006/09/10 09:09:03 pva Exp $
+
+*sussen-0.29 (10 Sep 2006)
+
+ 10 Sep 2006; Peter Volkov <pva@gentoo.org> -sussen-0.25.ebuild,
+ -sussen-0.26.ebuild, -sussen-0.27.ebuild, +sussen-0.29.ebuild:
+ Version bump. Thank upstream dev Loren Bandiera for report. Ebuild polishing
+ (gnome2.eclass functions are used only with gnome in USE, changed location
+ of www/asp/*). Removed broken sussen versions.
07 Sep 2006; Peter Volkov <pva@gentoo.org> -sussen-0.5.3.ebuild,
-sussen-0.10.ebuild, -sussen-0.12.ebuild:
diff --git a/net-analyzer/sussen/files/digest-sussen-0.29 b/net-analyzer/sussen/files/digest-sussen-0.29
new file mode 100644
index 000000000000..85d55fac9c5c
--- /dev/null
+++ b/net-analyzer/sussen/files/digest-sussen-0.29
@@ -0,0 +1,3 @@
+MD5 b266d4c673847ca7485705aa4ddc24cb sussen-0.29.tar.gz 864138
+RMD160 4c5a800d60e10dba7604e67dae925176e33c8d5b sussen-0.29.tar.gz 864138
+SHA256 7fff13ed7d4883f4b8ad14950ea8bc7d631212b6a53210de18b785b767bff900 sussen-0.29.tar.gz 864138
diff --git a/net-analyzer/sussen/sussen-0.29.ebuild b/net-analyzer/sussen/sussen-0.29.ebuild
new file mode 100644
index 000000000000..5b4a5cb446b8
--- /dev/null
+++ b/net-analyzer/sussen/sussen-0.29.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/sussen-0.29.ebuild,v 1.1 2006/09/10 09:09:03 pva Exp $
+
+inherit eutils gnome2 mono
+
+DESCRIPTION="Sussen is a tool that checks for vulnerabilities and configuration issues on computer systems"
+HOMEPAGE="http://dev.mmgsecurity.com/projects/sussen/"
+SRC_URI="http://dev.mmgsecurity.com/downloads//${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+IUSE="doc dbus gnome"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="=dev-lang/mono-1.1*
+ gnome? ( >=dev-dotnet/gtk-sharp-2.4
+ >=dev-dotnet/gnome-sharp-2.4
+ >=dev-dotnet/gconf-sharp-2.4
+ >=dev-dotnet/glade-sharp-2.4
+ gnome-base/gnome-panel )
+ dbus? ( sys-apps/dbus )"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/monodoc-1.1.8 )
+ app-arch/rpm
+ >=dev-util/intltool-0.34.2"
+
+DOCS="AUTHORS ChangeLog README TODO"
+
+pkg_setup() {
+ if use dbus ; then
+ built_with_use -a sys-apps/dbus mono || die \
+ "${PN} requires dbus build with mono support. Please, reemerge dbus with USE=\"mono\""
+ fi
+ use gnome || { elog "You do not have gnome in your USE flags.";
+ elog "applet and editor will not be built." ; }
+}
+
+# src_unpack, pkg_postinst, pkg_postrm are exported in gnome2.eclass. But since
+# we have gnome2 support depends on USE let's call gnome2.eclass internal
+# functions only when USE="gnome".
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use gnome && gnome2_omf_fix
+}
+
+src_compile () {
+ # Put all asp pages in /usr/share/$PF dir instead of /usr/share/sussen
+ sed -i -e \
+ "s:wwwdir = \$(datadir)/doc/sussen/www/asp:wwwdir = \$(datadir)/doc/${PF}/www/asp:" \
+ www/asp/Makefile.in || die "sed failed."
+
+ econf ${myconf} \
+ $(use_enable dbus) \
+ $(use_enable gnome) || die "./configure failed."
+
+ emake || die "Compilation failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc ${DOCS}
+
+ if use gnome ; then
+ elog "sussen-applet is a GNOME applet. You can not run it directly from"
+ elog "the command line. Use GNOME panel to invoke it."
+ elog "You can also run it with the --tray-icon command line option."
+ echo
+ ewarn "sussen-editor is still work in progress. Just basic functionality is"
+ ewarn "working (New, Save, Execute)."
+ echo
+ ewarn "Beginning with sussen-0.24 default location for oval definitions changed."
+ ewarn "If you had previous versions installed, please, run the following"
+ ewarn "commands to clean outdated locations for each user that run sussen:"
+ ewarn
+ ewarn "gconftool-2 --unset /apps/sussen-applet/oval_xml_directory"
+ ewarn "gconftool-2 --unset /apps/sussen-applet/oval_download_directory"
+ echo
+ fi
+}
+
+pkg_postinst() {
+ use gnome && gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ use gnome && gnome2_pkg_postrm
+}