summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-07-22 21:45:07 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-07-22 21:45:07 +0000
commit13b340e5a27bc56be5f465b4d8fb8221bd4b2a79 (patch)
tree5f2ede38daf907cfbd6fde8b7a8552d7f57509b6 /net-analyzer/pnp4nagios
parentVersion bump. Use unistring for collation with media-export plugin. (diff)
downloadgentoo-2-13b340e5a27bc56be5f465b4d8fb8221bd4b2a79.tar.gz
gentoo-2-13b340e5a27bc56be5f465b4d8fb8221bd4b2a79.tar.bz2
gentoo-2-13b340e5a27bc56be5f465b4d8fb8221bd4b2a79.zip
Version bump, bug 424793 and some improvements part #1
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/pnp4nagios')
-rw-r--r--net-analyzer/pnp4nagios/ChangeLog8
-rw-r--r--net-analyzer/pnp4nagios/files/npcd.initd19
-rw-r--r--net-analyzer/pnp4nagios/pnp4nagios-0.6.18.ebuild81
3 files changed, 107 insertions, 1 deletions
diff --git a/net-analyzer/pnp4nagios/ChangeLog b/net-analyzer/pnp4nagios/ChangeLog
index 15be45ca1eae..615ca0922e6d 100644
--- a/net-analyzer/pnp4nagios/ChangeLog
+++ b/net-analyzer/pnp4nagios/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/pnp4nagios
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.42 2012/06/25 19:45:21 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.43 2012/07/22 21:45:07 idl0r Exp $
+
+*pnp4nagios-0.6.18 (22 Jul 2012)
+
+ 22 Jul 2012; Christian Ruppert <idl0r@gentoo.org> +pnp4nagios-0.6.18.ebuild,
+ +files/npcd.initd:
+ Version bump, bug 424793 and some improvements part #1
*pnp4nagios-0.6.14-r1 (25 Jun 2012)
diff --git a/net-analyzer/pnp4nagios/files/npcd.initd b/net-analyzer/pnp4nagios/files/npcd.initd
new file mode 100644
index 000000000000..abf7aeb7ea76
--- /dev/null
+++ b/net-analyzer/pnp4nagios/files/npcd.initd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/files/npcd.initd,v 1.1 2012/07/22 21:45:07 idl0r Exp $
+
+extra_started_commands="reload"
+
+command="/usr/bin/npcd"
+command_args="-f /etc/pnp/npcd.cfg -d"
+
+depend() {
+ need net
+}
+
+reload() {
+ ebegin "Reloading npcd"
+ kill -HUP `pgrep npcd`
+ eend $? "Failed to reload npcd"
+}
diff --git a/net-analyzer/pnp4nagios/pnp4nagios-0.6.18.ebuild b/net-analyzer/pnp4nagios/pnp4nagios-0.6.18.ebuild
new file mode 100644
index 000000000000..4e4b6e33d646
--- /dev/null
+++ b/net-analyzer/pnp4nagios/pnp4nagios-0.6.18.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/pnp4nagios-0.6.18.ebuild,v 1.1 2012/07/22 21:45:07 idl0r Exp $
+
+EAPI="4"
+
+inherit depend.apache eutils
+
+DESCRIPTION="A performance data analyzer for nagios"
+HOMEPAGE="http://www.pnp4nagios.org"
+
+SRC_URI="mirror://sourceforge/${PN}/PNP-0.6/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-lang/php[json,simplexml,zlib,xml,filter]
+ >=dev-lang/php-5.3
+ >=net-analyzer/rrdtool-1.2[perl]
+ || ( net-analyzer/nagios-core net-analyzer/icinga )"
+RDEPEND="${DEPEND}
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-HiRes
+ media-fonts/dejavu
+ apache2? ( www-servers/apache[apache2_modules_rewrite] )"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.6.14-makefile.patch
+}
+
+src_configure() {
+ local var_dir=
+ local user_group=
+
+ if has_version net-analyzer/nagios-core; then
+ var_dir=/var/nagios/
+ user_group=nagios
+ else
+ var_dir=/var/lib/icinga/
+ user_group=icinga
+ fi
+
+ econf \
+ --sysconfdir=/etc/pnp \
+ --datarootdir=/usr/share/pnp \
+ --mandir=/usr/share/man \
+ --with-perfdata-dir=${var_dir}/perfdata \
+ --with-nagios-user=${user_group} \
+ --with-nagios-group=${user_group} \
+ --with-perfdata-logfile=${var_dir}/perfdata.log \
+ --with-perfdata-spool-dir=/var/spool/pnp
+}
+
+src_compile() {
+ # The default target just shows a help
+ emake all
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-config || die "emake install failed"
+ newinitd "${FILESDIR}/npcd.initd" npcd
+ rm "${D}/usr/share/pnp/install.php"
+
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}"/98_pnp4nagios.conf
+ fi
+}
+
+pkg_postinst() {
+ elog "Please make sure to enable URL rewriting in Apache or any other"
+ elog "webserver you're using, to get pnp4nagios running!"
+}