summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-08-25 16:35:13 +0000
committerCédric Krier <cedk@gentoo.org>2007-08-25 16:35:13 +0000
commitfc77447da1f57d1be8551a6dbffea15c1d9cd246 (patch)
tree7df8a662b3ce78a8a5a746601ce02a3109d81f07 /net-analyzer/pmacct
parentAdd USE=mmx to help workaround #189467. (diff)
downloadgentoo-2-fc77447da1f57d1be8551a6dbffea15c1d9cd246.tar.gz
gentoo-2-fc77447da1f57d1be8551a6dbffea15c1d9cd246.tar.bz2
gentoo-2-fc77447da1f57d1be8551a6dbffea15c1d9cd246.zip
Version bump
(Portage version: 2.1.2.12)
Diffstat (limited to 'net-analyzer/pmacct')
-rw-r--r--net-analyzer/pmacct/ChangeLog7
-rw-r--r--net-analyzer/pmacct/files/digest-pmacct-0.11.43
-rw-r--r--net-analyzer/pmacct/pmacct-0.11.4.ebuild56
3 files changed, 65 insertions, 1 deletions
diff --git a/net-analyzer/pmacct/ChangeLog b/net-analyzer/pmacct/ChangeLog
index b8e47e68f726..d09e0a42967c 100644
--- a/net-analyzer/pmacct/ChangeLog
+++ b/net-analyzer/pmacct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/pmacct
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.49 2007/08/13 21:24:40 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.50 2007/08/25 16:35:13 cedk Exp $
+
+*pmacct-0.11.4 (25 Aug 2007)
+
+ 25 Aug 2007; Cédric Krier <cedk@gentoo.org> +pmacct-0.11.4.ebuild:
+ Version bump
13 Aug 2007; Tobias Scherbaum <dertobi123@gentoo.org>
pmacct-0.11.3.ebuild:
diff --git a/net-analyzer/pmacct/files/digest-pmacct-0.11.4 b/net-analyzer/pmacct/files/digest-pmacct-0.11.4
new file mode 100644
index 000000000000..2dda131ea4d2
--- /dev/null
+++ b/net-analyzer/pmacct/files/digest-pmacct-0.11.4
@@ -0,0 +1,3 @@
+MD5 df2aff55718800c8373baf3a046d8e2b pmacct-0.11.4.tar.gz 422189
+RMD160 ad8aa10f44ade158435ce81e89e57463b8142bb0 pmacct-0.11.4.tar.gz 422189
+SHA256 34c3870eb2acc63173b95c9a08128592b1ee850dd88e0cbdf2f9e0b9fa3f87c9 pmacct-0.11.4.tar.gz 422189
diff --git a/net-analyzer/pmacct/pmacct-0.11.4.ebuild b/net-analyzer/pmacct/pmacct-0.11.4.ebuild
new file mode 100644
index 000000000000..3bf722f754f9
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-0.11.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.11.4.ebuild,v 1.1 2007/08/25 16:35:13 cedk Exp $
+
+DESCRIPTION="A network tool to gather ip traffic informations"
+HOMEPAGE="http://www.pmacct.net/"
+SRC_URI="http://www.pmacct.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="64bit debug ipv6 mmap mysql postgres sqlite3"
+
+RDEPEND="net-libs/libpcap
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+ sqlite3? ( =dev-db/sqlite-3* )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
+}
+
+src_compile() {
+ econf \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable mmap) \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_enable 64bit) \
+ $(use_enable sqlite3) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
+ docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
+
+ for dirname in examples sql; do
+ docinto ${dirname}
+ dodoc ${dirname}/* || die "dodoc ${dirname} failed"
+ done
+
+ newinitd "${FILESDIR}"/pmacctd-init.d pmacctd || die "newinitd failed"
+ newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd || die "newconfd failed"
+
+ insinto /etc
+ newins "${S}"/examples/pmacctd-imt.conf.example pmacctd.conf.example || \
+ die "newins failed"
+}