summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-05-24 14:52:32 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-05-24 14:52:32 +0000
commit77b7e3b2d1ef7d54e2fe9d027e24b8d1f810823e (patch)
tree5b1ce595bf5cae98b7f8cac34b2ba13f5c59eeb6 /net-analyzer/pmacct
parentMigration (diff)
downloadgentoo-2-77b7e3b2d1ef7d54e2fe9d027e24b8d1f810823e.tar.gz
gentoo-2-77b7e3b2d1ef7d54e2fe9d027e24b8d1f810823e.tar.bz2
gentoo-2-77b7e3b2d1ef7d54e2fe9d027e24b8d1f810823e.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-analyzer/pmacct')
-rw-r--r--net-analyzer/pmacct/Manifest2
-rw-r--r--net-analyzer/pmacct/files/digest-pmacct-0.8.61
-rw-r--r--net-analyzer/pmacct/pmacct-0.8.6.ebuild54
3 files changed, 57 insertions, 0 deletions
diff --git a/net-analyzer/pmacct/Manifest b/net-analyzer/pmacct/Manifest
index 77964d006669..f1dd54f969a3 100644
--- a/net-analyzer/pmacct/Manifest
+++ b/net-analyzer/pmacct/Manifest
@@ -1,4 +1,5 @@
MD5 497e26efadd51aa9e5b90e0bddc13866 pmacct-0.8.4.ebuild 1505
+MD5 6e2abf845b1634a798333ed7d676b715 pmacct-0.8.6.ebuild 1506
MD5 1a8be45d950c81b34a3b76149de79975 pmacct-0.8.3.ebuild 1493
MD5 c6a998a4dae0a4900dc612aed194fb54 ChangeLog 2915
MD5 6e2abf845b1634a798333ed7d676b715 pmacct-0.8.5.ebuild 1506
@@ -8,3 +9,4 @@ MD5 2afa8e97312b03f3e119c0befed9e7d3 files/pmacctd-init.d 869
MD5 ab598b974f8a63136ead320763bf7a5f files/digest-pmacct-0.8.3 64
MD5 5aada4dc083afac65f161d24379db6fc files/digest-pmacct-0.8.4 64
MD5 f6c685e6ca8ed840ccd737080816aeec files/digest-pmacct-0.8.5 64
+MD5 dc1c27641a784b8d4e4397e5415aa7c8 files/digest-pmacct-0.8.6 64
diff --git a/net-analyzer/pmacct/files/digest-pmacct-0.8.6 b/net-analyzer/pmacct/files/digest-pmacct-0.8.6
new file mode 100644
index 000000000000..93048815d58c
--- /dev/null
+++ b/net-analyzer/pmacct/files/digest-pmacct-0.8.6
@@ -0,0 +1 @@
+MD5 b725f7b4af335d2f668cb61621a5c2d9 pmacct-0.8.6.tar.gz 244189
diff --git a/net-analyzer/pmacct/pmacct-0.8.6.ebuild b/net-analyzer/pmacct/pmacct-0.8.6.ebuild
new file mode 100644
index 000000000000..c971a429c2c3
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-0.8.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.8.6.ebuild,v 1.1 2005/05/24 14:52:32 vanquirius Exp $
+
+MY_P="${P%_*}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A network tool to gather ip traffic informations"
+HOMEPAGE="http://www.ba.cnr.it/~paolo/pmacct/"
+SRC_URI="http://www.ba.cnr.it/~paolo/pmacct/${P/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="ipv6 mmap mysql postgres"
+
+RDEPEND="virtual/libpcap
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
+}
+
+src_compile() {
+ econf \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable mmap) \
+ $(use_enable ipv6) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
+ docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
+
+ for dirname in examples sql; do
+ docinto ${dirname}
+ dodoc ${dirname}/* || die "dodoc ${dirname} failed"
+ done
+
+ newinitd ${FILESDIR}/pmacctd-init.d pmacctd || die "newinitd failed"
+ newconfd ${FILESDIR}/pmacctd-conf.d pmacctd || die "newconfd failed"
+
+ insinto /etc
+ newins ${S}/examples/pmacctd-imt.conf.example pmacctd.conf.example || \
+ die "newins failed"
+}