summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-01-06 19:14:42 +0000
committerCédric Krier <cedk@gentoo.org>2007-01-06 19:14:42 +0000
commit76a679cf495eea378621caff98ebb756da063339 (patch)
treef7a4e3f8e69d74bee7b09a499e69bee33d6b9b60 /net-analyzer/p0f
parentAdded IUSE=debug, which was dropped when \'inherit debug\' was removed from x... (diff)
downloadgentoo-2-76a679cf495eea378621caff98ebb756da063339.tar.gz
gentoo-2-76a679cf495eea378621caff98ebb756da063339.tar.bz2
gentoo-2-76a679cf495eea378621caff98ebb756da063339.zip
Improve init script for bug #143415 and cross-compile
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-analyzer/p0f')
-rw-r--r--net-analyzer/p0f/ChangeLog8
-rw-r--r--net-analyzer/p0f/files/digest-p0f-2.0.52
-rw-r--r--net-analyzer/p0f/files/p0f.confd2
-rwxr-xr-xnet-analyzer/p0f/files/p0f.initd210
-rw-r--r--net-analyzer/p0f/p0f-2.0.8.ebuild10
5 files changed, 21 insertions, 11 deletions
diff --git a/net-analyzer/p0f/ChangeLog b/net-analyzer/p0f/ChangeLog
index 3a44321a7f7e..5f0223189fa2 100644
--- a/net-analyzer/p0f/ChangeLog
+++ b/net-analyzer/p0f/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/p0f
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/ChangeLog,v 1.28 2006/12/10 03:51:35 vanquirius Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/ChangeLog,v 1.29 2007/01/06 19:14:42 cedk Exp $
+
+ 06 Jan 2007; Cedric Krier <cedk@gentoo.org> files/p0f.confd,
+ files/p0f.initd2, p0f-2.0.8.ebuild:
+ Improve init script for bug #143415 and cross-compile
*p0f-2.0.8 (10 Dec 2006)
diff --git a/net-analyzer/p0f/files/digest-p0f-2.0.5 b/net-analyzer/p0f/files/digest-p0f-2.0.5
index 07d6ee7ea1cd..6c3b8b5796fa 100644
--- a/net-analyzer/p0f/files/digest-p0f-2.0.5
+++ b/net-analyzer/p0f/files/digest-p0f-2.0.5
@@ -1 +1,3 @@
MD5 78235749e8ada6ad2b16b40fe15081f6 p0f-2.0.5.tgz 130002
+RMD160 34ee678aa721ee38959419808ed798aa23228a16 p0f-2.0.5.tgz 130002
+SHA256 563c62f63acfbef79e79659c3f483813816c7d032ef73e96e462a3b4f9a2fc7f p0f-2.0.5.tgz 130002
diff --git a/net-analyzer/p0f/files/p0f.confd b/net-analyzer/p0f/files/p0f.confd
index ae3a068cebad..01c02896ec01 100644
--- a/net-analyzer/p0f/files/p0f.confd
+++ b/net-analyzer/p0f/files/p0f.confd
@@ -1,3 +1,3 @@
P0FLOGFILE=/var/log/p0f-audit.log
P0FDEVICE=eth0
-P0FOPTIONS="-tdlo"
+P0FOPTIONS="-tl"
diff --git a/net-analyzer/p0f/files/p0f.initd2 b/net-analyzer/p0f/files/p0f.initd2
index f32f11ca82c0..75e1a5089f1b 100755
--- a/net-analyzer/p0f/files/p0f.initd2
+++ b/net-analyzer/p0f/files/p0f.initd2
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/files/p0f.initd2,v 1.1 2005/06/19 01:54:40 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/files/p0f.initd2,v 1.2 2007/01/06 19:14:42 cedk Exp $
start() {
ebegin "Starting p0f"
@@ -18,15 +18,19 @@ start() {
for OneIP in `/sbin/ifconfig 2>/dev/null | grep 'inet addr' | sed -e 's/.*addr://' -e 's/ .*//'` ; do
BpfFilter="$BpfFilter and not src host $OneIP"
done
-
+
+
# Create a lock file.
mkdir -p /var/lock/subsys
touch /var/lock/subsys/p0f
# Start up p0f and filter out all packets originating from any of this machines IP's.
+ if [ -z "${P0FLOGFILE}" ]; then
+ P0FLOGFILE="/var/log/p0f"
+ fi
einfo "Logfile: ${P0FLOGFILE}"
start-stop-daemon --start --quiet --exec /usr/sbin/p0f -- -i "${P0FDEVICE}" \
- "${P0FOPTIONS}" "${P0FLOGFILE}" "${BpfFilter}" >> "/var/log/p0f" 2>&1 &
+ "${P0FOPTIONS}" -o "${P0FLOGFILE}" -d "${BpfFilter}" 2>/dev/null
eend ${?}
}
diff --git a/net-analyzer/p0f/p0f-2.0.8.ebuild b/net-analyzer/p0f/p0f-2.0.8.ebuild
index 9be6be0e2479..16c5608250a3 100644
--- a/net-analyzer/p0f/p0f-2.0.8.ebuild
+++ b/net-analyzer/p0f/p0f-2.0.8.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.8.ebuild,v 1.1 2006/12/10 03:51:35 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.8.ebuild,v 1.2 2007/01/06 19:14:42 cedk Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="p0f performs passive OS detection based on SYN packets."
HOMEPAGE="http://lcamtuf.coredump.cx/p0f.shtml"
@@ -27,8 +27,8 @@ src_unpack() {
src_compile() {
local static
use static && static="static"
- emake ${static} || die "emake ${static} failed"
- emake ${static} p0fq || die "emake ${static} p0fq failed"
+ emake CC="$(tc-getCC)" ${static} || die "emake ${static} failed"
+ emake CC="$(tc-getCC)" ${static} p0fq || die "emake ${static} p0fq failed"
}
src_install () {