summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-07-16 14:15:45 +0000
committerJeroen Roovers <jer@gentoo.org>2014-07-16 14:15:45 +0000
commitb91bfdf124e4b3e8994b496897e2dcf88338faf4 (patch)
tree9b8cc218f0418bae305aeb65468038d119db1e63 /net-analyzer/ntop
parentBeutify wording (diff)
downloadgentoo-2-b91bfdf124e4b3e8994b496897e2dcf88338faf4.tar.gz
gentoo-2-b91bfdf124e4b3e8994b496897e2dcf88338faf4.tar.bz2
gentoo-2-b91bfdf124e4b3e8994b496897e2dcf88338faf4.zip
Fix missing includes for standard functions. Stop running autotools in src_install(). Use python-config --includes, not --cflags. Do not "clean up" INCS (INCLUDES).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/ntop')
-rw-r--r--net-analyzer/ntop/ChangeLog8
-rw-r--r--net-analyzer/ntop/files/ntop-5.0.1-INCS.patch27
-rw-r--r--net-analyzer/ntop/files/ntop-5.0.1-includes.patch20
-rw-r--r--net-analyzer/ntop/ntop-5.0.1-r1.ebuild10
4 files changed, 63 insertions, 2 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index 3a7bd8ffd7f7..28b8a18d84c3 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/ntop
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.119 2014/07/15 18:37:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.120 2014/07/16 14:15:44 jer Exp $
+
+ 16 Jul 2014; Jeroen Roovers <jer@gentoo.org> ntop-5.0.1-r1.ebuild,
+ +files/ntop-5.0.1-INCS.patch, +files/ntop-5.0.1-includes.patch:
+ Fix missing includes for standard functions. Stop running autotools in
+ src_install(). Use python-config --includes, not --cflags. Do not "clean up"
+ INCS (INCLUDES).
15 Jul 2014; Jeroen Roovers <jer@gentoo.org> files/ntop-4.0.3-gentoo.patch,
files/ntop-4.1.0-gentoo.patch, files/ntop-5.0.1-gentoo.patch:
diff --git a/net-analyzer/ntop/files/ntop-5.0.1-INCS.patch b/net-analyzer/ntop/files/ntop-5.0.1-INCS.patch
new file mode 100644
index 000000000000..de49a41d7175
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-5.0.1-INCS.patch
@@ -0,0 +1,27 @@
+--- a/configure
++++ b/configure
+@@ -18983,7 +18983,7 @@
+ else
+ LIBS="${LIBS} ${PYTHON_LIBS}"
+
+- PYTHON_INCS=`$PYTHON_CONFIG --cflags | sed -e "s/-arch i386//" | sed -e "s/-arch ppc//" | sed -e "s/-arch x86_64//"`
++ PYTHON_INCS=`$PYTHON_CONFIG --includes | sed -e "s/-arch i386//" | sed -e "s/-arch ppc//" | sed -e "s/-arch x86_64//"`
+
+ INCS="${INCS} ${PYTHON_INCS}"
+
+@@ -19335,15 +19335,6 @@
+ for(i=NF; i>0; i--) { \
+ if ($i in fields) { } else { fields[$i]="."; out[i]=$i } \
+ } \
+- for(i=1; i<=NF; i++) { \
+- if (i in out) { printf("%s ", out[i]) } \
+- } \
+- print "" \
+- }'`
+- INCS=`echo ${INCS} | ${ac_cv_prog_AWK} '{ \
+- for(i=NF; i>0; i--) { \
+- if ($i in fields) { } else { fields[$i]="."; out[i]=$i } \
+- } \
+ for(i=1; i<=NF; i++) { \
+ if (i in out) { printf("%s ", out[i]) } \
+ } \
diff --git a/net-analyzer/ntop/files/ntop-5.0.1-includes.patch b/net-analyzer/ntop/files/ntop-5.0.1-includes.patch
new file mode 100644
index 000000000000..fcd5f28d3491
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-5.0.1-includes.patch
@@ -0,0 +1,20 @@
+--- a/nDPI/src/lib/protocols/netflow.c
++++ b/nDPI/src/lib/protocols/netflow.c
+@@ -19,6 +19,7 @@
+
+
+ #include "ipq_utils.h"
++#include <time.h> /* time() */
+
+ #ifdef NTOP_PROTOCOL_NETFLOW
+
+--- a/nDPI/src/lib/protocols/ssl.c
++++ b/nDPI/src/lib/protocols/ssl.c
+@@ -22,6 +22,7 @@
+
+
+ #include "ipq_utils.h"
++#include <ctype.h> /* isalpha() isdigit() ... */
+
+ #ifdef IPOQUE_PROTOCOL_SSL
+
diff --git a/net-analyzer/ntop/ntop-5.0.1-r1.ebuild b/net-analyzer/ntop/ntop-5.0.1-r1.ebuild
index 093757bd3e96..7411c5ad47f9 100644
--- a/net-analyzer/ntop/ntop-5.0.1-r1.ebuild
+++ b/net-analyzer/ntop/ntop-5.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-5.0.1-r1.ebuild,v 1.2 2014/07/15 17:45:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-5.0.1-r1.ebuild,v 1.3 2014/07/16 14:15:44 jer Exp $
EAPI=5
PYTHON_COMPAT=( python2_{6,7} )
@@ -51,9 +51,17 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-includes.patch
cp /usr/share/aclocal/libtool.m4 libtool.m4.in
cat acinclude.m4.in libtool.m4.in acinclude.m4.ntop > acinclude.m4
eautoreconf
+
+ # The build system is a complete mess, so apply a configure patch here
+ # instead of patching configure.in above
+ epatch "${FILESDIR}"/${P}-INCS.patch
+
+ # Stop make from doing autotools stuff
+ sed -i -e '/missing --run echo/s|=.*|= true|g' Makefile.in || die
}
src_configure() {